Project

General

Profile

Bug #1059

Fedora 19 connectivity diagnosis tools

Added by ajachimiak over 6 years ago. Updated over 5 years ago.

Status:
Assigned
Priority:
Normal
Assignee:
Category:
platform
Target version:
Start date:
08/01/2013
Due date:
% Done:

0%


Description

On a fresh Fedora 19 install essential commands like `ifconfig` and `dig` are not installed.

This is solved by ssh'ing in and running the following commands:

sudo yum install net-tools
sudo yum install bind-utils

Solutions:
(1) include the installation of thee utilities into the Amahi install script
(2) Create a free app that installs these after installation.

I think choice 2 might cause some difficulty. I think the connectivity issues that need to solved with these tools are usually encountered after installation, not after a time period of successful usage.

History

#1 Updated by cpg over 6 years ago

  • Description updated (diff)

#2 Updated by cpg over 6 years ago

True and a a good idea.

We struggled to get the size of the express disc down. We still ended up with extras that are hard to remove due to dependencies. So I think it's not great to have them in the disc.

Now, you have to have connectivity to install these tools, so an app is a possibility. It should be easy to add, since it's just some packages.

#3 Updated by bigfoot65 over 6 years ago

I think an app is a good idea. Pretty simple, maybe one app for each?

#4 Updated by ajachimiak over 6 years ago

bigfoot65 wrote:

I think an app is a good idea. Pretty simple, maybe one app for each?

I was thinking "HDA connection Diagnosis Tools" that adds all of the functionality needed to diagnose an HDA remotely.

My line of thinking here is to get enough tools onboard to make the Interactive Troubleshooter (at amahi.net) functional.

As it stands, it is outdated (references to deprecated nslookup) and non-functional for Fedora because of the missing commands on the HDA.

I can update the Interactive Troubleshooter to instruct the user to install an app, but I would rather it be one app that installs all of the needed tools at once.

#5 Updated by ajachimiak over 6 years ago

FYI: Here is what each package installs:

Net Tools (link)
  • arp(8)
  • hostname(1)
  • ifconfig(8)
  • ipmaddr
  • iptunnel
  • mii-tool(8)
  • nameif(8)
  • netstat(8)
  • plipconfig(8)
  • rarp(8)
  • route(8)
  • slattach(8)
Bind Utils (link)
  • /usr/bin/dig
  • /usr/bin/host
  • /usr/bin/nslookup
  • /usr/bin/nsupdate

#6 Updated by ajachimiak over 6 years ago

New app submitted.
Title: HDA Troubleshooting Tools

I added the packages net-tools and bind-utils as rpm dependencies and left most of the other fields blank.

Let me know if there are corrections that need to be made.

===
FYI: I still feel that these should be installed without the user clicking through the app installer... Maybe at the same time that the platform fetches info after receiving the Install code? I think there are some scripts run after the configuration is received. Would adding:

yum install -y net-tools bind-utils

break anything? Perhaps if it fails, just skip that step and add a note to the logs...
--Just my two cents. :-)

#7 Updated by bigfoot65 almost 6 years ago

  • Status changed from New to Closed

HDA Troubleshooting Tools app resolved this issue.
http://www.amahi.org/apps/hda-troubleshooting-tools

#8 Updated by bigfoot65 over 5 years ago

  • Status changed from Closed to Assigned
  • Assignee set to cpg
  • Target version set to amahi-7-3

We need to add the following packages to the default Amahi install:

net-tools bind-utils

Although there is an app to install them, they need to be available on initial install of Amahi. If a user is having network issues, they cannot install the app.

Seems best to just add them to the install script and remove the app.

Also available in: Atom