Project

General

Profile

Bug #1068

Amahi-netboot

Added by mattman about 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
08/05/2013
Due date:
% Done:

0%


Description

After install Amahi-netboot on Amahi 7, tftp service will not start and give this error.

tftp.service - Tftp Server

Loaded: loaded (/usr/lib/systemd/system/tftp.service; static)
Active: failed (Result: resources)
Aug 05 20:38:42 localhost.localdomain systemd[1]: Starting Tftp Server...
Aug 05 20:38:42 localhost.localdomain systemd[1]: tftp.service failed to run 'start' task: Invalid argument
Aug 05 20:38:42 localhost.localdomain systemd[1]: Failed to start Tftp Server.
Aug 05 20:50:54 localhost.localdomain systemd[1]: Stopped Tftp Server.

If you start the tftp.socket manually tftp service will start with not errors.

I still have not managed to load my test virtual PC into the PXE server so I'm still working on this.

History

#1 Updated by bigfoot65 about 7 years ago

  • Target version set to amahi-7-0

#2 Updated by damonq about 7 years ago

  • Assignee set to cpg

Can confirm,
amahi-app-installer.log

======= app install begin @ 2013-08-07 19:54:45 -0400 ==========
Installing app id kldmhcgaux under /var/hda/platform/html ENV=production
App: Amahi Netboot installed ======= app install end @ 2013-08-07 19:54:54 -0400 ==========

Checked cpg's netboot github https://github.com/amahi/netboot/blob/master/amahi-netboot.spec

1.
Install path /var/lib/tftpboot/
Contents empty post-install

2.
/etc/dnsmasq.d/amahi-pxe.conf #not created
3
/etc/xinetd.d/tftp disabled = yes

Temp workaround
1. Copy previous netboot files to /var/lib/tftpboot/

2. /etc/xinetd.d/tftp changed line disabled =no :Edit Sorry typo

3. Create amahi-pxe.conf in /etc/dnsmasq.d/
With contents:
dhcp-boot=pxelinux.0,hda,192.168.X.XX #insert hda IP
enable-tftp
tftp-root=/var/lib/tftpboot

#3 Updated by mattman about 7 years ago

Thanks cpg workaround did work but I needed to change one path.

2. /etc/xinet.d/tftp changed line disabled =no

my install I needed to use

/etc/xinetd.d/tftp

I think that the Fedora documentation is incorrect as this to documents the path as '/etc/xinet.d/tftp'

thanks again for the work around.

#4 Updated by damonq about 7 years ago

Have built an updated rpm package with ERPXE, possibly as a replacement to netboot. http://erpxe.org/Category:Plugins

They have over a hundred plugins, But no web-interface like cobbler or one click-kick.

Have successfully installed it on Amahi 7 with rpm package. Needs some more testing but it looks extremely promising .

https://github.com/damonq/netboot-plus

#5 Updated by cpg over 6 years ago

  • Status changed from New to Assigned
  • Priority changed from Normal to High

#6 Updated by cpg over 6 years ago

  • Assignee changed from cpg to bigfoot65

ok, created alpha.amahi.org/tmp/amahi-netboot-0.3-1.noarch.rpm
with the suggested changes (why not do a pull request??)

can someone test it before we commit it to the repo?

#7 Updated by bigfoot65 over 6 years ago

Testing now. One suggestion is to remove the PBA lines from /var/lib/tftboot/pxelinux.cfg/default file.

#8 Updated by mattman over 6 years ago

  • Assignee changed from bigfoot65 to cpg

After installing, there are no files in /usr/share/amahi-netboot/tftp as per the 'Netboot for Noobs Tutorial 2'.

#9 Updated by mattman over 6 years ago

Sorry, I have tried to update but I still pulling down this version 'amahi-netboot-0.2-1.noarch'

#10 Updated by bigfoot65 over 6 years ago

  • Assignee changed from cpg to bigfoot65

I see two things that need changed with the files mentioned above.

One is in /etc/dnsmasq.d/amahi-pxe.conf, the HDA IP should appear here:
dhcp-boot=pxelinux.0,hda,HDA IP

The line currently looks like this:
dhcp-boot=pxelinux.0,hda,

In etc/xinetd.d/tftp, the line disable should be changed from yes to no.

It currently looks like this:
disable = yes

Lastly, the entire structure looks different than the current amahi-netboot in the repo. The files were located in /var/lib/tftboot and now they are in /tftboot. I also see extra files in the directories that were not there before.

#11 Updated by bigfoot65 over 6 years ago

Please disregard the directory comments by mattman.

Those are not for Fedora 19. The structure I mentioned is what's being used based on the current F19 repo amahi-netboot.

#12 Updated by cpg over 6 years ago

bigfoot65 wrote:

Testing now. One suggestion is to remove the PBA lines from /var/lib/tftboot/pxelinux.cfg/default file.

there are no references to PBA. the new tftpboot files are in /tftpboot and there are no references to PBA, near as i can see.
you are looking at the old files.

what if remove the last comma in the conf file. will that work without an IP address?

dhcp-boot=pxelinux.0,hda

what exactly is breaking with this rpm (and removing the last comma).

#13 Updated by bigfoot65 over 6 years ago

Sorry, the path has changed from the previous version so that threw me off. There are also additional files in pxelinux.cfg that weren't there before. Previously all that was there was default.

I will try to test without the IP address and see if that works.

#14 Updated by bigfoot65 over 6 years ago

I am guessing this has changes that were made by damonq possibly. The files are completely different than the previous RPM.

I am trying to test now.

#15 Updated by bigfoot65 over 6 years ago

Ok, appears to boot without IP address. In etc/xinetd.d/tftp, the line disable should be changed from yes to no.

This is way more complicated than the previous netboot version. There are lots of menus and options. May take me a while to figure out how to update Clonezilla and other apps to work with it.

I kinda liked the old version as it was simple. This does not work easily out of the box. Many built in options do not appear to work. For example running mem test. There are menus all over the place.

#16 Updated by cpg over 6 years ago

new try, removing all the new fancy things in that ERPXE tftp directory ...

alpha.amahi.org/tmp/amahi-netboot-0.5-1.noarch.rpm

#17 Updated by bigfoot65 over 6 years ago

  • Assignee changed from bigfoot65 to cpg

Did a quick install, but not tested yet using a client to boot. All the changes needed are in place.

There is a spacing issue with:

disable = no

should look like:

disable = no

to align with the others, but that is not important. Just wanted to mention it in case it mattered to you. Does not to me as it should work either way :)

I will test it operationally tomorrow with my production HDA. I am confident it will work, but it needs to be validated.

#18 Updated by mattman over 6 years ago

  • Status changed from Assigned to Feedback

Hi
I have install the latest alpha release and I can confirm that is it working on my VM test client from my Amahi 7 with Fedora 19, if I have time I will try a laptop as a client.
As there is only MemTest+ in the options I will now try to add some more programs that can load for PXE.
But as far as I can tell this new version is working.

#19 Updated by bigfoot65 over 6 years ago

  • Status changed from Feedback to Resolved

This version works perfectly! I have tested with Clonezilla and no issues. Client boots to menu and apps work as designed.

Recommend we close this bug.

#20 Updated by cpg over 6 years ago

  • Status changed from Resolved to Closed

amahi-netboot-0.5-1.noarch.rpm has been pushed to the f19 repo. thanks for the feedback. closing.

Also available in: Atom