Project

General

Profile

Bug #1083

Gallery2 fails with an error in main.php

Added by dano5 almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Apps
Target version:
Start date:
08/12/2013
Due date:
% Done:

100%


Description

After installing Gallery 2 on a freshly installed Amahi7 the app works, but if you click the app link it goes to http://gallery2/main.php which doesn't work & gives a error page.
Instead of in my case going to http://gallery2.lastboks.net/main.php as it should.
Same happens when trying to log into the app after manually fixing the URL and quite a few of the links in the app.

This was tested on Windows 8 with latest Chrome, Opera & Firefox.

History

#1 Updated by cpg almost 9 years ago

  • Subject changed from A7 - Gallery2 to Gallery2 fails with an error in main.php

#2 Updated by bigfoot65 almost 9 years ago

I cannot reproduce this error. I installed and clicked the link, which then wen to http://gallery2/main.php no problem. I messed around in the app and had no issues.

This could be a DNS issue on your end. I will analyze further, but until I can reproduce it not much to go on. BTW, not all apps will direct to your domain.

#3 Updated by bigfoot65 almost 9 years ago

  • Status changed from New to Feedback

I did find a line in the config.php file for the app that had the link hard coded. I commented it out to enable autoconfig of the URL. Tested it and the domain is now added to the URL.

To fix it on your install, edit /var/hda/web-apps/gallery2/html/config.php and add a # to the beginning of the next to last line:

$gallery->setConfig('baseUri', 'http://gallery2/main.php');

Please report back if this resolves your problem.

#4 Updated by dano5 almost 9 years ago

  • % Done changed from 0 to 100

this works and the proposed fix has also been added to the app already, so no longer an issue.

#5 Updated by achmetinternet over 8 years ago

Could this be related to this bug?

https://bugs.amahi.org/issues/1139

#6 Updated by bigfoot65 over 8 years ago

  • Status changed from Feedback to Closed

This was confirmed as fixed.

Also available in: Atom