Project

General

Profile

Bug #1084

Transmission won't automatically load torrents files

Added by kikkegek almost 8 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Apps
Target version:
Start date:
08/13/2013
Due date:
% Done:

0%


Description

I installed the Transmission app through the one-click-proces.

transmission app works fine and web-gui is accesible.

followed the wiki completely
[[https://wiki.amahi.org/index.php/Transmission]]

then tried to make it automatically load torrents, but it wont.

the cronjob is run, but the torent is not loaded.

when I run the transmission-remote command from the commandline in debugmode the output it this:

[jochen@localhost FILMS]$ transmission-remote localhost:9091 --auth transmission:torrent -a /var/hda/files/torrents/*.torrent -b

posting:
-------- {"arguments":{"metainfo":"lv0........................iduAFd38mKl40VlrplKwhMaQQwesvro1fuPda7QMluIkEXQKD+N/9ODPhZIn4/22oxhSoiwDrsPtcy8Pv3SkCp6Et1YBlZQ=="},"method":"torrent-add","tag": 8}


  • Couldn't find host localhost in the .netrc file; using defaults
  • About to connect() to localhost port 9091 (#0)
  • Trying ::1...
  • Connected to localhost (::1) port 9091 (#0)

POST /transmission/rpc/ HTTP/1.1

User-Agent: transmission-remote/2.80 (14103)
Host: localhost:9091
Accept: */*
Accept-Encoding: deflate, gzip
Content-Length: 26841
Content-Type: application/x-www-form-urlencoded
Expect: 100-continue

  • Done waiting for 100-continue
  • Connection #0 to host localhost left intact
    Çë{w³ÈSted response: n<ùu©QrÝÇ͸2VòLb>bñçUÈ

History

#1 Updated by cpg almost 8 years ago

  • Subject changed from AMAHI7 - Transmission wont automatically load torrents files to Transmission won't automatically load torrents files
  • Description updated (diff)

#2 Updated by bigfoot65 almost 8 years ago

  • Status changed from New to Feedback

Did you make the user name and password match the previous step? Also did you remove the []? It should look like this if I understand the wiki correctly.

?*/5 * * * * transmission transmission-remote localhost:9091 --auth username:password -a /var/hda/files/torrents/*.torrent && rm -f /var/hda/files/torrents/*.torrent

If you copied this straight from the wiki, be careful of hidden characters. Sometimes one is attached to the copy & paste at the beginning or end of a line. Best way to find them is delete the first and character, then reenter it. Backspace on the last character and reenter it as well.

I have seen these really cause a lot of time and trouble diagnosing for something that takes 10 seconds to prevent.

#3 Updated by kikkegek almost 8 years ago

yes, I did. The cronjob was already there. I didnt have to copy anything. I only had to add the username and password to the settings.json file.

#4 Updated by bigfoot65 almost 8 years ago

Thanks for the clarification. Not sure what is going on, but we will investigate when time permits.

#5 Updated by achmetinternet almost 8 years ago

Same issue here. Made the entries in settings.json and also set the permission of my watch folder to 775.

#6 Updated by kikkegek over 7 years ago

any updates Bigfoot65?

#7 Updated by bigfoot65 over 7 years ago

Is this still an issue? This one has not made it to the top of the pile yet.

#8 Updated by bigfoot65 over 7 years ago

  • Assignee set to kikkegek

Please see https://bugs.amahi.org/issues/1348 for a potential solution.

#9 Updated by bigfoot65 over 7 years ago

Also I incorrectly told you to follow the wiki for the /etc/cron.d/amahi-transmission. It should not match the wiki.

If you uninstall and reinstall the app, it will put it back to normal. Now that the missing dependency was added, this may work as designed.

Please report back. If we do not hear anything, the bug will be closed.

#10 Updated by kikkegek over 7 years ago

uninstalled the app. rebooted. Installaed the app again.

cant access web interface.

checked the status of the transmission service:

[jochen@localhost ~]$ sudo systemctl status amahi-transmission.service
[sudo] password for jochen:
amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
Active: active (running) since do 2014-04-24 09:39:34 CEST; 21s ago
Process: 1171 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=0/SUCCESS)
CGroup: name=systemd:/system/amahi-transmission.service
??1185 /usr/bin/transmission-daemon -w /var/hda/files/drives/drive2/torrents

apr 24 09:39:33 localhost.localdomain systemd1: Starting SYSV: This is a daemon which runs on the server to download torrents...
apr 24 09:39:34 localhost.localdomain amahi-transmission1171: /etc/rc.d/init.d/amahi-transmission: line 34: [: =: unary operator expected
apr 24 09:39:34 localhost.localdomain amahi-transmission1171: gzip: level1.gz: unexpected end of file
apr 24 09:39:34 localhost.localdomain amahi-transmission1171: chown: cannot access ‘level1’: No such file or directory
apr 24 09:39:34 localhost.localdomain runuser1182: pam_unix(runuser:session): session opened for user transmission by (uid=0)
apr 24 09:39:34 localhost.localdomain systemd1: Started SYSV: This is a daemon which runs on the server to download torrents.
apr 24 09:39:35 localhost.localdomain transmission-daemon1185: Couldn't bind port 9091 on 0.0.0.0: Address already in use (Is another copy of Transmission already running?) (net.c:371)
apr 24 09:39:35 localhost.localdomain transmission-daemon1185: UDP Failed to set receive buffer: requested 4194304, got 425984 (tr-udp.c:78)
apr 24 09:39:35 localhost.localdomain transmission-daemon1185: UDP Failed to set send buffer: requested 1048576, got 425984 (tr-udp.c:89)

please help.

#11 Updated by bigfoot65 over 7 years ago

Reboot again as it appears the port is locked. If that doesn't work we will have to dig deeper.

#12 Updated by kikkegek over 7 years ago

rebooted. checked the messages log. but port is still blocked

#less /var/log/messages | grep transmission

Apr 24 17:20:21 localhost transmission-daemon1185: Closing session
Apr 24 17:21:23 localhost amahi-transmission1171: /etc/rc.d/init.d/amahi-transmission: line 34: [: =: unary operator expected
Apr 24 17:21:23 localhost amahi-transmission1171: gzip: level1.gz: unexpected end of file
Apr 24 17:21:23 localhost amahi-transmission1171: chown: cannot access ‘level1’: No such file or directory
Apr 24 17:21:23 localhost amahi-transmission1171: Starting Transmission daemon... [ OK ]#015[ OK ]
Apr 24 17:21:24 localhost transmission-daemon1185: Couldn't bind port 9091 on 0.0.0.0: Address already in use (Is another copy of Transmission already running?) (net.c:371)
Apr 24 17:21:24 localhost transmission-daemon1185: UDP Failed to set receive buffer: requested 4194304, got 425984 (tr-udp.c:78)
Apr 24 17:21:24 localhost transmission-daemon1185: UDP Failed to set send buffer: requested 1048576, got 425984 (tr-udp.c:89)

#13 Updated by kikkegek over 7 years ago

[jochen@localhost ~]$ sudo nmap -sT -O localhost

Starting Nmap 6.40 ( http://nmap.org ) at 2014-04-24 17:27 CEST
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00036s latency).
Other addresses for localhost (not scanned): 127.0.0.1
Not shown: 990 closed ports
PORT STATE SERVICE
22/tcp open ssh
25/tcp open smtp
53/tcp open domain
80/tcp open http
139/tcp open netbios-ssn
445/tcp open microsoft-ds
3306/tcp open mysql
8081/tcp open blackice-icecap
8200/tcp open trivnet1
9091/tcp open xmltec-xmlmail
Device type: general purpose
Running: Linux 3.X
OS CPE: cpe:/o:linux:linux_kernel:3
OS details: Linux 3.7 - 3.9
Network Distance: 0 hops

OS detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 4.12 seconds

#14 Updated by bigfoot65 over 7 years ago

Not sure what that means. Wonder if when you installed the app, it left pieces behind. Might need to uninstall, then ensure amahi-transmission is completely gone. Check for *.rpmsave files as well.

Then if it's clean, reboot and try installing again. I don't know what else would cause the issue.

I guess you could also change the port to something different and try that too. There are a few places that you would need to make the change.

#15 Updated by kikkegek over 7 years ago

hi Bigfoot65

service xml-tec=xmlmail is currently using port 9091 and I have searched the web, but cant find the purpose of it, nor why it would have been installed under Amahi of Fedora.

I have tried changing the port of transmission-daemon, stopping the service and making sure I kill all transmission services. then editing as SU the settings/json file...but when I restart the service it still uses 9091 as port and the settings.json file seems unchanged. I know the cronjob also has a port in the commandline, changed that also, and that file is not changed back. I have absolutely no clue why the settings are not saved when I change the settings.json file.

I search the whole HDA for another instance of the settings.json file, but can only find it in:
/var/lib/transmission/.config/transmission-daemon/settings.json

could you help me out how I would search and clean my HDA for transmission left-overs after uninstalling? that would really help a lot.

#16 Updated by bigfoot65 about 7 years ago

Before you uninstall the app, do this as root user:
rpm -ql amahi-transmission

That will tell you all the files installed. Make a note of them, then uninstall the app.

Once finished, check the file list to ensure everything is removed.

#17 Updated by bigfoot65 about 7 years ago

I have updated the app and I believe we have a solution that works. Please uninstall and reinstall the app.

Please let us know if it works.

#18 Updated by kikkegek about 7 years ago

YES TOUCHDOWN!

torrent files are now automatically added to the que and renamed to torrentfilename.added

it will still need some tweaking to get it working when you are not using the default folders like me.

I have three drives in my HDA and my LZ is at /var/hda/files/drives/drive2/ so my torrent folder was manually relocated after installation by me to /var/hda/files/drives/drive2/torrents/

you might want to add that info to the wiki.

I changed it in the:
/var/lib/transmission/.config/transmission-daemon/settings.json

and in the watch script
/usr/share/transmission/torrentwatch.sh

thanks guys...you really pulled through!!!! super support again by the AMAHI TEAM!

#19 Updated by bigfoot65 about 7 years ago

  • Status changed from Feedback to Closed

Glad it worked for you. Please feel free to update the wiki.

Also available in: Atom