Project

General

Profile

Bug #1178

Fedora 21 platform test install

Added by trw3937 almost 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
hda-install
Target version:
-
Start date:
11/26/2013
Due date:
% Done:

0%


Description

I installed the Fed 20 beta2 32 bit into a vm using the minimal headless setup. I ran yum update and followed the wiki instructions for F19 32 bit. I followed this page : https://wiki.amahi.org/index.php/Amahi_7_full_DVD

and all the dependencies for this step yum -y install hda-ctl hda-platform seem to be met except yum errors with ruby-mysql package missing. Otherwise it could work. I am not sure if F20 paths have changed from F19 though.

I'll post back when the ruby-mysql pkg is available.

Archetech

Amahi8.PNG View (121 KB) bigfoot65, 03/08/2015 06:07 PM

History

#1 Updated by bigfoot65 almost 7 years ago

  • Priority changed from Normal to Low

Thanks for the info.

Have not heard plans to move to Fedora 20. We still have work to do on Fedora 19, so not sure this is in our future task list. We typically skip a release with Amahi unless it's a simple transition, which it never is in past experience.

If you would like to continue testing, that's up to you but it may be all for nothing.

#2 Updated by bigfoot65 almost 7 years ago

Requested clarification from our lead developer. More to follow.

#3 Updated by cpg almost 7 years ago

thanks for reporting. this is useful to know when we start working our way into new distro updates.

it seems like the march to rename mysql stuff into mariadb stuff continues.
the ruby-mysql may be a glitch in the process.

#4 Updated by cpg over 6 years ago

providing the output of in a pastie (not here, it's probably way too long!),

yum list all

would help identify what is going on on f20, package-wise.

the team does not have an f20 machine to test on at the moment.

#5 Updated by bigfoot65 over 6 years ago

FYI...I just tried to upgrade to Fedora 20. It broke Ruby badly. This is what I anticipated, so did not spend much time on looking at it.

#6 Updated by cpg almost 6 years ago

  • Subject changed from Fedora 20 platform test install to Fedora 21 platform test install
  • Status changed from New to Assigned
  • Assignee set to cpg

looks like the same applies to f21, according to archetech.

#7 Updated by bigfoot65 almost 6 years ago

Tested install of hda-ctl-5.4.2-1.x86_64.rpm and hda-platform-7.4.0-1.x86_64.rpm on a minimal install Fedora 21 system.

Installed dependencies manually as follows:
bc bind-utils cadaver fpaste httpd mariadb-server monit perl-libwww-perl php php-mysqlnd pmount rsync ruby-augeas ruby-libs ruby-mysql samba perl-Authen-PAM perl-LWP-Protocol-https perl-URI ruby rubygem-bundler rubygem-ruby-dbus bzip2 hddtemp mlocate patch mod_passenger rubygem-passenger rubygem-passenger-native tar unzip v8 wol

There are 3 outstanding dependency issues that prevent the successful install of the hda-ctl and hda-platform:

A. amahi-anywhere (need Fedora 21 version)
B. ruby 2.0.0 (only 2.1.5 is available in Fedora 21)
C. ruby-mysql (this is now rubygem-mysql2 potentially https://github.com/brianmario/mysql2)

I did not install the amahi repo as there is not one for Fedora 21 that I am aware.

#8 Updated by cpg almost 6 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from cpg to bigfoot65
  • Priority changed from Low to Normal

great.

ok, i think i fix all three deps.
i regenerated the rpms without changing the version number.

(i'd like to do that for now; if you'd like me to change version numbers for the rpms in the future please let me know explicitly)

#9 Updated by bigfoot65 almost 6 years ago

  • Assignee changed from bigfoot65 to cpg

Ok, both are now installed. Should I proceed to try the hda-install?

BTW I am find with the version numbers not changing.

#10 Updated by cpg almost 6 years ago

ok, snapshot, do a test install. report, we can fix and try reinstalling.

#11 Updated by bigfoot65 almost 6 years ago

Have not done the snapshot yet, but hda-install failed.
/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- mysql (LoadError)
from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/bin/hda-install:25:in `<main>'

I have an feeling all the references to mysql will need to be changed to accommodate the new rubygem-mysql2 usage. The web page I provided in the bug reflects the syntax I believe.

Should I still create a snapshot?

#12 Updated by cpg almost 6 years ago

  • Assignee changed from cpg to bigfoot65

ok, updated rpms have been created. hda-platform is the same version, however, hda-ctl has been bumped hda-ctl-5.5.0-1.x86_64.rpm

may want to revert to a clean state before this new test install.

#13 Updated by cpg almost 6 years ago

  • Assignee changed from bigfoot65 to cpg

The install went well after a more accurate setting of the IP addresses, etc.

The web interface for the platform shows:

You have already activated rake 10.1.0, but your Gemfile requires rake 10.3.2

#14 Updated by cpg almost 6 years ago

after working-around this rake issue, the dashboard is showing on the machine and it appears most things are there!

apps, of course, are not going to work yet.

#15 Updated by cpg almost 6 years ago

  • Assignee changed from cpg to bigfoot65

do we have a checklist for testing the platform details? i only tested advanced settings, but not languages, network aliases, etc. etc.
(if not, we should make one)

please test as much as possible (no apps)

#16 Updated by bigfoot65 almost 6 years ago

I will test in a few hours using this checklist: #1386

#17 Updated by bigfoot65 almost 6 years ago

  • Assignee changed from bigfoot65 to cpg

I have completed the initial test of the dashboard functionality. Most everything works as designed. I have a few comments for the areas indicated below:

1. Shares: Reset permissions does chmod 777 vs 775 as default. It does not change ownership, only the folder permissions. Not sure if this is recursive as I did not check.

Just a general comment that when you delete empty shares, it removes directory. When there are files present, it does not. This is probably by design, but worth mentioning.

2. Disks: Virtual disks do not show up in the devices area. They do show in partitions.

3. Settings, Servers: Start on boot not disabled when unchecked. I did this with Samba and on reboot it restarted.

As mentioned, everything else appears to work correctly.

#18 Updated by trw3937 almost 6 years ago

Hey Hey its F21-AM8 finally! I skillfully wget'ed the hda-ctl/hda=platform rpm's from cpg and installed into a F21 server min install vm on vbox 4.3.20.

Testing so far but no apps are possible yet per cpg. I tried to install a cms web app but it would not fire up in a browser. Got the apache test page. Probably my amahi web app skills are rusty or its just not ready.

Client PC gets a dhcp ip lease from AM8 and shares are accessible with a simple login as my admin user.
Web UI comes up on client w/o issue and all tabs seem ok. Server journalctl -b and -xn look clean so basic services are working right.

So time to roll some new rpm's when a web app or 3 are ready to test.

Thanks guys. Fun to see some action on this...

Archetech

#19 Updated by cpg over 5 years ago

we have an (untested as of yet) f21 rpm repo for x86_64.

f21.amahi.org

#20 Updated by cpg over 5 years ago

  • Status changed from Feedback to Assigned

The first iso of Amahi 8/F21 built ok, somehow. The error is that It has issues finding amahi.ks, the kickstart file.

http://dl.dropbox.com/u/364883/Screenshots/a_n0.png

#21 Updated by bigfoot65 over 5 years ago

Did a quick test and the attached screenshot is what I encountered.

I went to each item and selected the defaults. However for software, there was nothing listed for me.

I did a complete install and it worked, except I never got prompted for the HDA code nor did it appear Amahi installed. I did try hda-install CODE and the command was not found.

#22 Updated by cpg over 5 years ago

thanks for the update. some hook somewhere failed.

#23 Updated by cpg over 5 years ago

thins that would be useful to test from this image:

1) install (with the issues you reported)
2) login as root on the clean install and run: rpm -qa > rpm.list .... then fpaste that and report the url here
3) proceed as if this were the full-dvd method of installing amahi (changing all pertinent urls to f21). report any missing deps or errors
4) if possible, after installing hda-ctl and hda-platform, try hda-install and report any errors here (the install log would be good too, in private)

#24 Updated by bigfoot65 over 5 years ago

- Installed Express DVD. Still had same errors on initial setup screen. Cleared them up and proceeded with install.
- I was not prompted for install code. Amahi did not appear to be installed after reboot.
- fpaste is not installed by default.
- rpm.lst http://ur1.ca/jvpgk
- no log files in /root
- Followed https://wiki.amahi.org/index.php/Amahi_7_full_DVD guidance, substituting f21 for f19
- Installed without errors
- Had to restart networking, but that could be a local issue as this is a VM.
- hda-install.log emailed to cpg.
- Installed phpSysInfo without error. Verified it works as designed.

#25 Updated by cpg over 5 years ago

closing this bug to prepare for an alpha release. the procedure for the alpha install will be soon at the Amahi Fedora 21 wiki page.

#26 Updated by cpg over 5 years ago

  • Status changed from Assigned to Closed

Also available in: Atom