Project

General

Profile

Bug #1209

DLNA App broken - Amahi 7.1 (Fedora 19)

Added by doaserver over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Medium
Assignee:
-
Category:
DLNA
Target version:
Start date:
12/14/2013
Due date:
% Done:

0%


Description

DLNA App broken

I have installed Amahi 7.1 with the Express CD (Fedora 19)
It is a fresh installation on a new hard drive.

Information:
System 3.10.5-201.fc19.x86_64 ,x86_64
Platform 7.1.1-1
Core 5.1.3-1

DLNA 1.0.26-2 (installed 2013-12-14)

When I install the DLNA App, it will not start the DLNA Server. The app-installerlog seems to be okay:

[root@localhost ~]# cat /var/log/amahi-app-installer.log ======= app install begin @ 2013-12-14 14:52:29 +0100 ==========
Installing app id ogiaus92x5 under /var/hda/platform/html ENV=production
Your HDA services have been restarted.
Your HDA services have been restarted.
Configuring Amahi settings
Reloading systemctl daemon
Enabling minidlna.service
ln -s '/usr/lib/systemd/system/minidlna.service' '/etc/systemd/system/multi-user.target.wants/minidlna.service'
Starting minidlna.service
App: DLNA installed ======= app install end @ 2013-12-14 14:55:43 +0100 ==========

But when I check the Webinterface I can see, that the server is not running. I can't start it by myself ("Start it" or "Restart").
Minidlna itself doesn't log anything. The directory is empty (/var/log/minidlna/)

Here are some other logs I think they may help to solve the Problem:

[root@localhost ~]# cat /var/log/monit.log | grep minidlna
[CET Dec 14 14:55:48] error : 'minidlna' process is not running
[CET Dec 14 14:55:48] info : 'minidlna' trying to restart
[CET Dec 14 14:55:48] info : 'minidlna' start: /usr/bin/systemctl
[CET Dec 14 14:56:18] error : 'minidlna' failed to start

----------------------------------------------------------------------------------------------------------------------------

This is very interesting: I noticed, that "plexmediaserver" has been installed but I have not do this by myself. My XBOX360 recognize this media server.

[root@localhost ~]# cat /var/log/yum.log
Dec 14 14:04:46 Updated: hda-platform-7.1.1-1.x86_64
Dec 14 14:04:47 Updated: hda-ctl-5.1.3-1.x86_64
Dec 14 14:04:50 Updated: hda-greyhole-0.9.35-1.x86_64
Dec 14 14:52:38 Installed: rpmfusion-free-release-19-1.noarch
Dec 14 14:52:47 Installed: rpmfusion-nonfree-release-19-1.noarch
Dec 14 14:53:00 Installed: lame-libs-3.99.5-2.fc19.x86_64
Dec 14 14:53:01 Installed: lame-3.99.5-2.fc19.x86_64
Dec 14 14:53:02 Installed: net-tools-2.0-0.15.20131119git.fc19.x86_64
Dec 14 14:55:37 Installed: plexmediaserver-0.9.8.14.263-139ddbc.x86_64
Dec 14 14:55:38 Installed: libid3tag-0.15.1b-15.fc19.x86_64
Dec 14 14:55:38 Installed: libexif-0.6.21-4.fc19.x86_64
Dec 14 14:55:39 Installed: minidlna-1.1.0-1.fc19.x86_64
Dec 14 15:26:45 Installed: nano-2.3.1-7.fc19.x86_64

----------------------------------------------------------------------------------------------------------------------------

[root@localhost ~]# cat /var/log/messages
Dec 14 15:53:16 localhost systemd1: Starting MiniDLNA is a DLNA/UPnP-AV server software...
Dec 14 15:53:16 localhost systemd1: Started MiniDLNA is a DLNA/UPnP-AV server software.
Dec 14 15:53:16 localhost systemd1: minidlna.service: main process exited, code=exited, status=127/n/a
Dec 14 15:53:16 localhost systemd1: Unit minidlna.service entered failed state.
Dec 14 15:53:16 localhost minidlnad2659: /usr/sbin/minidlnad: error while loading shared libraries: libavformat.so.54: cannot open shared object file: No such file or directory
Dec 14 15:54:46 localhost systemd1: Starting MiniDLNA is a DLNA/UPnP-AV server software...
Dec 14 15:54:46 localhost systemd1: Started MiniDLNA is a DLNA/UPnP-AV server software.
Dec 14 15:54:46 localhost minidlnad2702: /usr/sbin/minidlnad: error while loading shared libraries: libavformat.so.54: cannot open shared object file: No such file or directory
Dec 14 15:54:46 localhost systemd1: minidlna.service: main process exited, code=exited, status=127/n/a
Dec 14 15:54:46 localhost systemd1: Unit minidlna.service entered failed state.
Dec 14 15:56:16 localhost systemd1: Starting MiniDLNA is a DLNA/UPnP-AV server software...
Dec 14 15:56:16 localhost systemd1: Started MiniDLNA is a DLNA/UPnP-AV server software.
Dec 14 15:56:16 localhost systemd1: minidlna.service: main process exited, code=exited, status=127/n/a
Dec 14 15:56:16 localhost systemd1: Unit minidlna.service entered failed state.
Dec 14 15:56:16 localhost minidlnad2747: /usr/sbin/minidlnad: error while loading shared libraries: libavformat.so.54: cannot open shared object file: No such file or directory
Dec 14 15:57:46 localhost systemd1: Starting MiniDLNA is a DLNA/UPnP-AV server software...
Dec 14 15:57:46 localhost systemd1: Started MiniDLNA is a DLNA/UPnP-AV server software.
Dec 14 15:57:46 localhost minidlnad2786: /usr/sbin/minidlnad: error while loading shared libraries: libavformat.so.54: cannot open shared object file: No such file or directory
Dec 14 15:57:46 localhost systemd1: minidlna.service: main process exited, code=exited, status=127/n/a
Dec 14 15:57:46 localhost systemd1: Unit minidlna.service entered failed state.

History

#1 Updated by doaserver over 5 years ago

I have written with bigfoot65 yesterday, but his proposals for solution do not work for me.

https://forums.amahi.org/viewtopic.php?f=19&t=5053

#2 Updated by bigfoot65 over 5 years ago

Thanks for the update. We have noticed plexmediaserver and looking into why it's being installed.

Please do systemctl status minidlna.service and report the results. This should help us determine the issue.

#3 Updated by bigfoot65 over 5 years ago

  • Status changed from New to Feedback
  • Assignee changed from cpg to doaserver
  • Priority changed from High to Medium

#4 Updated by doaserver over 5 years ago

bigfoot65 wrote:

Thanks for the update. We have noticed plexmediaserver and looking into why it's being installed.

Please do systemctl status minidlna.service and report the results. This should help us determine the issue.

Here is the result from "systemctl status minidlna.service"

[root@localhost ~]# systemctl status minidlna.service
minidlna.service - MiniDLNA is a DLNA/UPnP-AV server software
   Loaded: loaded (/usr/lib/systemd/system/minidlna.service; enabled)
   Active: failed (Result: exit-code) since Sa 2013-12-14 17:07:15 CET; 6s ago
  Process: 947 ExecStart=/usr/sbin/minidlnad -S (code=exited, status=127)

Dez 14 17:07:15 localhost.localdomain systemd[1]: Starting MiniDLNA is a DLNA/UPnP-AV server software...
Dez 14 17:07:15 localhost.localdomain systemd[1]: Started MiniDLNA is a DLNA/UPnP-AV server software.
Dez 14 17:07:15 localhost.localdomain systemd[1]: minidlna.service: main process exited, code=exited, status=127/n/a
Dez 14 17:07:15 localhost.localdomain systemd[1]: Unit minidlna.service entered failed state.

Is there anything you have done manually to customize your HDA? If not, then we can rule that out now.

I have done a fresh installation this morning.
I have installed ethtool for 'wake on LAN' and wrote a script that enable it every time the system boot up. The command is stored in rc.local.
I have activated the script with the command 'systemctl start rc-local'

I changed the Path were minidlna searches for videos and commented out the lines for audio and images --> minidlna.conf

The changes you suggested are revoked (1000-minidlna.conf; minidlna.conf)!

No futher changes!

#5 Updated by bigfoot65 over 5 years ago

Ok, lt's try this. Uninstall DLNA. Then do yum erase plexmediaserver. Look to see what it wants to uninstall before saying Yes. If it's minidlna, that's ok. If there is more listed, please ensure it's not anything amahi specific or it may break your HDA. Then reinstall DLNA.

Don't do a yum update until I can find the syntax to exclude plesmediaserver from the updates. I think that is the cause of the problems. It should not be installed unless you install the app.

I have done this procedure on my machine and not had any issues. Please report back if it helps. We'll resolve this somehow.

#6 Updated by bigfoot65 over 5 years ago

The following will prevent plexmediaserver package from being installed when doing yum update. This is once DLNA has been uninstalled and the plexmediaserver package has been erased from your HDA.

1. Edit /etc/yum.repos.d/amahi.repo and add this to the bottom of the file:
exclude=plexmediaserver

2. Save it and then do yum clean all followed by yum update and you should not see any updates for plexmediaserver.

3. Reinstall DLNA and all should work fine.

This is a work around until we resolve bug # 1210, then no longer needed.
https://bugs.amahi.org/issues/1210

#7 Updated by doaserver over 5 years ago

  • Status changed from Feedback to Closed

Perfect!
That is the solution! :)

#8 Updated by bigfoot65 over 5 years ago

  • Status changed from Closed to Assigned

Reopened as issue still exists without the work around applied.

#9 Updated by bigfoot65 over 5 years ago

  • Assignee changed from doaserver to cpg

#10 Updated by bigfoot65 over 5 years ago

Notice that minidlna shows dependency on a lib found in plexmediaserver package:

http://paste.fedoraproject.org/64719/82560611/

I think you may have already discovered this in the other bug, but wanted to ensure it was captured. Now to disassociate it somehow :)

#11 Updated by bigfoot65 about 5 years ago

Recommend we remove plexmediaserver package from Amahi repo. Bug will be closed once complete.

See bug 1210:
https://bugs.amahi.org/issues/1210

#12 Updated by bigfoot65 about 5 years ago

  • Status changed from Assigned to Closed
  • Assignee deleted (cpg)

No longer needed.

Also available in: Atom