Project

General

Profile

Bug #1213

Cannot turn off DNS Server - Amahi 7.1 (Fedora 19)

Added by doaserver almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
DNS
Target version:
Start date:
12/16/2013
Due date:
% Done:

0%


Description

System 3.10.5-201.fc19.x86_64 ,x86_64
Platform 7.1.1-1
Core 5.1.3-1

Today I tried to turn off the DNS Server permanently.

I followed the Instruction from here:
https://wiki.amahi.org/index.php/Turning_off_DNS

But everytime I reboot the system, the DNS Server is running again.

History

#1 Updated by bigfoot65 almost 8 years ago

  • Status changed from New to Feedback
  • Assignee changed from bigfoot65 to doaserver

Not sure it can be easily turned off. The guidance you referenced I do not believe is specific to Fedora 19. Will have to do some research to find out why it does not turn off. My guess would be that Monit is restarting it or it's set to start on boot.

Is there a reason you want it off? Without the DNS server on the HDA, it will not properly resolve URLs for apps.

If you don't want to use the HDA DNS for your client, then point the client to a different DNS server. I believe you can also change the DNS provider in Amahi 7 as well, if you prefer a different one than OpenDNS.

#2 Updated by doaserver almost 8 years ago

I installed the system as a DLNA Server and network drive. I don't want to use other apps.
The Server will only run if he's needed. The rest of the time he is waiting for magic packets to wake up (WOL).

The moment I shutdown the system the router don't recognize that there is no DNS server in the local network anymore and therefore the router don't take over hda's job. You can imagine the nasty result...

When I point the clients to a different DNS server I have to configure this in the DHCP Server or have to use static IP, am I right?

#3 Updated by bigfoot65 almost 8 years ago

If that is the case, then why not use DHCP and DNS from your router? Then turn off DHCP on HDA and leave DNS alone. As long as router is handling DHCP and DNS, it will not see the HDA DNS.

You should be able to access shares and DLNA via IP address. That should eliminate your problem.

#4 Updated by doaserver almost 8 years ago

Good idea, but I can't turn off the DHCP either!
The DHCP Server is not listed under the 'Server' Tab. It was never there.

#5 Updated by bigfoot65 almost 8 years ago

It's under Settings in the Network tab, providing you have Advanced Settings enabled. I believe that is where you can change DNS or turn it off as well. The server's tab is meant to show status.

#6 Updated by doaserver almost 8 years ago

It seems to solve my problem.
Never the less the bug is there.

#7 Updated by bigfoot65 almost 8 years ago

Did you see an option to uncheck DNS in the Network tab, Settings?

Also you would never want to turn off DNS on the HDA, but remember you don't have to use it for clients. It is needed for apps to resolve locally on the HDA.

#8 Updated by bigfoot65 almost 8 years ago

There is no issue here. The Settings option in the Networks tab allows disabling of the DNS. The Servers tab shows it as running, but that is due to it sharing the same service as DHCP.

This is not really a bug, but by design. Closing as no further action required.

#9 Updated by bigfoot65 almost 8 years ago

  • Status changed from Feedback to Closed
  • Assignee deleted (doaserver)

Also available in: Atom