Project

General

Profile

Bug #1231

httpd service stops working

Added by jonathankonrad almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
12/22/2013
Due date:
% Done:

0%


Description

I installed Amahi 7.1 using the express CD. After rebooting twice, then initializing all appeared right. Installed Transmission app. OK. Installed Linfo app. Noticed that when clicking on the app in the home screen it returned me to the dashboard instead of taking to the app. After a few reboots trying to find out what was wrong and testing if it was a DNS issue, the dashboard became unavailable. Now, when this is run at the command line on the HDA:

service httpd status

This is the result:

Redirecting to /bin/systemctl status httpd.service
httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
Active: failed (Result: exit-code) since Sun 2013-12-22 19:30:47 MST; 48s ago
Process: 2523 ExecStop=/usr/sbin/httpd $OPTIONS -k graceful-stop (code=exited, status=1/FAILURE)
Process: 2521 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)

Dec 22 19:30:47 localhost.localdomain httpd2521: httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/c...reference
Dec 22 19:30:47 localhost.localdomain systemd1: httpd.service: main process exited, code=exited, status=1/FAILURE
Dec 22 19:30:47 localhost.localdomain httpd2523: httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/c...reference
Dec 22 19:30:47 localhost.localdomain systemd1: httpd.service: control process exited, code=exited status=1
Dec 22 19:30:47 localhost.localdomain systemd1: Failed to start The Apache HTTP Server.
Dec 22 19:30:47 localhost.localdomain systemd1: Unit httpd.service entered failed state.

Hardware is a Virualized machine running in Xenserver 6.2. The VM has 4GB RAM and 2 CPU cores. The base hardware is an i5 4570 cpu on an ASUS board with 8 GBs of DDR3 Ram and a single 3TB 7200 RPM SATA III drive.

History

#1 Updated by cpg almost 7 years ago

  • Category deleted (hda-install)
  • Status changed from New to Assigned
  • Assignee set to cpg

we have not gotten to the bottom of why this is happening.

however, the current best known workaround (which invalidates further debug in the system to get to the bottom of it) is:

yum -y update openssl

#2 Updated by jonathankonrad almost 7 years ago

That fixed my issue. The dashboard loads properly now. There might still be some errors in my install but this is what I get when I run: service httpd status

Redirecting to /bin/systemctl status httpd.service
httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
Active: active (running) since Sun 2013-12-22 20:17:57 MST; 10min ago
Process: 1405 ExecReload=/usr/sbin/httpd $OPTIONS -k graceful (code=exited, status=0/SUCCESS)
Main PID: 506 (httpd)
Status: "Total requests: 0; Current requests/sec: 0; Current traffic: 0 B/sec"
CGroup: name=systemd:/system/httpd.service
?? 506 /usr/sbin/httpd -DFOREGROUND
??1410 PassengerWatchdog
??1413 PassengerHelperAgent
??1415 Passenger spawn server
??1418 PassengerLoggingAgent
??1425 /usr/sbin/httpd -DFOREGROUND
??1427 /usr/sbin/httpd -DFOREGROUND
??1428 /usr/sbin/httpd -DFOREGROUND
??1429 /usr/sbin/httpd -DFOREGROUND
??1430 /usr/sbin/httpd -DFOREGROUND
??1433 Passenger ApplicationSpawner: /var/hda/platform/html
??1437 /usr/sbin/httpd -DFOREGROUND
??1443 Rack: /var/hda/platform/html
??1449 /usr/sbin/httpd -DFOREGROUND
??1457 /usr/sbin/httpd -DFOREGROUND
??1479 Rack: /var/hda/platform/html
??1487 Rack: /var/hda/platform/html
??1495 Rack: /var/hda/platform/html
??1502 Rack: /var/hda/platform/html
??1509 /usr/sbin/httpd -DFOREGROUND
??1510 /usr/sbin/httpd -DFOREGROUND
??1512 /usr/sbin/httpd -DFOREGROUND

Dec 22 20:17:57 localhost.localdomain systemd1: Started The Apache HTTP Server.
Dec 22 20:21:53 localhost.localdomain systemd1: Reloading The Apache HTTP Server.
Dec 22 20:21:53 localhost.localdomain httpd1135: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using localhost...s message
Dec 22 20:21:53 localhost.localdomain systemd1: Reloaded The Apache HTTP Server.
Dec 22 20:23:41 localhost.localdomain systemd1: Reloading The Apache HTTP Server.
Dec 22 20:23:41 localhost.localdomain httpd1331: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using localhost...s message
Dec 22 20:23:41 localhost.localdomain systemd1: Reloaded The Apache HTTP Server.
Dec 22 20:23:43 localhost.localdomain systemd1: Reloading The Apache HTTP Server.
Dec 22 20:23:43 localhost.localdomain httpd1405: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using localhost...s message
Dec 22 20:23:43 localhost.localdomain systemd1: Reloaded The Apache HTTP Server.
[root@localhost conf.d]#

#3 Updated by bigfoot65 over 6 years ago

Is this resolved?

#4 Updated by jonathankonrad over 6 years ago

I have not done anything to resolve this. I used the workaround as cpg suggested and now it all works, so I'm not sure what else I can do here.

#5 Updated by cpg over 6 years ago

  • Status changed from Assigned to Closed

we released a dep and it can be closed.

#6 Updated by nagybal over 6 years ago

  • Status changed from Closed to Assigned

Exactelly the same happened to me today. Express install. Everything was working fine for weeks. Plex, Transmission OK.

Installing Webmin or AjaXplorer completes without any error. But opening the app, I get routed back to the dashboard. Reboot. The dashboard (http://hda) does not load any longer.

It works if I access it using the server IP. Apps load
(for example the below is OK:
http://transmission.vbu.hu/transmission/web/
http://ajaxplorer.vbu.hu
http://plexms.vbu.hu/index.html)

#7 Updated by cpg over 6 years ago

This says nothing about what is a possible error happening:

systemctl restart httpd

If that fails, then this should give details of the error

systemctl status httpd

if not, then this should give you a url with details of the latest errors in httpd:

tail -100 /var/log/httpd/error_log | apaste

#8 Updated by nagybal over 6 years ago

"systemctl restart httpd" fixed hda.vbu.hu
but after a restart the issue is similar: hda.hbu.hu and http://ajaxplorer.vbu.hu does not work. Plex and Transmission are OK.
but "systemctl restart httpd" did not help this time

[root@localhost bigb]# systemctl status httpd
httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
Active: active (running) since szo 2014-03-15 20:34:52 CET; 33s ago
Process: 1201 ExecStop=/usr/sbin/httpd $OPTIONS -k graceful-stop (code=exited, status=0/SUCCESS)
Main PID: 1213 (httpd)
Status: "Total requests: 13; Current requests/sec: 0; Current traffic: 0 B/sec"
CGroup: name=systemd:/system/httpd.service
??1213 /usr/sbin/httpd -DFOREGROUND
??1234 PassengerWatchdog
??1237 PassengerHelperAgent
??1239 Passenger spawn server
??1244 PassengerLoggingAgent
??1249 /usr/sbin/httpd -DFOREGROUND
??1250 /usr/sbin/httpd -DFOREGROUND
??1251 /usr/sbin/httpd -DFOREGROUND
??1252 /usr/sbin/httpd -DFOREGROUND
??1253 /usr/sbin/httpd -DFOREGROUND
??1258 Passenger ApplicationSpawner: /var/hda/platform/html
??1261 /usr/sbin/httpd -DFOREGROUND
??1266 /usr/sbin/httpd -DFOREGROUND
??1270 Rack: /var/hda/platform/html
??1278 Rack: /var/hda/platform/html
??1296 Rack: /var/hda/platform/html
??1303 Rack: /var/hda/platform/html
??1311 /usr/sbin/httpd -DFOREGROUND

márc 15 20:34:52 localhost.localdomain httpd1213: AH00558: httpd: Could no...
márc 15 20:34:52 localhost.localdomain systemd1: Started The Apache HTTP S...

#9 Updated by nagybal over 6 years ago

  • Status changed from Assigned to Closed

I just came back and the dashboard and AjaxPlorer work. Seems like I just needed to wait long enough to start them. I will reopen the bug report if this come up again.

Thank You for the support

Also available in: Atom