Project

General

Profile

Bug #1239

Multicraft install on Amahi 7 with Fedora 19

Added by jonathankonrad over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
Apps
Target version:
Start date:
12/26/2013
Due date:
% Done:

0%


Description

I purchased Multicraft and it installed on Amahi 7 on Fedora 19. When I go to the web interface I can login with the default "admin" and "admin". I setup a basic server, all default and then clicked start. It will not start. I checked the console and this is what it reads:

25.12 15:07:59 [Multicraft] Loaded config for "Default Minecraft Server"
25.12 15:07:59 [Multicraft] Starting server!
25.12 15:07:59 [Multicraft] Loading server properties
25.12 15:07:59 [Multicraft] Server stopped
25.12 15:07:59 [Multicraft] Retrying server startup
25.12 15:07:54 [Multicraft] Server stopped
25.12 15:07:54 [Multicraft] Failed to obtain process information: no process found with pid 0
25.12 15:07:54 [Multicraft] Is Java installed and in the PATH environment variable?
25.12 15:07:54 [Multicraft] Failed to start server: [Errno 2] No such file or directory
25.12 15:07:54 [Multicraft] Server executable "/usr/bin/java" not found, server startup might fail!

Well, I thought I would try:

yum install java

It worked! The server runs and I can connect. I would like to use the ftp server part of Multicraft but it does not seem to be working. I imagine it conflicts with something in Amahi.

History

#1 Updated by cpg over 7 years ago

That's interesting. We checked it to have a dependency on java, but it was not there, so we just added it. Good catch!

As far as the ftp support -- we just investigated a bit and there appear to be some conflicting issues with it. First, is it really an FTP server? If it's built-in, it ought to not have any dependencies. Oh, does it require any port to be open and forwarded?

Their documentation points to a link in youtube on how to give access http://www.youtube.com/watch?v=3jb9E3_I8iw&hd=1

Can you try that?

Finally, what leads you to imagine it conflicts with something in amahi? Any details on that?
It could be a dependency missing.

Oh -- you are aware FTP by default is unsafe as a protocol because it sends credentials, etc. in plaintext?

#2 Updated by jonathankonrad over 7 years ago

I am aware that ftp can be inherently unsafe. That is related to what I meant by something conflicting with the Amahi. I had imagined that port 21 is locked down intentionally by the Amahi team and Multicraft was attempting to use that port. I did follow their short youtube and did a few simple checks and there is nothing I can do inside of Multicraft differently to get it to work. A quick scan of my HDA shows only ports: 22, 53, 80, 139, 445 in use right now (only scanned ports under 1000). The reason why I might want ftp in this case is I could give my son control over this part of my server. He could upload world files he has worked on and other minecraft files to the servers he sets up, without direct access to other parts of my HDA.

#3 Updated by cpg over 7 years ago

No objections to your reasons -- I was just pointing out it was unsafe. Unless you are doing it inside the network, which should be better.

If there nothing on port 21, there appears to be no FTP server.

Anything showing in the logs that could shed some light as to what's failing or missing?

#4 Updated by jonathankonrad over 7 years ago

This is what Multicraft reports:

Unable to connect to FTP server on port 21.

The error occured in file /var/hda/web-apps/multicraft/html/protected/extensions/net2ftp/includes/filesystem.inc.php on line 57.
• function ftp_openconnection (/var/hda/web-apps/multicraft/html/protected/extensions/net2ftp/modules/browse/browse.inc.php on line 235)
• function net2ftp_module_printBody (/var/hda/web-apps/multicraft/html/protected/extensions/net2ftp/main.inc.php on line 315)
• function net2ftp (/var/hda/web-apps/multicraft/html/protected/controllers/FtpClientController.php on line 186) • argument 0: printBody

• function actionBrowse ( on line ) • argument 0: 1
• argument 1:

• function invokeArgs (/var/hda/web-apps/multicraft/html/protected/yii/web/actions/CAction.php on line 107) • argument 0:
• argument 1: Array

• function runWithParamsInternal (/var/hda/web-apps/multicraft/html/protected/yii/web/actions/CInlineAction.php on line 48) • argument 0:
• argument 1: Method [ public method actionBrowse ] { @@ /var/hda/web-apps/multicraft/html/protected/controllers/FtpClientController.php 127 - 206 - Parameters [2] { Parameter #0 [ $id ] Parameter #1 [ $partial = false ] } }
• argument 2: Array

• function runWithParams (/var/hda/web-apps/multicraft/html/protected/yii/web/CController.php on line 309) • argument 0: Array

• function runAction (/var/hda/web-apps/multicraft/html/protected/yii/web/filters/CFilterChain.php on line 134) • argument 0:

• function run (/var/hda/web-apps/multicraft/html/protected/yii/web/filters/CFilter.php on line 41)
• function filter (/var/hda/web-apps/multicraft/html/protected/yii/web/CController.php on line 1146) • argument 0:

• function filterAccessControl (/var/hda/web-apps/multicraft/html/protected/yii/web/filters/CInlineFilter.php on line 59) • argument 0:

• function filter (/var/hda/web-apps/multicraft/html/protected/yii/web/filters/CFilterChain.php on line 131) • argument 0:

• function run (/var/hda/web-apps/multicraft/html/protected/yii/web/CController.php on line 292)
• function runActionWithFilters (/var/hda/web-apps/multicraft/html/protected/yii/web/CController.php on line 266) • argument 0:
• argument 1: Array

• function run (/var/hda/web-apps/multicraft/html/protected/yii/web/CWebApplication.php on line 283) • argument 0: browse

• function runController (/var/hda/web-apps/multicraft/html/protected/yii/web/CWebApplication.php on line 142) • argument 0: ftpClient/browse

• function processRequest (/var/hda/web-apps/multicraft/html/protected/yii/base/CApplication.php on line 162)
• function run (/var/hda/web-apps/multicraft/html/index.php on line 23)

#5 Updated by jonathankonrad over 7 years ago

  • Status changed from New to Feedback
  • Target version set to amahi-7-1

Multicraft was not helpful:

"Thank you for your inquiry. Issues with the FTP server are almost always related to a problem with the firewall or some other network configuration issue that is outside of the scope of the Multicraft configuration itself. I recommend checking your installation for such issues to address this.

Best Regards,
- Daniel"

#6 Updated by bigfoot65 over 6 years ago

  • Assignee set to jonathankonrad

Any update to this jonathankonrad?

#7 Updated by jonathankonrad over 6 years ago

Sorry. No update. I use the multi-craft package every weekend to host servers for my kids. However, I just setup a share to access where the server keeps the world files. That way we have access to edit files or try different mods. Perhaps we should close this, I currently do not have the time to trouble shoot the FTP server not working. Maybe this summer.

#8 Updated by bigfoot65 over 6 years ago

  • Status changed from Feedback to Closed

Closed per submitter request.

Also available in: Atom