Project

General

Profile

Bug #1251

Search HDA not working - Amahi 7.1

Added by tpcmserver about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/03/2014
Due date:
% Done:

90%


Description

Hi.

I did a fresh install with Express Disk 7.1 and now the search funtion on the control/setup panel is not working (it was working in my prior install Amahi 7).

I've made 2 fresh installs. One, with express disk, on a 64 bits machine and the other one on a 32 bits machine. Both have the same issue. I didn't check any logs but both installs were smooth and servers working just fine.

My issue is the same as described on Bug #622. Images (and general feeling) can be found on https://forums.amahi.org/viewtopic.php?f=16&t=1715

I've checked the logs and none have any suspicious information that I can report.

Reference to bug #622: I do not have Greyhole instaled but on /var/log/ exists several Greyhole logs (?). Nevertheless none is stucked.

Help would be appreciated.

History

#1 Updated by tpcmserver about 5 years ago

  • Target version changed from amahi-7-2 to amahi-7-1

#2 Updated by bigfoot65 about 5 years ago

Greyhole is installed by default and running, regardless if you have set it up. Recommend you try this command and see if it helps:

systemctl stop greyhole.service
logrotate -d /etc/logrotate.d/greyhole

to stop if from starting on boot, do this:
systemctl disable greyhole.service

To verify it's stopped, do this one:
systemctl status greyhole.service

#3 Updated by bigfoot65 about 5 years ago

  • Status changed from New to Feedback
  • Assignee set to tpcmserver

#4 Updated by cpg about 5 years ago

  • Description updated (diff)

[can you file a separate bug for the greyhole issue, please?]

About search, please note that the locate database updates nightly, unfortunately, so only things that are added before the previous nightly indexing will show up.

It's possible you installed and searched. Is this a possibility in your case?

We should probably change the system default from every night to every hour. This search is somewhat expensive, tho. Another possibility would be to keep our own search engine, but that is a fair bit of extra work, best done in a plugin.

#5 Updated by tpcmserver about 5 years ago

Bigfoot65

run the commands but nothing (new) hapened. Cannot search HDA!!! (by the way, do you know if there is a way of making a search through the files with command prompt? - just to test...)

cpg

witch Greyhole issue are you talking about? As far as I understand Greyhole is running as it should (bigfoot65 info).

I've tried several times to search. Overnight it's not an issue. But I like your idea of updating more often. How can I do that?

Did I mention that i've run the search HDA button without a problem, with the same hardware and the same files, with an installation made in July 2013 until I've made a reinstall in mid December 2013?

#6 Updated by cpg about 5 years ago

to update to hourly, you can do this:

mv /etc/cron.daily/mlocate /etc/cron.hourly/

if you get an error because you do not have that file, that is an issue.

to check with command line, type

locate abcde

where abcde is the search term

#7 Updated by tpcmserver about 5 years ago

locate does not run. It says "command not found".

Checking the foruns I found that to run the "locate" cmd you need to have installed "mlocate".

In folder "cron.daily" there is no "mlocate" folder/file (I run "ls cron.daily" and the result was "greyhole logrotate man-db.cron").

Should I install "mlocate"? https://admin.fedoraproject.org/pkgdb/acls/name/mlocate

#8 Updated by cpg about 5 years ago

looks like this may be a missing dependency. fixed in commit:139ff09 of hda-platform.

please do as follows:

yum -y install mlocate

then you can change it to hourly from daily if you prefer.

if it works, please set status to Closed for this bug request.

#9 Updated by cpg about 5 years ago

  • Target version changed from amahi-7-1 to amahi-7-2

#10 Updated by tpcmserver about 5 years ago

  • Target version changed from amahi-7-2 to amahi-7-1

"mlocate" instaled. Reboot. Run "locate" cmd again and it says that "mlocate.db" not found.

Then I run "sudo updatedb". And it works!!!!

Do I need to update every one of my machines or are you gonna issue an automatic update?

#11 Updated by tpcmserver about 5 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 90

Also available in: Atom