Project

General

Profile

Feature #128

Support for changing DHCP lease time

Added by essary over 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Medium
Assignee:
Category:
-
Target version:
-
Start date:
04/22/2009
Due date:
% Done:

50%


Description

I am running Amahi on my home server and when using Amahi as my DHCP server my SSH sessions kept freezing when "SSHing" from my laptop running Ubuntu. The only fix I found was setting up a static IP. If there was a way to configure the lease time to something other than 10 minutes then I would still be able to use DHCP as opposed to Static IP addresses.

History

#1 Updated by pjcrux about 12 years ago

I am running Amahi on my home server and when using Amahi as my DHCP server my SSH sessions kept freezing when "SSHing" from my laptop running Ubuntu. The only fix I found was setting up a static IP. If there was a way to configure the lease time to something other than 10 minutes then I would still be able to use DHCP as opposed to Static IP addresses.

Update:

Hdactl needs to read an external file for the value of the DHCP Lease. That way it is more easily managed by users without mucking with the master script.

#2 Updated by essary about 12 years ago

  • Priority changed from Normal to Medium

Issue 201 was essentially a duplicate of this feature request. I have added the info from 201 below.

petercross wrote:

charlesghopkins wrote:

The lease renewal is a factor especially because you have a device that is filling / servicing a a LOT of roles and if you can minimize the impact ..... When you are gaming you do not want a lease renewal in the middle especially if someone is streaming media from the HDA and due to bandwidth cannot get a DHCP address.

"Lease duration is another area to consider (i.e. the amount of time before a client needs to renew its DHCP address) - if this is set too long, and there are a large number of mobile clients, there is a risk of running out of available IP addresses as these mobile clients join the network, lease an address and then leave again without releasing it; conversely, too short and there is a large amount of renewal traffic as the DHCP client attempts to renew its lease at the half life. For most environments, I find that an 80:20 rule can be applied - i.e. provide 20% more addresses than are expected to be in use at any one time (to cater for mobile clients) and set the lease time to 1 day but for a subnet with largely static PCs, then longer leases may be appropriate."

Recommended settings:
4 hours = 240 <---- I would recommend not going below this minimum.
8 hours = 480
12 hours = 720 <--- This setting would be optimal, I think, for a home environment.
24 hours = 1440
8 days = 11520 (default recommended time for the specification).

http://www.imconf.net/imc-2007/papers/imc17.pdf

http://www.markwilson.co.uk/blog/2005/07/best-practices-for-managing-automatic.htm

http://www.google.com/search?q=dhcp+lease+time+best+practice

hdactl needs to read an external file for the value of the DHCP Lease. That way it is more easily managed by users without mucking with the master script. -Chaz|home

#3 Updated by essary almost 12 years ago

  • Assignee set to essary
  • % Done changed from 0 to 50

I have the interface in working order and the backend code in place to write the settings to the database. All that is left is the work to hda-install to initially add the setting to the database.

#4 Updated by cpg over 11 years ago

fixed and released in amahi 5!

#5 Updated by cpg over 11 years ago

  • Status changed from New to Closed

Also available in: Atom