Project

General

Profile

Bug #1291

CrashPlan on Fedora 19

Added by twc over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Apps
Target version:
Start date:
02/07/2014
Due date:
% Done:

0%


Description

CrashPlan App has a status of Alpha on Fedora 19. In discussing this on IRC with user cpg he said that this is because "crashplan status: CP needs a desktop to finish installing. we're looking for a way to install without one". Per cpg's request I am logging this bug to capture the two links I provided on IRC and to explain further.

It is true that CrashPlan requires a Desktop GUI for configuration. However, it is not required to run that GUI on the same machine as the CP Engine. It is worth noting that a headless configuration is unsupported by Code42 (the makers of CrashPlan).

That said, following the steps here http://www.shasam.net/blog/2012/3/21/crashplan-on-the-netgear-readynas-x86.html will allow a user to install a headless CP onto an x86 based ReadyNAS.

Code42 also provides the information at https://support.code42.com/CrashPlan/Latest/Configuring/Configuring_A_Headless_Client on how to connect to, and configure a headless client.

I will also note that, for what it is worth, in discussion with a Code42 front line support rep I was told that because of the CP Family Plan (up to 10 computers on one plan) that they are "working hard" on a way to allow the GUI on one machine to connect to, and configure, another machine (So for example "Dad" could connect to "Mom" or "Sis" or "Brother" or whoever's computer remotely and set it up). Obviously as a front line rep "mileage may vary" but...

History

#1 Updated by bigfoot65 over 6 years ago

Looked at the links for install and appears to be more complicated than expected.

The only way to complete install is by using a client install on a Windows/Linux/Mac machine. It also involves temporarily changing the configuration on the HDA to complete.

Will have to test, but not expecting this one to work out well. Would be simpler to install Amahi VNC app, then install CP. That would lend to having the desktop available on the same location as the CP server app.

More to follow.

#2 Updated by bigfoot65 over 6 years ago

  • Target version changed from amahi-7-0 to amahi-7-1

#3 Updated by bigfoot65 over 6 years ago

  • Status changed from New to Assigned
  • Assignee set to bigfoot65

I think I have it working correctly. There is wiki guidance to use the Desktop client to configure and complete install.

https://wiki.amahi.org/index.php/Crashplan

Posted in forums asking for testers to try and provide feedback.

#4 Updated by danewood over 6 years ago

Install error

Welcome to the CrashPlan Installer.

Press enter to continue with installation.
Validating environment...
detected root permissions
The current version of Java (1.8) is incompatible with CrashPlan.
Please install one of the following version of the Sun JRE or OpenJDK: 1.5 1.6 1.7
Redirecting to /bin/systemctl restart crashplan.service
Failed to issue method call: Unit crashplan.service failed to load: No such file or directory. See system logs and 'systemctl status crashplan.service' for details.
App: CrashPlan installed ======= app install end @ 2014-03-04 23:58:46 -0700 ==========

#5 Updated by danewood over 6 years ago

Here is the log from apps installed prior to Crashplan (including the crashplan segment)

======= app install begin @ 2014-03-04 23:47:47 -0700 ==========
Installing app id oxlimkd9bi under /var/hda/platform/html ENV=production
Redirecting to /bin/systemctl stop netatalk.service
Redirecting to /bin/systemctl reload monit.service
App: Amahi Time Machine installed ======= app install end @ 2014-03-04 23:48:19 -0700 ========== ======= app install begin @ 2014-03-04 23:57:02 -0700 ==========
Installing app id frq3hxy7kj under /var/hda/platform/html ENV=production
file /var/hda/tmp/amahi-download-cache/cd74ccbed1a67f82c943f0ad6637413dacf7ae46 written in cache
Your HDA services have been restarted.
Your HDA services have been restarted.
NOTE: file /tmp/amahi-download-cache/5ae921fbf1142f8376ae85dc9a6168dcf050afe2 written in cache
App: eyeOS installed ======= app install end @ 2014-03-04 23:57:42 -0700 ========== ======= app install begin @ 2014-03-04 23:56:49 -0700 ==========
Installing app id ogiaus92x5 under /var/hda/platform/html ENV=production
Your HDA services have been restarted.
Your HDA services have been restarted.
Configuring Amahi settings
Reloading systemctl daemon
Enabling minidlna.service
ln -s '/usr/lib/systemd/system/minidlna.service' '/etc/systemd/system/multi-user.target.wants/minidlna.service'
Starting minidlna.service
App: DLNA installed ======= app install end @ 2014-03-04 23:57:45 -0700 ========== ======= app install begin @ 2014-03-04 23:58:34 -0700 ==========
Installing app id sp2uf8jdkx under /var/hda/platform/html ENV=production ======= app install begin @ 2014-03-04 23:58:14 -0700 ==========
Installing app id wzjcdmbnqp under /var/hda/platform/html ENV=production
NOTE: file /tmp/amahi-download-cache/a4942e55e442d9958d172ec87b98a40d9490a2bc written in cache ======= app install begin @ 2014-03-04 23:57:47 -0700 ==========
Installing app id csjnit42fq under /var/hda/platform/html ENV=production
file /var/hda/tmp/amahi-download-cache/84515cad07a3f66fe6ae2a32e78be42dd22f72a1 written in cache
Your HDA services have been restarted.
Your HDA services have been restarted.
App: Transmission installed ======= app install end @ 2014-03-04 23:58:40 -0700 ========== ======= app install begin @ 2014-03-04 23:57:39 -0700 ==========
Installing app id 2uslky9of5 under /var/hda/platform/html ENV=production
NOTICE: redirected 'http://downloads.sourceforge.net/project/subsonic/subsonic/4.9/subsonic-4.9.rpm' --> 'http://softlayer-ams.dl.sourceforge.net/project/subsonic/subsonic/4.9/subsonic-4.9.rpm' ...
file /var/hda/tmp/amahi-download-cache/46b408a302cb0414b1c349de8afaf90ea17239be written in cache
Your HDA services have been restarted.
Your HDA services have been restarted.
NOTE: file /tmp/amahi-download-cache/f934d12e6bcd6bf525b75d93a1d0e06f7b30183a written in cache
App: OpenVPN installed ======= app install end @ 2014-03-04 23:58:41 -0700 ==========

Welcome to the CrashPlan Installer.

Press enter to continue with installation.
Validating environment...
detected root permissions
App: Subsonic installed ======= app install end @ 2014-03-04 23:58:42 -0700 ==========
44819 blocks
The current version of Java (1.8) is incompatible with CrashPlan.
Please install one of the following version of the Sun JRE or OpenJDK: 1.5 1.6 1.7
Redirecting to /bin/systemctl restart crashplan.service
Failed to issue method call: Unit crashplan.service failed to load: No such file or directory. See system logs and 'systemctl status crashplan.service' for details.
App: CrashPlan installed ======= app install end @ 2014-03-04 23:58:46 -0700 ==========

#6 Updated by bigfoot65 over 6 years ago

  • Status changed from Assigned to Feedback

App has been updated to use the correct version of Java. However, any app that installed 1.8.0 will prevent this from working correctly.

The only solution for those is to remove Java 1.8.0 and install 1.7.0. All the apps using Java will function with the older version. Apps have been updated in the Amahi store to not use Java 1.8.0.

Please test and report back if it works now.

#7 Updated by bigfoot65 over 6 years ago

  • Status changed from Feedback to Closed

No reply indicates resolved.

Also available in: Atom