Project

General

Profile

Bug #1314

Ability to play ogg vorbis files would be appreciated.

Added by vogateer over 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
03/01/2014
Due date:
% Done:

0%


Description

I love the app. The only thing I want is to be able to play ogg vorbis files. This might be a bug, since it tries to play the files, but all I get is silence. Flac files play without issue.

02 I Will Come for You.ogg (2.22 MB) vogateer, 03/04/2014 04:05 AM

03 Une année sans lumière.ogg (4.6 MB) vogateer, 03/04/2014 04:55 AM

History

#1 Updated by cpg over 8 years ago

  • Status changed from New to Feedback
  • Assignee set to vogateer

Thanks for the feeback.

We thought we built support for ogg vorbis files. At this time, the
support is based on the extension of the file.

Can you give us an example of a filename that does not play?
(or even share a file)

Our music support is not great yet (no recognition of playlists, no
background playing, no cover art), but we want to improve it over time
if people like the app, which seems to be the case.

(when you do that assign the bug back to cpg please)

#2 Updated by vogateer over 8 years ago

I should have known that you built support for ogg in. The music player does try to play it, showing a working progress bar and the correct duration of the ogg vorbis file, but no sound comes out.

I've attached an example of an ogg vorbis file that won't play, and I believe this file was freely available from Jamendo or some other site where artists make their works freely downloadable. I've tried to play many ogg vorbis files, and none of them have worked so far, including the very simple names.

I don't think it's related, but there used to be a lot of characters in the filenames that Samba didn't like, so the Amahi app wouldn't even show a single folder in the music category. I used a little script to change all the filenames, so now all the files I've tried have showed up, and I haven't had that problem since.

#3 Updated by cpg over 8 years ago

  • Assignee changed from cpg to vogateer

I have trouble playing this file with the following:

  • chrome on mac
  • firefox on mac
  • toast titanium on mac
  • vlc on ios (no surprise, since the Amahi iOS app embeds VLC)
  • vlc on desktop mac (no surprise since VLC for the mac uses the same library as VLC for iOS)
  • adobe audition

I cannot quickly find other programs to test with.

they typically "break" after 4.5 seconds and silence. then some actually resume after a while.

adobe audition actually loads the file with an error (http://dl.dropbox.com/u/364883/Screenshots/2v7g.png)
and then it plays it ok.

toast titanium plays it ok, except at second 4.5 into the file, it has this huge spike of noise and then continues. then there are multiple of these spikes.

dropbox on ios does not play it, but it may be that it's not built in.

we use this file and similar for testing: alpha.amahi.org/adg3com_electrofreak.ogg

what are the chances that the formats of this file (and your other files) are somewhat broken, corrupted or old?

#4 Updated by vogateer over 8 years ago

Ugh, I picked a file that I hadn't encoded myself. Sorry to waste your time with that, because that file gives me the same problem when I use VLC and other media players on my own computer.

This file works fine for my computer, not on the Amahi app, though.

#5 Updated by cpg over 8 years ago

ok, that one plays ok for me on Amahi for iOS version 1.8 on iOS 7.0.6.

that one does not play for you?

#6 Updated by vogateer over 8 years ago

That file does not play for me. Amahi for iOS version 1.8.

Looks like this iPad is on iOS 7.0 (11A465). I don't think it's been updated to iOS 7.0.6. This iPad is usually updated by a company, so we don't do those upgrades. That difference in iOS versions might explain it.

I'll update iOS and see if that helps.

#7 Updated by cpg over 8 years ago

i do not think a minor version would do it.

i remember one user had parental controls and PDFs and other things would not play.

one other thing that happened to me was that i had the silent button on. however the ipad does not have that.

#8 Updated by vogateer over 8 years ago

Unfortunately, upgrading iOS didn't help. I knew it was a doubtful attempt at a solution, but it was worth a try.

Let me know if there's something I can do to help troubleshoot. I'm not knowledgeable about iOS, but I'll do what I can.

#9 Updated by vogateer over 8 years ago

  • Status changed from Feedback to Resolved

Updated to the latest Amahi today, and Ogg Vorbis files are playing well. Good work!

#10 Updated by cpg about 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom