Project

General

Profile

Bug #1315

httpd breaks after update

Added by bigfoot65 almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/03/2014
Due date:
% Done:

0%


Description

There may be an issue with the latest httpd, httpd-tools, and mod_ssl package and Amahi. I installed Webmin, which pulled in the latest mod_ssl and httpd broke.

httpd-tools-2.4.7-1.fc19.x86_64
httpd-2.4.7-1.fc19.x86_64
mod_ssl-2.4.7-1.fc19.x86_64

Doing systemctl restart httpd.service results in the following error message:
httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf.modules.d/00-lua.conf: Cannot load modules/mod_lua.so into server: /etc/httpd/modules/mod_lua.so: undefined symbol: apr_bcrypt_encode

I updated openssl and that did not fix it. The only fix I found so far is to downgrade.

yum downgrade httpd httpd-tools mod_ssl

After doing that and restarting httpd.service, all is well.

Is this 00-lua.conf Amahi specific or part of Fedora 19? I think there is at least one user who has found the same issue. I removed mod_ssl from the two apps to prevent mandatory upgrade of httpd.

History

#1 Updated by cpg almost 7 years ago

let's see who owns that file:

rpm -qf /etc/httpd/conf.modules.d/00-lua.conf

oops, looks like httpd owns it. so it's a bug upstream!?

#2 Updated by bigfoot65 almost 7 years ago

Yea that's what I am thinking too. I will see what I can find out.

#3 Updated by bigfoot65 almost 7 years ago

I did not find anything about this issue. However, what I did find out is if you do yum update and install all updates, the issue is not reproduced.

It appears there must be other packages that when updated with httpd prevent this issue.

#4 Updated by bigfoot65 almost 7 years ago

  • Status changed from New to Closed

Have not heard anyone else with issues. Closing bug report.

Also available in: Atom