Project

General

Profile

Bug #1327

ffmpeg RPM Conflict

Added by bigfoot65 over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Apps
Target version:
Start date:
03/22/2014
Due date:
% Done:

0%


Description

Apparently the install of the ffmpeg RPM package causes conflicts with minidlna. Specifically, the ffmpeg-libs-1.2.6-1 installs libavutil.so.52 and libavformat.so.54 which is also installed by minidlna.

The error from systemctl status minidlna.service is:
minidlna.service
Loaded: error (Reason: No such file or directory)
Active: failed (Result: exit-code) since Sat 2014-03-22 10:35:09 CDT; 3min 32s ago
Main PID: 14728 (code=exited, status=127)

Mar 22 10:35:09 localhost.localdomain systemd1: Starting MiniDLNA is a DLNA/UPnP-AV server software...
Mar 22 10:35:09 localhost.localdomain systemd1: Started MiniDLNA is a DLNA/UPnP-AV server software.
Mar 22 10:35:09 localhost.localdomain minidlnad14728: /usr/sbin/minidlnad: symbol lookup error: /lib64/libavcodec.so.54: undefined symbol: vpx_c..._dx_algo
Mar 22 10:35:09 localhost.localdomain systemd1: minidlna.service: main process exited, code=exited, status=127/n/a
Mar 22 10:35:09 localhost.localdomain systemd1: Unit minidlna.service entered failed state.
Mar 22 10:35:42 localhost.localdomain systemd1: Stopped MiniDLNA is a DLNA/UPnP-AV server software.
Mar 22 10:35:44 localhost.localdomain systemd1: Stopped MiniDLNA is a DLNA/UPnP-AV server software.
Mar 22 10:35:47 localhost.localdomain systemd1: Stopped minidlna.service.

The two of them cannot coexist, much like the issue we had with Plex Media Server. Not sure what the solution is here. There are only a handful of apps that use ffmpeg, but don't know which ones for sure.

This must have been caused by the latest minidlna update as we have not had any reported issues in the past.

History

#1 Updated by bigfoot65 over 5 years ago

So far, the only LIVE app I have found that uses ffmpeg is Subsonic. I will update as I find more.

#2 Updated by bigfoot65 over 5 years ago

Here's the info on the minidlna package:
http://pkgs.org/fedora-19/rpmfusion-free-updates-i386/minidlna-1.1.2-1.fc19.i686.rpm.html

Now look at the new package via yum install:
Dependencies Resolved

=============================================================================================================================================================
Package Arch Version Repository Size =============================================================================================================================================================
Installing:
minidlna x86_64 1.1.2-1.fc19 rpmfusion-free-updates 156 k
Installing for dependencies:
celt x86_64 0.11.3-1.fc19 updates 76 k
ffmpeg-libs x86_64 1.2.6-1.fc19 rpmfusion-free-updates 3.7 M
fribidi x86_64 0.19.4-3.fc19 fedora 63 k
lame-libs x86_64 3.99.5-2.fc19 rpmfusion-free 339 k
libass x86_64 0.10.1-3.fc19 fedora 63 k
libdc1394 x86_64 2.2.0-2.fc19 fedora 119 k
libid3tag x86_64 0.15.1b-15.fc19 fedora 47 k
libva x86_64 1.1.1-2.fc19 fedora 61 k
openal-soft x86_64 1.15.1-2.fc19 fedora 185 k
opencv-core x86_64 2.4.6.1-1.fc19 updates 1.8 M
schroedinger x86_64 1.0.11-4.fc19 fedora 297 k
x264-libs x86_64 0.130-3.20130502git1db4621.fc19 rpmfusion-free 512 k
xvidcore x86_64 1.3.2-5.fc19 rpmfusion-free 259 k

Transaction Summary =============================================================================================================================================================
Install 1 Package (+13 Dependent packages)

I have downloaded the older version packages as they are not available in the RPM Fusion repo via command line from my attempts. Suggest we put these in the repo or dl.amahi.org and adjust the app to only use this version until they sort it out.

http://download1.rpmfusion.org/free/fedora/releases/19/Everything/i386/os/minidlna-1.0.26-2.fc19.i686.rpm

http://download1.rpmfusion.org/free/fedora/releases/19/Everything/x86_64/os/minidlna-1.0.26-2.fc19.x86_64.rpm

We will have to exclude the install of the newer version as well.

Not the ideal solution, but an option.

#3 Updated by bigfoot65 over 5 years ago

Looks like it's more complicated than I predicted. It still wants to install the ffmpeg-libs with the older version as well.

Bad mojo that two packages are dependent again in the repo. Version conflicts are such a pain :(

#4 Updated by bigfoot65 over 5 years ago

Now it's a real problem, DLNA is broken as a result.

Installing it on a prestine Amahi 7 VM results in the error listed above. We may have to pull DLNA from the store again :(

I will keep investigating, but things are not looking good.

#5 Updated by bigfoot65 over 5 years ago

  • Priority changed from Medium to High

#6 Updated by bigfoot65 over 5 years ago

Doing a yum update seems to correct the problem with the DLNA install. Not sure about installing ffmpeg yet, still investigating.

I may be raising the flag too soon here.

#7 Updated by bigfoot65 over 5 years ago

Installed DLNA on pristine Amahi 7 64-bit VM. App did not work. I then did a yum update to get all the OS updates and it started working.

I installed ffmpeg and it continues to work fine. I stopped and restarted minidlna without issue.

So seems that there is a package somewhere that needs updated to get the right versions in sync.

Will leave this bug open until verified from the person who had issues in the forums.

#8 Updated by cpg over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to bigfoot65

Great job in diagnosing this!

The work-around is to update everything, then.

We do not have the ability to specify greater than or smaller than versions of packages at this time to force dependencies.

#9 Updated by bigfoot65 over 5 years ago

  • Status changed from Assigned to Closed
  • Assignee deleted (bigfoot65)

Closing as no further action required.

I have not heard any rumblings in the forums since creating the bug report.

Also available in: Atom