Project

General

Profile

Bug #1328

owncloud 6 iOS app can't login

Added by InteNsity over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/22/2014
Due date:
% Done:

0%


Description

I recently updated to owncloud 6 from amahi, everything seemed to work fine but when i tried to login with my owncloud app i couldn't login
basically you have to give an adress( wich was username.yourhda.com wich directs to the owncloud app)
it then says that a connection is established. after that you can login with the username and password that you made in the owncloud app.
problem is that it says that the username/password is incorrect. I triple checked this with multiple users i made. the webinterface works fine and the desktop app too.

so, i dug arround in the owncloud forum and learned that it is SERVERside. also, and i quote:
"It was a serverside problem. My Admin solved it by patching the suexec."
"I had to enable all PHP verbs and disable the integrated WebDav module on my IIS."

not a pro myself so this doesn't say a thing to me but maybe you guys know what they mean :)

History

#1 Updated by bigfoot65 over 6 years ago

Probably not something we should do. To risky and may open up security vulnerabilities.

Recommend guidance be added to the wiki to accomplish this modification at the users own risk. It could also affect behavior of the HDA or other apps.

Without proper documentation of the steps, this could cause additional support work.

#2 Updated by cpg over 6 years ago

  • Project changed from platform to apps
  • Category deleted (App Install)
  • Status changed from New to Feedback
  • Assignee set to InteNsity

this does not make a lot of sense.

definitely we should never ever advise users to patch suexec or anything like that.

first, the address should be internal to your network (owncloud-6.your-internal-domain.com or such). anything from an external (e.g. *.yourhda.com) network should not be even attempted until things are working internally first. any external access needs some knowledge about tweaking virtual servers, port forwarding, etc.

for all we know you may be trying to access some random server on the web.

first please make sure you are using the address/name of your INTERNAL owncloud 6 app. you can see it via your dashboard. then try again and report.

you should see activity in the logs of the webapp in your amahi server under /var/hda/web-apps/owncloud-6/logs/

#3 Updated by InteNsity over 6 years ago

Ok,
- I had a similar setup with the old owncloud app wich worked fine.
- the owncloud iphone app doesn't support internal connections.
- I know for a fact that it is suposed to be working, as the same login credentials are used for the windows client and the web-interface(both work)
- the iphone app states "connection established", so nothing is wrong there
- the app clearly states that username/password is incorrect(100% sure it is)
- the earlier mentioned fixes are just quotes from the owncloud forum and had nothing to do with amahi
- can any of you maybe test this so i know if it is an issue for me only or not.
- my owncloud app gives an error stating that i should use https instead of http

#4 Updated by northridgegrp over 6 years ago

Using the ownCloud forum is not always the best place to get fixes to issues. The forum is driven primarily driven by ownCloud users, many of their solutions are "band-aids" and are not recommended actions by the ownCloud organization (especially poking around server infrastructure such as PHP). I have tried OC forum recommendations before, but later I have been informed by the OC developers that the practice is NOT recommended and can be dangerous. It is extremely rare that ownCloud developers ever answer OC forum issues.

The ownCloud Github would be the best place to go, "https://github.com/owncloud" in to the "apps" section and raise an issue. It sometimes will take awhile to get an answer but something will come back from a developer or moderator. In cases like this there maybe a bug issue already raised.

In recent days I've seen some developer chatter around the iOS app, so I did not read the discussion details as I don't use iOS devices. The author of this Amahi bug should seek answers by going to the ownCloud Github.

#5 Updated by InteNsity over 6 years ago

Ok guys,
i found the problem, turns out it can't login while you have a VPN installed(or activated)(atleast Hotspot Shield vpn) while logging in on iphone, this is a bug within owncloud so sorry for all the trouble.

#6 Updated by bigfoot65 over 6 years ago

  • Status changed from Feedback to Closed
  • Assignee deleted (InteNsity)

User resolved.

Also available in: Atom