Project

General

Profile

Bug #1333

plex media server

Added by hal1968 over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Medium
Assignee:
Category:
Apps
Target version:
-
Start date:
03/27/2014
Due date:
% Done:

0%


Description

could the latest version of plex media server be updated into the apps downloads for Amahi7 ?
They have been working on a lot of updates which the client software can take advantage of ... but the server needs to be updated for it to take effect. It would be appreciated ... and most likely by everyone who uses this app.
The latest version for Fedora is: RPM for Fedora 14 or newer
Version 0.9.9.7.429-f80a8d6.

Whereas the latest available for download through the one click install for Amahi is 0.9.8.18.290-11b7fdd

Thx

History

#1 Updated by cpg over 6 years ago

  • Status changed from New to Assigned
  • Assignee set to cpg

#2 Updated by bigfoot65 over 6 years ago

Are we close to getting this one resolved?

#3 Updated by hal1968 over 6 years ago

Hey Fellas ... Any news or updates an this ?
Thx

#4 Updated by bigfoot65 over 6 years ago

It has not made it to the top of our list. We are quite busy with the Google of Summer projects. Hope to have some news soon.

#5 Updated by cpg over 6 years ago

  • Priority changed from Normal to Medium

#6 Updated by cpg over 6 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from cpg to hal1968

test rpm ...

alpha.amahi.org/tmp/amahi-plex-0.2-1.x86_64.rpm

please test it and report. my app plex does show a login now. this did not use to happen. pretty nasty, if you ask me.
http://dl.dropbox.com/u/364883/Screenshots/yrs8.png

#7 Updated by cpg over 6 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from hal1968 to cpg

strike that. i think i built it incorrectly.

#8 Updated by hal1968 over 6 years ago

ok ... I'll hang on .
BTW ... is there some reading or instruction you can point me towards in relation to what you are doing ... maybe I can help with these types of things in the future ... but I would need some pretty detailed literature to drive me the right direction since I haven't done anything like that before. But I am the sort that can catch on pretty quickly with a little nudge in the right direction.

#9 Updated by cpg over 6 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from cpg to hal1968

ok, 64-bit only test rpm available for your testing:

rpm -Uvh alpha.amahi.org/tmp/amahi-plex-0.2-1.x86_64.rpm

when done, please assign back to me wether it works or not (with details of why it does not work).

#10 Updated by hal1968 over 6 years ago

I just got back into town
So I tried to install what you have provided (pardon my ignorance.. I am new to this Linux stuff.. so pls bare with me)

I got this when I tried to install it .. " missing destination file operandafter 'alpha.amahi.org/tmp/amahi-plex-0.2-1.X86_64.rpm'

Apparently... I haven't done it correctly ... or I'm not doing the install properly ... Initially I tried to download the link you provided ... but that didn't result in anything ... nothing came in ... so tried the other way and the above result was what I got.

Sorry to bother you with what is probably a stupid error on my part

#11 Updated by cpg over 6 years ago

we avoid hotlinking to the alpha site directly.

rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.2-1.x86_64.rpm

you have to do it as root (or with sudo and your user has to be an admin).

#12 Updated by hal1968 over 6 years ago

ok ... I'm done.. tired .. you better give this to someone who can install it ... I guess I'm just lacking the basics

#13 Updated by cpg over 6 years ago

sigh, i forgot to add the http at the front of that url. updated.

i installed it and it seems like it's working, but i cannot login to plex. either i forgot the login info or the app now requires pinging plex.tv (which is not nice).

#14 Updated by bigfoot65 over 6 years ago

We have a test app for the new version.
http://www.amahi.org/apps/plex-media-server-clone

I have given you access to test it. Uninstall all versions of Plex Media Server and install this one.

Please let me know how it goes. Once testing is complete, you will need to uninstall it.

We will then update the LIVE app with this new amahi-plex version and you can install it.

BTW, it installed fine for me and appears to be working. I do not have the capability to test the features of the app.

#15 Updated by hal1968 over 6 years ago

well ... again , I'm either completely lost or I don't have permission .. I'm able to click that link which results to a page that says it is in an "alpha state".. but I'm unable to do anything with it.
I attempted to copy it into a temp directory from within a terminal as "root" ... but got this "cp cannot stat" ... that being said ... the error in an attempt to install this way is most likely mine.
pls bare with me .... I'm not really fluent with this stuff ... and there doesn't appear to be any in depth instruction to go about it in any fashion... considering the fact that most stuff I've googled comes up with things in relation to unbuntu and that seems to be handled differently with variations in commands within the terminal... nevertheless, its still a good learning process for me ... just a little frustrating for you ...lol

#16 Updated by bigfoot65 over 6 years ago

You go to the HDA dashboard and choose Apps. Then in available apps look for the test application.

Have not installed Amahi apps before? If so, then nothing has changed.

Googling things will not always help. Best to follow the guidance we provide and nothing else or you can mess up your HDA.

#17 Updated by bigfoot65 over 6 years ago

If you don't see it, might be a pay app. If that is the case, you would need to purchase it via the amahi.org web site.

Not sure if we can give you a credit for helping test, but work asking.

#18 Updated by hal1968 over 6 years ago

found it ... it wasn't showing up earlier when I was looking for it ... but Its there now ... I'll report back later today after some testing . And yes I paid for the app previously and installed ... that's why I was a little confused when I couldn't locate it earlier
Thanks again

#19 Updated by bigfoot65 over 6 years ago

Sounds good. If it tests ok, we will release it.

#20 Updated by hal1968 over 6 years ago

its works good ... just the guys at plex need to work on their updates a little bit . thanks again

#21 Updated by cpg over 6 years ago

just a quick note ... this is not enough info. we need more details:

  • how exactly did you install the app?
  • did you uninstall the original and install the clone?
  • did you install the clone update without installing the other one?
  • specifically we need to know if updates will work, otherwise we will face the wrath of upset users if we release and update and breaks their already-working app

#22 Updated by hal1968 over 6 years ago

fair enough
my steps exactly
1) uninstall the original from the dashboard via its uninstall option
2) found the clone version after a bit ... installed again via the dashboard
3) *** note , there was no need to update the shared directories , it maintained that info even though the original was uninstalled first. Exceptionally convenient if the update is to be an automatic type of process.
4) some of the features that were spoke about for this version of the plex media servers aren't exactly doing as I assumed ... after reading some of the posts in their own forums they still have a bit of work to do ... so of course this has nothing to do with your work ... but nevertheless it does help a bit with the google chromecast stuff a bit and it shows their playlist feature in its infancy ... still a bit of work to do there. I was unable to test the photo part due to its reliance on its first implementation on apple gadgets (I'm not a Mac person)
Everything else seemed to run very well.
  • As well , if you need it installed in another way to test this in some other fashion , just ask
    Thanks for your time
    Hal

#23 Updated by cpg over 6 years ago

awesome. good details.

the one way we'd like to test is:

  • uninstall all plex
  • install the existing main app (not the updated/clone app)
  • go via ssh and do the update of the new rpm file (as root/sudo rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.2-1.x86_64.rpm
  • test that the update works well (not installing the cloned/updated app)

if this works, we want to release. i am preparing the 32 bit version as we speak

#24 Updated by hal1968 over 6 years ago

as you requested
1) uninstalled everything
2) reinstalled the original
3) installed the update via SSH through that putty program thing as root
4)all the links actually worked and it went through the Preparing... 100%, then followed by Updating / Installing process 1:amahi-plex-0.2-1 50%, followed by Cleaning up / removing 2:amahi-plex-0.1.3-1 reported 100%
end result seems to be the same as installing the clone via the dashboard....the only odd thing is the dashboard reports this version of plex is installed "Version: 0.9.8.18.290-11b7fdd".... does this seem right to you ?

#25 Updated by cpg over 6 years ago

  • Status changed from Feedback to Closed
  • Assignee changed from hal1968 to cpg

yes, that will be fine -- we're updating the underlying code, so it will be fine.

thanks for the feedback.

the update has been released to the repos in 32bit and 64bit formats.

let the wrath begin!

#26 Updated by cpg over 6 years ago

  • Status changed from Closed to Feedback
  • Assignee changed from cpg to hal1968

for the record, the new version of amahi-plex releases plex's version 0.9.9.7.429-f80a8d6.

#27 Updated by hal1968 over 6 years ago

ok ... just one other quick question ... since I have this other test version installed .... should I uninstall it before you release the official one ?

#28 Updated by cpg over 6 years ago

according to step 1 in comment #24, you should have installed everything, therefore you should have "that other version" (i assume the clone) installed. if you followed the steps you mentioned, you are up to date and identical to the latest official release from our repos.

#29 Updated by bigfoot65 over 6 years ago

  • Status changed from Feedback to Closed

Apparently all is well as there has been no red flags as of yet. Closing.

Also available in: Atom