Project

General

Profile

Feature #1335

Update amahi-greyhole to 0.9.48

Added by bigfoot65 over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
03/31/2014
Due date:
% Done:

0%


Description

Greyhole is now up to version 0.9.48. The latest amahi-greyhole version is 0.9.44. Recommend we update to the latest.

Change log is as follows:
What's new in 0.9.48
--------------------
- Bugfix: quiet warnings from --going when a specific share doesn't exist on the drive that is getting removed.
- Bugfix: first time installs would fail when trying to create the Greyhole in-memory spool, because that would try to parse the config file (greyhole.conf), and fail, thus preventing all new users from installing Greyhole!

What's new in 0.9.47
--------------------
- Bugfix: log action was not correctly set for CLI commands (--going, etc.)
- Bugfix: during --fsck, if we find a metadata file that says the symlink is OK, we still need to check if it really is!
- Bugfix: --going wasn't creating extra file copies as expected!! Regression in 0.9.45+

What's new in 0.9.46
--------------------
- Bugfix: greyhole-dfree is a Bash script really; /bin/sh is not good enough.

What's new in 0.9.45
--------------------
- Bugfix: slow writes to Greyhole shares, due to constant writes in spool folder
- Bugfix: Ignored folder renamed: files won't be processed. Fixes GH-108
- Bugfix: Prevent 'no such file' errors in --view-queue, when spooled files get deleted by the daemon
- Bugfix: Create missing symlink to libsmbd_base.so.0, on Ubuntu 14. Fixes GH-107
- Bugfix: typo when trying to log something and greyhole.log/.err isn't writable by the current user.
- Bugfix: settings.name field in the database should be a UTF-8 string. Fixes GH-115
- Bugfix: "Tried to fsck a share that is missing from greyhole.conf" is not critical anymore; happens when a user removes a share that still has fsck or fsck_file tasks pending.
- Improvement: greyhole-dfree is now a shell script that will return a cached value. The cache will be refreshed every 15s using the old script that is now in /usr/share/greyhole/greyhole-dfree.php. Thanks to julakali for the idea and most of the implementation.
- Improvement: Show warnings when some drives are not used. Fixes GH-89
- Improvement: Remove leftovers from .deb packages. Fixes GH-91
- Improvement: New config option to allow the user to choose if old versions of modified files should be moved to the trash or not. Default to ON. Thanks to NovaKing.
- Improvement: Executing php scripts with open_basedir=/ to override whatever the default might be in php.ini; need that to be able to work on files from all drives, write logs, etc.
- Improvement: Minor changes to init.d script (for CentOS mostly)


Related issues

Related to greyhole - Bug #1343: Amahi-greyhole 0.9.49 not working correctly Closed 04/12/2014

History

#2 Updated by bigfoot65 over 7 years ago

Change log:
What's new in 0.9.49
--------------------
- Bugfix: prevent warnings that would appear if something gets logged before the timezone setting is parsed and applied.
- Bugfix: disk visualization web-app was broken.

#3 Updated by cpg over 7 years ago

this one does not build cleanly for me either. thanks for the update.
I would discourage linking to unsupported rpms. less headaches.

#4 Updated by bigfoot65 over 7 years ago

Sorry, forgot I should have linked to the source not the actual RPM. Sounds like this is becoming a PITA app.

#5 Updated by cpg over 7 years ago

Not really a PITA. I am more the PITA that insists on certain principles as to what we should put in front of our users.

that said, i am taking a look.

#6 Updated by cpg over 7 years ago

latest at alpha.amahi.org/tmp/amahi-greyhole-0.9.49-1.x86_64.rpm

if you can please test. if all goes well we can put in the repos.

#7 Updated by bigfoot65 over 7 years ago

Tested and appears to be working as expected. I did notice one thing:

Apr 12 02:54:05 INFO daemon: Greyhole (version VERSION) daemon started.

When you just enter greyhole, same result. Not sure if this is a bug in Greyhole or a problem with the build.

It does work correctly though despite this anomoly.

#8 Updated by bigfoot65 over 7 years ago

BTW, the last amahi-greyhole version (0.9.44) reported correctly. That tends to make me think it's a Greyhole issue and not the Amahi build.

#9 Updated by cpg over 7 years ago

ok, amahi-greyhole-0.9.49 released 32 and 64 bits.

#10 Updated by cpg over 7 years ago

  • Status changed from Assigned to Closed

Also available in: Atom