Project

General

Profile

Bug #1336

Amahi Sync integration in the platform

Added by cpg over 6 years ago. Updated over 6 years ago.

Status:
Feedback
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
04/03/2014
Due date:
% Done:

0%


Description

Here is a bit of a UI for Amahi Sync integration with the platform.

Please do not distribute because this code has DB changes. Prefer if you can test on a VM and snapshot the VM before you install this in, in case it hoses things in the db.

alpha.amahi.org/tmp/hda-platform-7.2.2-1.x86_64.rpm

after install go to setup > shares. each share should have an Amahi Sync checkbox. initially all shares should have it disabled, except Public. this is important -- please check this.

at the moment, the UI has not effect yet, the Amahi Sync client with integration needs to be installed (almost ready), but we want to test it first.

History

#1 Updated by bigfoot65 over 6 years ago

  • Status changed from New to Feedback
  • Target version set to amahi-7-2

Tested the new platform and the Amahi-Sync check box was present in all shares. I checked and unchecked each to ensure it had the appearance of working.

Created a new share and it also had the Amahi-Sync checkbox. Checked and unchecked with no issues.

Also verified that Public was already enabled by default.

#2 Updated by cpg over 6 years ago

OK, we have an initial version of Amahi Sync in alpha for testing.

It has the following known issues:
  • removing shares from sync does not work
  • nor changing the path of a share
  • adding a share for sync can be done but only works after restarting the service
  • listing the files in non-public shares works, however, accessing the non-public files in the amahi.me domain does not work yet.

Please test on a VM if possible.

Here is how to install:

    alpha.amahi.org/tmp/amahi-sync-0.22-1.x86_64.rpm
    alpha.amahi.org/tmp/hda-platform-7.2.2-1.x86_64.rpm

please provide feedback.

#3 Updated by bigfoot65 over 6 years ago

Not exactly sure what to test.

It installs fine. The service did not start automatically. Added a share, selected sync, and enabled sync on an existing share.

There is no log file being generated, so I don't know what it's doing. A status check reflects it is running.

#4 Updated by cpg over 6 years ago

when you add the share, did that share show up on your amahi.org control panel under amahi sync?

#5 Updated by bigfoot65 over 6 years ago

Both shares are now showing on amahi.org. Uploaded a file to each and they are showing as well.

Also available in: Atom