Project

General

Profile

Bug #1343

Amahi-greyhole 0.9.49 not working correctly

Added by doaserver over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Target version:
Start date:
04/12/2014
Due date:
% Done:

0%


Description

System: 3.13.9-100.fc19.x86_64 ,x86_64
Platform: 7.2-1
Core: 5.1.4-1

Today my greyhole installation was updated to 0.9.48. Now it is logging in debug-mode and my available diskspace is not correct:

Here is what greyhole logged after the update:

Apr 12 16:43:33 DEBUG daemon: Loading metadata store backup directories...
Apr 12 16:43:33 INFO daemon: Restoring settings from last backup: /var/hda/drives/drive2/greyholeStorage/.gh_settings.bak
Apr 12 16:43:33 DEBUG daemon: Loading metadata store backup directories...
Apr 12 16:43:33 DEBUG daemon: Found 2 directories in the settings table.
Apr 12 16:43:34 DEBUG daemon: Checking symlink at /usr/lib64/samba/vfs/greyhole.so...
Apr 12 16:43:34 WARN daemon: Greyhole VFS module for Samba was missing, or the wrong version for your Samba. It will now be replaced with a symlink to /usr/lib64/greyhole/greyhole-samba40.so
Apr 12 16:43:34 INFO daemon: The Samba daemon will now restart...
Apr 12 16:43:34 DEBUG simplify_tasks: Simplifying pending tasks.
Apr 12 16:43:34 DEBUG sleep: Nothing to do... Sleeping.
Apr 12 16:43:44 DEBUG sleep: Nothing to do... Sleeping.
Apr 12 16:43:54 DEBUG sleep: Nothing to do... Sleeping.
Apr 12 16:44:04 DEBUG sleep: Nothing to do... Sleeping.

Sorry when I assigned it to the wrong user.


Related issues

Related to greyhole - Feature #1335: Update amahi-greyhole to 0.9.48 Closed 03/31/2014

History

#1 Updated by bigfoot65 over 6 years ago

The debug is normal according to the greyhole.conf file.

  1. Available verbosity levels: DEBUG, INFO, WARN, ERROR
  2. Note that for --status to work correctly, you'll need to keep this to DEBUG.

    log_level = DEBUG

Not sure about the trash share though. May need to remove the share, then add it back.

#2 Updated by bigfoot65 over 6 years ago

Something really odd is going on with the shares. Most of mine are reflecting the same diskspace.

http://i.imgur.com/dOHlCI0.png

Not sure if the latest Greyhole is causing this or not.

#3 Updated by bigfoot65 over 6 years ago

  • Priority changed from Normal to Urgent

Definitely a bug in the latest amahi-greyhole. To correct, I did the following:

yum downgrade amahi-greyhole

Edit /etc/yum.conf and added to the bottom of the file:
exclude=amahi-greyhole

This will revert to the previous version and prevent it from upgrading until this is resolved.

Recommend we remove the this version from the repo until fixed. The previous version is 0.9.44-2.

#4 Updated by doaserver over 6 years ago

bigfoot65 wrote:

Definitely a bug in the latest amahi-greyhole. To correct, I did the following:

yum downgrade amahi-greyhole

Edit /etc/yum.conf and added to the bottom of the file:
exclude=amahi-greyhole

This will revert to the previous version and prevent it from upgrading until this is resolved.

Recommend we remove the this version from the repo until fixed. The previous version is 0.9.44-2.

I did nearly the same!
Restored from a backup I made yesterday and blocked the update.

Will wait until the problem is fixed.

#5 Updated by cpg over 6 years ago

and this is why we need to test thoroughly and not jump to releasing so fast.
we really don't need, nor can take, this sort of unnecessary, avoidable, urgent interruption to our plans.

#6 Updated by bigfoot65 over 6 years ago

Sorry I did not catch the issue. I did test everything at least I thought, including adding files and watching the log file.

I did not notice the disk partitions as never thought to check that page. I have never encountered that issue before, otherwise I would have thought to check it too.

I know for next time. Guess I need to build a checklist so I remember to check all these items. I did a manual upgrade of changed files to check the validity of the latest Greyhole source. If I did it correctly, all looks fine so far other than the version not being displayed.

#7 Updated by bigfoot65 over 6 years ago

What's odd is the test machine I used is experiencing no issues. I have the mount_shares_locally installed on it as well.

The mounts page reflects correctly. Using latest platform as well. I used the VM Server, the Amahi Express CD VM. It has one greyhole drive with 1 file in a folder.

#8 Updated by cpg over 6 years ago

  • Subject changed from Amahi-greyhole 0.9.48 not working correctly to Amahi-greyhole 0.9.49 not working correctly

can you guys build al list of symptoms of this bug?

#9 Updated by bigfoot65 over 6 years ago

Here's what I saw:

1. Issuing greyhole at command prompt did not yield version.
2. Any share that is network mapped in Windows does not correctly reflect the actual drive space. It shows 1MB.
3. When using mount_shares_locally, they appear in the Disk tab, Partition option. They are also reflected as 1MB. This only applies to Greyhole enabled shares. Any other share appears correctly.
4. The log file reflects DEBUG on every line. Not sure if this is a bug as the greyhole.conf file indicates that this is normal.

That is all I noticed on my production HDA. On the test HDA, only #1 and #4 showed.

#10 Updated by bigfoot65 over 6 years ago

To clarify #2, this only applies to Greyhole enabled shares. My Public share is not part of Greyhole and it displayed the disk space correctly.

#11 Updated by cpg over 6 years ago

This is what the GH developers say:

The log format changed a little a couple of versions ago; what was numbers before are now words, for the log level. Numbers are for syslog only.

The incorrect free space reports would be an issue with greyhole-dfree. Users should try to execute it from the command line, to see what appears.

Also: the output of this should be included in bug reports: https://github.com/gboudreau/Greyhole/wiki/GetHelp > Gather system information

#12 Updated by bigfoot65 over 6 years ago

I think I see the issue. /usr/share/greyhole/greyhole-dfree.php is missing. When you execute greyhole-dfree from command line, it says:

/bin/greyhole-dfree: line 20: /usr/share/greyhole/greyhole-dfree.php: No such file or directory

I pulled it from the Greyhole source file, placed it in /usr/share/greyhole with execute permissions and now drives reporting correctly.

#13 Updated by bigfoot65 over 6 years ago

BTW, I forgot to mention the result of rpm -ql amahi-greyhole:

http://ur1.ca/h2lhx

#14 Updated by cpg over 6 years ago

alpha.amahi.org/tmp/amahi-greyhole-0.9.49-2.x86_64.rpm

#15 Updated by bigfoot65 over 6 years ago

The file is not found at that URL.

#16 Updated by cpg over 6 years ago

  • Status changed from New to Closed

users verified the fix. the update has been released.

Also available in: Atom