Project

General

Profile

Bug #1393

Video Controls Placing

Added by ming about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
UI/UX
Target version:
-
Start date:
05/31/2014
Due date:
% Done:

0%


Description

Video controls shouldn’t be overlapped via system bars.

History

#1 Updated by ming about 8 years ago

android:fitsSystemWindows should do the trick but it surprisingly doesn’t work or I’m doing wrong things. There is the API demo — XML and Java. Sony published an article as well.

#2 Updated by megabitdragon about 8 years ago

I asked about this on android-dev freenode channel and a couple of guys said the solution is to make a custom media control. Bummer.
I found this blog (http://www.brightec.co.uk/blog/custom-android-media-controller) where they start with the android media controller and modify it. Maybe it is something we can consider if we have no other options.

#3 Updated by ming about 8 years ago

The problem is not about the view, it is about the layout. Give me any view that fits system bars and I'll fit existing controls.

#4 Updated by megabitdragon about 8 years ago

I totally agree with you but,but what will be the solution? Whatever I tried didn't work.

#5 Updated by ming about 8 years ago

I’ll try to change the layout we have, but just writing another view will not solve this, it will not fit as well.

#6 Updated by ming about 8 years ago

  • Status changed from New to Closed

Fixed!

Also available in: Atom