Project

General

Profile

Bug #1401

Transmission App not working

Added by vegaramos1 over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Apps
Target version:
-
Start date:
06/05/2014
Due date:
% Done:

0%


Description

I am running Amahi 7/Fedora 19. I had the Transmission app running successfully on my HDA, then one day it just stopped working. I tried uninstalling/reinstalling the Transmission application, but that didn't help. I tried getting help from the forums, but we weren't able to get it working. Please see the forums link below.

https://forums.amahi.org/viewtopic.php?f=26&t=5389

transmission.txt View (5.83 KB) bigfoot65, 07/30/2014 01:34 PM

transmission-myhda.rtf (5.67 KB) vegaramos1, 07/30/2014 08:52 PM

status-output.txt View (3.71 KB) vegaramos1, 08/01/2014 07:52 PM

History

#1 Updated by bigfoot65 over 5 years ago

  • Status changed from New to Feedback
  • Assignee set to vegaramos1

Have not been able to duplicate the issue. Is there anything you have done manually to the HDA? Are OS updates installed? What other apps are installed?

#2 Updated by vegaramos1 over 5 years ago

  • Assignee changed from vegaramos1 to bigfoot65

I don't think I did anything to the HDA that would have caused this issue (but I never rule it out, LOL). Current apps I have installed are:

  • phpSysinfo
  • Webmin
  • DLNA
  • OwnCloud 6
  • Transmission
  • Amahi TimeMachine
  • Amahi Sync
  • OpenVPN
  • Amahi Anywhere
  • Crashplan

Not an app, but I've also mounted my shares locally. I also have smartmontools configured on my HDA. I've also tried to get mt-daapd working again on so that is installed (but still not working). I also have btsync installed, but that was just done this weekend (long after this problem arose).

I have also updated my HDA using "yum -y update" to no avail.

Thanks

#3 Updated by bigfoot65 over 5 years ago

  • Assignee changed from bigfoot65 to vegaramos1
  • Target version changed from amahi-7-0 to amahi-7-2

OK, just wanted an idea of how your system is configured. Not sure if I will be able to sort this out for you as I have no issues on my test machine.

Will see what I can do as time permits.

#4 Updated by bigfoot65 over 5 years ago

Please try an uninstall and reinstall. Do the following as root user after you uninstall.

yum erase transmission-daemon
rm -rf /usr/share/transmission
rm -rf /etc/cron.d/amahi-transmission

#5 Updated by vegaramos1 over 5 years ago

I uninstalled the app, then entered the following commands:

sudo yum erase transmission-daemon

Got the following response:

_Loaded plugins: fastestmirror, langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package transmission-daemon.x86_64 0:2.80-2.fc19 will be erased
--> Processing Dependency: transmission-daemon >= 2.80 for package: amahi-transmission-0.3-1.noarch
--> Running transaction check
---> Package amahi-transmission.noarch 0:0.3-1 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size ================================================================================
Removing:
transmission-daemon x86_64 2.80-2.fc19 @updates 533 k
Removing for dependencies:
amahi-transmission noarch 0.3-1 installed 3.4 k

Transaction Summary ================================================================================
Remove 1 Package (+1 Dependent package)

Installed size: 536 k
Is this ok [y/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
/var/tmp/rpm-tmp.GlrYJP: line 1: fg: no job control
error: %preun(amahi-transmission-0.3-1.noarch) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package amahi-transmission-0.3-1.noarch
error: amahi-transmission-0.3-1.noarch: erase failed
Erasing : transmission-daemon-2.80-2.fc19.x86_64 1/2
Verifying : amahi-transmission-0.3-1.noarch 1/2
Verifying : transmission-daemon-2.80-2.fc19.x86_64 2/2

Removed:
transmission-daemon.x86_64 0:2.80-2.fc19

Failed:
amahi-transmission.noarch 0:0.3-1

Complete!_

Then I entered the remaining two commands

sudo rm -rf /usr/share/transmission
sudo rm -rf /etc/cron.d/amahi-transmission

I installed Transmission again, but still doesn't work.

systemctl | grep transmission
amahi-transmission.service loaded failed failed SYSV: This is a daemon which runs on the server to download torrents
[alvin@localhost ~]$ sudo systemctl restart amahi-transmission.service
Job for amahi-transmission.service failed. See 'systemctl status amahi-transmission.service' and 'journalctl -xn' for details.

#6 Updated by bigfoot65 over 5 years ago

Can you show all the results from
systemctl status amahi-transmission.service

This is an isolated incident it appears as I cannot reproduce. I did see where the removal of amahi-transmission failed so that might be a sign of a problem on your machine.

#7 Updated by vegaramos1 over 5 years ago

The results of systemctl start amahi-transmission.service is :

-------------------------------------------------------------------------------------------------------------------
amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
Active: failed (Result: exit-code) since Thu 2014-07-10 22:12:21 CDT; 1min 24s ago
Process: 30191 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=203/EXEC)

Jul 10 22:12:21 localhost.localdomain systemd1: Starting SYSV: This is a daemon which runs on the server to download torrents...
Jul 10 22:12:21 localhost.localdomain systemd1: amahi-transmission.service: control process exited, code=exited status=203
Jul 10 22:12:21 localhost.localdomain systemd1: Failed to start SYSV: This is a daemon which runs on the server to download torrents.
Jul 10 22:12:21 localhost.localdomain systemd1: Unit amahi-transmission.service entered failed state.
Jul 10 22:13:51 localhost.localdomain systemd1: Starting SYSV: This is a daemon which runs on the server to download torrents...
Jul 10 22:13:51 localhost.localdomain systemd30255: Failed at step EXEC spawning /etc/rc.d/init.d/amahi-transmission: No such file or directory
Jul 10 22:13:51 localhost.localdomain systemd1: amahi-transmission.service: control process exited, code=exited status=203
Jul 10 22:13:51 localhost.localdomain systemd1: Failed to start SYSV: This is a daemon which runs on the server to download torrents.
Jul 10 22:13:51 localhost.localdomain systemd1: Unit amahi-transmission.service entered failed state.
-------------------------------------------------------------------------------------------------------------------------------

I retried the previous instructions, and I noticed an error when installing the transmission application. From the amahi-app-installer.log


======= app install begin @ 2014-07-10 22:12:08 -0500 ==========
Installing app id csjnit42fq under /var/hda/platform/html/script/.. ENV=production
file /var/hda/tmp/amahi-download-cache/84515cad07a3f66fe6ae2a32e78be42dd22f72a1 written in cache
Your HDA services have been restarted.
Your HDA services have been restarted.
/var/hda/web-apps/transmission/elevated/install.sh: line 5: /usr/share/transmission/torrentwatch.sh: No such file or directory
chmod: cannot access ‘/usr/share/transmission/torrentwatch.sh’: No such file or directory
App: Transmission installed ======= app install end @ 2014-07-10 22:12:15 0500 ==========
------------------------------------------------------------------------------------------------------------------

Looks like I'm missing a file torrentwatch.sh, actually the /usr/share/transmission directory is also missing.

#8 Updated by bigfoot65 over 5 years ago

Ok, ensure the application is uninstalled. Then do:
yum install amahi-transmission

Now try installing the app and report back. You may need to reboot the HDA afterwards.

#9 Updated by vegaramos1 over 5 years ago

Nothing is updated...

[alvin@localhost ~]$ sudo yum install amahi-transmission
Loaded plugins: fastestmirror, langpacks, refresh-packagekit
Loading mirror speeds from cached hostfile * fedora: fedora.mirror.constant.com * rpmfusion-free: mirror.us.leaseweb.net * rpmfusion-free-updates: mirror.us.leaseweb.net * rpmfusion-nonfree: mirror.us.leaseweb.net * rpmfusion-nonfree-updates: mirror.us.leaseweb.net * updates: fedora.bhs.mirrors.ovh.net
Package matching amahi-transmission-0.2-5.noarch already installed. Checking for update.
Nothing to do

#10 Updated by bigfoot65 over 5 years ago

Did you reinstall the app after doing that update? I am at a loss as what to try next. It works fine for me and I have not been able to duplicate your issue as of yet.

#11 Updated by vegaramos1 over 5 years ago

I've installed, erased, re-installed, in several different combinations trying to find a work around. Kind of feels like "amahi-transmission.noarch 0:0.3-1" is corrupt, since it seems as if a script is missing, and it can't be removed, but that's just my ignorant assessment.

#12 Updated by bigfoot65 over 5 years ago

Agreed. Something is amiss with that package. I will ask our developer to take a look.

#13 Updated by bigfoot65 over 5 years ago

I have updated the app to install differently. Can you try uninstalling it, then do clean up as mentioned before. Ensure you remove the transmission-daemon before doing clean up.

Once all that is done and you are sure all the pieces are removed, reboot the HDA. Then when it's back up, install the app.

I hope this works this time, but if not then we will have to explore a different solution which involves removing the amahi-transmission RPM somehow.

#14 Updated by vegaramos1 over 5 years ago

Followed the directions again. Still not joy, but the error is different this time.

[alvin@localhost ~]$ sudo systemctl status amahi-transmission.service
[sudo] password for alvin:
amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
Active: failed (Result: exit-code) since Fri 2014-07-18 10:13:54 CDT; 30s ago
Process: 2090 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=1/FAILURE)

Jul 18 10:13:54 localhost.localdomain systemd1: Starting SYSV: This is a daemon which runs on the server to dow...s...

Jul 18 10:13:54 localhost.localdomain amahi-transmission2090: /etc/rc.d/init.d/amahi-transmission: line 34: [: =...ted

Jul 18 10:13:54 localhost.localdomain amahi-transmission2090: gzip: level1.gz: unexpected end of file
Jul 18 10:13:54 localhost.localdomain amahi-transmission2090: chown: cannot access ‘level1’: No such file or...ory
Jul 18 10:13:54 localhost.localdomain runuser2101: pam_unix(runuser:session): session opened for user transmiss...d=0)

Jul 18 10:13:54 localhost.localdomain transmission-daemon2103: transmission-daemon Error loading config file -- ...98)

Jul 18 10:13:54 localhost.localdomain systemd1: amahi-transmission.service: control process exited, code=exited...us=1

Jul 18 10:13:54 localhost.localdomain systemd1: Failed to start SYSV: This is a daemon which runs on the server...nts.

Jul 18 10:13:54 localhost.localdomain systemd1: Unit amahi-transmission.service entered failed state.

Checked the amahi-app-installer.log looks like the same issue, torrentwatch.sh still missing.

Installing app id csjnit42fq under /var/hda/platform/html/script/.. ENV=production
Your HDA services have been restarted.
Your HDA services have been restarted.
Installing amahi-transmission service
Enabling amahi-transmission service
Starting amahi-transmission (via systemctl): Job for amahi-transmission.service failed. See 'systemctl status amahi-tra
nsmission.service' and 'journalctl -xn' for details.
[FAILED]
/var/hda/web-apps/transmission/elevated/install.sh: line 10: /usr/share/transmission/torrentwatch.sh: No such file or di
rectory
chmod: cannot access ‘/usr/share/transmission/torrentwatch.sh’: No such file or directory
App: Transmission installed

#15 Updated by bigfoot65 over 5 years ago

I will take another look and see what I can figure out. Don't understand why it's not working as it works fine for me. The torrentwatch.sh file should be created. Can you do a search and see if it got created somewhere else?

I will let you know when it's ready to try again.

#16 Updated by vegaramos1 over 5 years ago

I tried searching for torrentwatch.sh and didn't get any hits:


[alvin@localhost /]$ sudo find -name torrentwatch.sh
[sudo] password for alvin:
[alvin@localhost /]$

I also searched on transmission, but don't see it listed anywhere:

[alvin@localhost /]$ sudo find -name transmission\*
[sudo] password for alvin:
./var/lib/transmission
./var/lib/transmission/.config/transmission-daemon
./var/hda/web-apps/transmission
./usr/share/applications/transmission-gtk.desktop
./usr/share/man/man1/transmission-show.1.gz
./usr/share/man/man1/transmission-edit.1.gz
./usr/share/man/man1/transmission-create.1.gz
./usr/share/man/man1/transmission-remote.1.gz
./usr/share/man/man1/transmission-cli.1.gz
./usr/share/man/man1/transmission-gtk.1.gz
./usr/share/man/man1/transmission-daemon.1.gz
./usr/share/doc/transmission-common-2.80
./usr/share/icons/hicolor/32x32/apps/transmission.png
./usr/share/icons/hicolor/48x48/apps/transmission.png
./usr/share/icons/hicolor/256x256/apps/transmission.png
./usr/share/icons/hicolor/scalable/apps/transmission.svg
./usr/share/icons/hicolor/24x24/apps/transmission.png
./usr/share/icons/hicolor/22x22/apps/transmission.png
./usr/share/icons/hicolor/16x16/apps/transmission.png
./usr/share/icons/HighContrast/32x32/apps/transmission.png
./usr/share/icons/HighContrast/48x48/apps/transmission.png
./usr/share/icons/HighContrast/256x256/apps/transmission.png
./usr/share/icons/HighContrast/24x24/apps/transmission.png
./usr/share/icons/HighContrast/22x22/apps/transmission.png
./usr/share/icons/HighContrast/16x16/apps/transmission.png
./usr/share/pixmaps/transmission.png
./usr/share/locale/pa/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/eo/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/gl/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/fr/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/bs/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ca@valencia/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/en_AU/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ru/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/nn/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/pt_BR/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ky/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ceb/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ur/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/sl/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/fi/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/sw/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/sq/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/fo/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/pl/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/en_GB/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/bg/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/sv/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/hu/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/sr/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ko/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/pt/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/kk/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/nl/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/he/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/nds/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/oc/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ml/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/is/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ga/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ka/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ja/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/it/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ca/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/be/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/te/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/si/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/bn/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/nb/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ug/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ast/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/az/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/hi/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/zh_CN/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/bo/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ar/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ta_LK/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/mk/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ro/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/tl/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/eu/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/uk/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ia/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/mr/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/br/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/tr/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/an/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/cs/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/es/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/zh_TW/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/sk/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/uz/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/vi/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/li/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/my/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ku/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/lv/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/gv/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/be@latin/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/de/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/el/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/fa/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/en_CA/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/lt/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ms/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/da/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/fil/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/hy/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/id/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/mt/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/et/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/ckb/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/th/LC_MESSAGES/transmission-gtk.mo
./usr/share/locale/hr/LC_MESSAGES/transmission-gtk.mo
./usr/lib/systemd/system/transmission-daemon.service
./usr/lib/firewalld/services/transmission-client.xml
./usr/bin/transmission-gtk
./usr/bin/transmission-show
./usr/bin/transmission-remote
./usr/bin/transmission-daemon
./usr/bin/transmission-edit
./usr/bin/transmission-create
./usr/bin/transmission-cli
./home/alvin/transmission-search.txt
./home/alvin/.config/transmission-daemon

#17 Updated by bigfoot65 over 5 years ago

Here's the fix:
1. Uninstall Transmission app
2. cd /usr/share
3. amahi-download transmission-fix.tar.gz 8140c3f69e6c497b424d942268520c32176137d2
4. tar -xzpf transmission-fix.tar.gz
5. rm -rf transmission-fix.tar.gz
6. Install Transmission app

You should not see any errors in the install log.

The problem was removing the /usr/share/transmission directory broke the transmission-daemon package. Reinstalling transmission-daemon did not add back the appropriate files needed. That was basically the /usr/share/transmission/webapp directory and it's contents.

For future, it's important to not remove /usr/share/transmission directory or it will break the package. This was my fault of course.

#18 Updated by vegaramos1 over 5 years ago

I feel like we are getting closer, but unless I did something wrong, it still doesn't work.

=======  app uninstall begin    @  2014-07-18 21:00:38 -0500 ==========
Uninstalling app id csjnit42fq under /var/hda/platform/html/script/.. ENV=production
Stopping amahi-transmission (via systemctl):  [  OK  ]
Disabling amahi-transmission service
Your HDA services have been restarted.
App: Transmission uninstalled
=======  app uninstall end      @  2014-07-18 21:00:45 -0500 ==========
=======  app install begin      @  2014-07-18 21:04:52 -0500 ==========
Installing   app id csjnit42fq under /var/hda/platform/html/script/.. ENV=production
Your HDA services have been restarted.
Your HDA services have been restarted.
Installing amahi-transmission service
Enabling amahi-transmission service
Starting amahi-transmission (via systemctl):  Job for amahi-transmission.service failed. See 'systemctl status amahi-transmission.service' and 'journalctl -xn' for details.
[FAILED]
App: Transmission installed
=======  app install end        @  2014-07-18 21:05:06 -0500 ==========
[alvin@localhost log]$ systemctl status amahi-
amahi-anywhere.service      amahi-sync.service
amahi-greyhole.service      amahi-transmission.service
amahi-installer.service     
[alvin@localhost log]$ systemctl status amahi-transmission.service 
amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
   Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
   Active: failed (Result: exit-code) since Fri 2014-07-18 21:05:07 CDT; 1min 21s ago
  Process: 34115 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=1/FAILURE)

Jul 18 21:05:07 localhost.localdomain systemd[1]: Starting SYSV: This is a da...
Jul 18 21:05:07 localhost.localdomain amahi-transmission[34115]: /etc/rc.d/in...
Jul 18 21:05:07 localhost.localdomain amahi-transmission[34115]: gzip: level1...
Jul 18 21:05:07 localhost.localdomain amahi-transmission[34115]: chown: canno...
Jul 18 21:05:07 localhost.localdomain runuser[34135]: pam_unix(runuser:sessio...
Jul 18 21:05:07 localhost.localdomain transmission-daemon[34137]: transmissio...
Jul 18 21:05:07 localhost.localdomain runuser[34135]: pam_unix(runuser:sessio...
Jul 18 21:05:07 localhost.localdomain systemd[1]: amahi-transmission.service:...
Jul 18 21:05:07 localhost.localdomain systemd[1]: Failed to start SYSV: This ...
Jul 18 21:05:07 localhost.localdomain systemd[1]: Unit amahi-transmission.ser...
Jul 18 21:06:37 localhost.localdomain systemd[1]: Starting SYSV: This is a da...
Jul 18 21:06:37 localhost.localdomain amahi-transmission[34277]: /etc/rc.d/in...
[alvin@localhost log]$ journalctl -xn
-- Logs begin at Sat 2014-03-29 20:57:17 CDT, end at Fri 2014-07-18 21:06:37 CDT. --
Jul 18 21:06:37 localhost.localdomain amahi-transmission[34277]: /etc/rc.d/init.d/amahi-transmission: line 34: [: =: unary operator expected
Jul 18 21:06:37 localhost.localdomain amahi-transmission[34277]: gzip: level1.gz: unexpected end of file
Jul 18 21:06:37 localhost.localdomain amahi-transmission[34277]: chown: cannot access ‘level1’: No such file or directory
Jul 18 21:06:37 localhost.localdomain runuser[34289]: pam_unix(runuser:session): session opened for user transmission by (uid=0)
Jul 18 21:06:37 localhost.localdomain transmission-daemon[34291]: transmission-daemon Error loading config file -- exiting. (daemon.c:498)
Jul 18 21:06:37 localhost.localdomain runuser[34289]: pam_unix(runuser:session): session closed for user transmission
Jul 18 21:06:37 localhost.localdomain amahi-transmission[34277]: [49B blob data]
Jul 18 21:06:37 localhost.localdomain systemd[1]: amahi-transmission.service: control process exited, code=exited status=1
Jul 18 21:06:37 localhost.localdomain systemd[1]: Failed to start SYSV: This is a daemon which runs on the server to download torrents.
-- Subject: Unit amahi-transmission.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit amahi-transmission.service has failed.
-- 
-- The result is failed.

#19 Updated by bigfoot65 over 5 years ago

OK there is something wrong with the service it seems. I will take a look.

#20 Updated by bigfoot65 over 5 years ago

Do this and post the results:
ll /var/lib/transmission/.config/transmission-daemon/

There may be more files you are missing.

Also I changed the URL for the blocklist as the current one was bad. Suggest you uninstall and reinstall again to test.

#21 Updated by vegaramos1 over 5 years ago

Sorry for the delay, I was out of town.

[alvin@localhost ~]$ ll /var/lib/transmission/.config/transmission-daemon/
total 20
drwxr-xr-x 2 transmission transmission 4096 Apr 21 23:53 blocklists
-rw------- 1 transmission transmission 1000 Apr 12 10:20 dht.dat
drwxr-xr-x 2 transmission transmission 4096 Apr 19 22:36 resume
-rw------- 1 transmission transmission    0 Jul 28 19:23 settings.json
-rw------- 1 transmission transmission    0 Jul 28 19:23 settings.json.bak
-rw------- 1 transmission transmission  157 Apr 19 22:37 stats.json
drwxr-xr-x 2 transmission transmission 4096 Apr 19 15:50 torrents
[alvin@localhost ~]$

#22 Updated by bigfoot65 over 5 years ago

Have you tried uninstalling and reinstalling? I tweaked the install.

#23 Updated by vegaramos1 over 5 years ago

Tried uninstalling and reinstalling again. Still not installing correctly.


=======  app install begin      @  2014-07-28 21:16:23 -0500 ==========
Installing   app id csjnit42fq under /var/hda/platform/html/script/.. ENV=production
Your HDA services have been restarted.
Your HDA services have been restarted.
Installing amahi-transmission service
Enabling amahi-transmission service
chmod: cannot access ‘/usr/share/transmission/torrentwatch.sh’: Not a directory
App: Transmission installed
=======  app install end        @  2014-07-28 21:16:40 -0500 ==========

[alvin@localhost log]$ systemctl status amahi-transmission.service 
amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
   Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
   Active: failed (Result: exit-code) since Mon 2014-07-28 21:20:04 CDT; 3s ago
  Process: 49984 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=1/FAILURE)

Jul 28 21:20:02 localhost.localdomain systemd[1]: Starting SYSV: This is a da...
Jul 28 21:20:02 localhost.localdomain amahi-transmission[49984]: /etc/rc.d/in...
Jul 28 21:20:04 localhost.localdomain amahi-transmission[49984]: chown: canno...
Jul 28 21:20:04 localhost.localdomain runuser[49998]: pam_unix(runuser:sessio...
Jul 28 21:20:04 localhost.localdomain transmission-daemon[50000]: transmissio...
Jul 28 21:20:04 localhost.localdomain systemd[1]: amahi-transmission.service:...
Jul 28 21:20:04 localhost.localdomain systemd[1]: Failed to start SYSV: This ...
Jul 28 21:20:04 localhost.localdomain systemd[1]: Unit amahi-transmission.ser...
[alvin@localhost log]$ 

#24 Updated by bigfoot65 over 5 years ago

I will have to do an install and then provide you a listing of files/permissions. You can then verify what you have and what is missing.

Something is really messed up on your HDA with this package and not sure if we will be able to fix it. I will do my best to help solve the issue, but it may take a while.

#25 Updated by bigfoot65 over 5 years ago

Check in /var/hda/web-apps/transmission/html for the torrentwatch.sh file. If it's there, copy it to /usr/share/transmission directory.

I will do an install, then try to capture all the files/permissions for the affected directories so we can compare it to your installation.

Have we tried this yet?
yum reinstall transmission-daemon

#26 Updated by bigfoot65 over 5 years ago

I have attached a text file that lists all the files that should be installed for the application to work.

Please check your installation and see what your missing if anything. Pay close attention to the file and ownership permissions.

If you find any issues, please let me know so we can figure out the root cause.

#27 Updated by vegaramos1 over 5 years ago

I followed the text file instructions, everything looks good except for the files in /usr/share/transmission. For some reason that is a file and not a directory on my machine. The files and folders under it are obviously missing as well.

The attached file shows the results, abnormalities are in red.

#28 Updated by bigfoot65 over 5 years ago

Ok, let's do this.
Download and untar this into the /usr/share directory by running the following as root user:
cd /usr/share
rm -rf transmission
amahi-download transmission-fix.tar.gz 8140c3f69e6c497b424d942268520c32176137d2
tar -xzpf transmission-fix.tar.gz

Check to see if the files now match the list. If so, then do the following as root user:
systemctl restart transmission-daemon.service
service amahi-transmission restart

If either fails, please note the errors. I am hoping that once the files match my install, it works.

#29 Updated by vegaramos1 over 5 years ago

The files under /usr/share/transmission now match your machine, but it still failed to start the service.

[root@localhost transmission]# systemctl restart transmission-daemon.service
Job for transmission-daemon.service failed. See 'systemctl status transmission-daemon.service' and 'journalctl -xn' f
details.
[root@localhost transmission]# systemctl status transmission-daemon.service
transmission-daemon.service - Transmission BitTorrent Daemon
   Loaded: loaded (/usr/lib/systemd/system/transmission-daemon.service; disabled)
   Active: failed (Result: exit-code) since Thu 2014-07-31 11:28:36 CDT; 24s ago
  Process: 23584 ExecStart=/usr/bin/transmission-daemon -f --log-error (code=exited, status=255)

Jul 31 11:28:36 localhost.localdomain systemd[1]: Starting Transmission BitTorrent Daemon...
Jul 31 11:28:36 localhost.localdomain systemd[1]: transmission-daemon.service: main process exited, code=ex.../n/a
Jul 31 11:28:36 localhost.localdomain systemd[1]: Failed to start Transmission BitTorrent Daemon.
Jul 31 11:28:36 localhost.localdomain systemd[1]: Unit transmission-daemon.service entered failed state.
[root@localhost transmission]# service amahi-transmission restart
Restarting amahi-transmission (via systemctl):  Job for amahi-transmission.service failed. See 'systemctl status amah
ransmission.service' and 'journalctl -xn' for details.
                                                           [FAILED]
[root@localhost transmission]# service amahi-transmission status
amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
   Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
   Active: failed (Result: exit-code) since Thu 2014-07-31 11:29:49 CDT; 21s ago
  Process: 23702 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=1/FAILURE)

Jul 31 11:29:45 localhost.localdomain systemd[1]: Starting SYSV: This is a daemon which runs on the server ...s...
Jul 31 11:29:45 localhost.localdomain amahi-transmission[23702]: /etc/rc.d/init.d/amahi-transmission: line 34...ed
Jul 31 11:29:49 localhost.localdomain amahi-transmission[23702]: chown: cannot access ‘blocklist.bin’: No...ry
Jul 31 11:29:49 localhost.localdomain runuser[23732]: pam_unix(runuser:session): session opened for user tra...=0)
Jul 31 11:29:49 localhost.localdomain systemd[1]: amahi-transmission.service: control process exited, code=...us=1
Jul 31 11:29:49 localhost.localdomain systemd[1]: Failed to start SYSV: This is a daemon which runs on the ...nts.
Jul 31 11:29:49 localhost.localdomain systemd[1]: Unit amahi-transmission.service entered failed state.
Jul 31 11:30:14 localhost.localdomain systemd[1]: Starting SYSV: This is a daemon which runs on the server ...s...
Jul 31 11:30:14 localhost.localdomain amahi-transmission[23771]: /etc/rc.d/init.d/amahi-transmission: line 34...ed

#30 Updated by bigfoot65 over 5 years ago

Can you please post the full text of the systemctl status commands? If needed, you can attach them in a text file.

#31 Updated by bigfoot65 over 5 years ago

Also let's try this afterwards. Uninstall the app. Then do rpm -e transmission-daemon. Check to see if the files are still in /usr/share/transmission.

Then reboot the HDA. Try reinstalling the app and let's see if it works.

#32 Updated by vegaramos1 over 5 years ago

How do I get the full text of systemctl status to display? I uninstalled the app and immediately noticed that torrent-watch.sh was deleted from /usr/share/transmission, but the /web directory is still there. I also tried:

[alvin@localhost share]$ cd transmission
[alvin@localhost transmission]$ ls
web
[alvin@localhost transmission]$ cd web
[alvin@localhost web]$ ls
images  index.html  javascript  LICENSE  style
[alvin@localhost web]$ su 
Password: 
[root@localhost web]# rpm -e transmission-daemon
error: Failed dependencies:
    transmission-daemon >= 2.80 is needed by (installed) amahi-transmission-0.3-1.noarch
[root@localhost web]# service amahi-transmission status

Should I continue to try and re-install?

Thanks!

#33 Updated by bigfoot65 over 5 years ago

To get it all, you may need to try and pipe it to a text file or fpaste.

Those files often stay behind. Your problem is getting rid of amahi-transmission. We need to figure out how to get it gone...that may be causing all the issues.

Can't hurt to try a reinstall.

#34 Updated by vegaramos1 over 5 years ago

Ok, systecmctl status is attached. I'll try a re-install.

#35 Updated by bigfoot65 over 5 years ago

Ok, lots of different stuff going on here. Not sure how to best fix it just yet. Wished we could get rid of the amahi-transmission package.

Can you try:
rpm -e amahi-transmission

Before you install.

#36 Updated by vegaramos1 over 5 years ago

[root@localhost transmission]# rpm -e amahi-transmission
/var/tmp/rpm-tmp.Fnn46K: line 1: fg: no job control
error: %preun(amahi-transmission-0.3-1.noarch) scriptlet failed, exit status 1
error: amahi-transmission-0.3-1.noarch: erase failed

#37 Updated by bigfoot65 over 5 years ago

Try this:
rpm -e --noscripts amahi-transmission

#38 Updated by vegaramos1 over 5 years ago

That seemed to work, shall I reinstall?

[root@localhost init.d]# rpm -e --noscripts amahi-transmission
[root@localhost init.d]# rpm -e --noscripts amahi-transmission
error: package amahi-transmission is not installed

#39 Updated by bigfoot65 over 5 years ago

Good, yes try this first:
yum reinstall transmission-daemon

Then reinstall the app.

#40 Updated by vegaramos1 over 5 years ago

This is so hard to believe, but the service still doesn't start.

[alvin@localhost ~]$ systemctl status amahi-transmission.service 
amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
   Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
   Active: failed (Result: exit-code) since Fri 2014-08-01 22:44:58 CDT; 47s ago
  Process: 2072 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=1/FAILURE)

Aug 01 22:44:56 localhost.localdomain systemd[1]: Starting SYSV: This is a daemon which runs on the server to download torrents...
Aug 01 22:44:56 localhost.localdomain amahi-transmission[2072]: /etc/rc.d/init.d/amahi-transmission: line 34: [: =: unary operator expected
Aug 01 22:44:58 localhost.localdomain amahi-transmission[2072]: chown: cannot access ‘blocklist.bin’: No such file or directory
Aug 01 22:44:58 localhost.localdomain runuser[2085]: pam_unix(runuser:session): session opened for user transmission by (uid=0)
Aug 01 22:44:58 localhost.localdomain transmission-daemon[2087]: transmission-daemon Error loading config file -- exiting. (daemon.c:498)
Aug 01 22:44:58 localhost.localdomain runuser[2085]: pam_unix(runuser:session): session closed for user transmission
Aug 01 22:44:58 localhost.localdomain amahi-transmission[2072]: [49B blob data]
Aug 01 22:44:58 localhost.localdomain systemd[1]: amahi-transmission.service: control process exited, code=exited status=1
Aug 01 22:44:58 localhost.localdomain systemd[1]: Failed to start SYSV: This is a daemon which runs on the server to download torrents.
Aug 01 22:44:58 localhost.localdomain systemd[1]: Unit amahi-transmission.service entered failed state.
[alvin@localhost ~]$ systemctl status amahi-transmission.service 
amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
   Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
   Active: failed (Result: exit-code) since Fri 2014-08-01 22:44:58 CDT; 1min 19s ago
  Process: 2072 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=1/FAILURE)

Aug 01 22:44:56 localhost.localdomain systemd[1]: Starting SYSV: This is a daemon which runs on the server to download torrents...
Aug 01 22:44:56 localhost.localdomain amahi-transmission[2072]: /etc/rc.d/init.d/amahi-transmission: line 34: [: =: unary operator expected
Aug 01 22:44:58 localhost.localdomain amahi-transmission[2072]: chown: cannot access ‘blocklist.bin’: No such file or directory
Aug 01 22:44:58 localhost.localdomain runuser[2085]: pam_unix(runuser:session): session opened for user transmission by (uid=0)
Aug 01 22:44:58 localhost.localdomain transmission-daemon[2087]: transmission-daemon Error loading config file -- exiting. (daemon.c:498)
Aug 01 22:44:58 localhost.localdomain runuser[2085]: pam_unix(runuser:session): session closed for user transmission
Aug 01 22:44:58 localhost.localdomain amahi-transmission[2072]: [49B blob data]
Aug 01 22:44:58 localhost.localdomain systemd[1]: amahi-transmission.service: control process exited, code=exited status=1
Aug 01 22:44:58 localhost.localdomain systemd[1]: Failed to start SYSV: This is a daemon which runs on the server to download torrents.
Aug 01 22:44:58 localhost.localdomain systemd[1]: Unit amahi-transmission.service entered failed state.
[alvin@localhost ~]$ 

#41 Updated by bigfoot65 over 5 years ago

  • Target version deleted (amahi-7-2)

Ok, uninstall and then reinstall.

Before doing so, do this:
a. Reboot HDA
b. Clear browser cache.

Also check the /var/log/amahi-app-installer.log for errors.

There is not much else left to try. Really stumped on this one.

#42 Updated by vegaramos1 over 5 years ago

I tried your latest instructions, but that didn't work either. I think I might need to re-install Amahi on this server, clearly there is something wrong with it. I'll wait till the next release....thanks for all of your assistance, I appreciate it.

#43 Updated by bigfoot65 over 5 years ago

Sorry it did not work. Would still like to resolve, so I will come up with another game plan for diagnosing.

Not sure if you are aware, but it will be a while before there is another change in OS requiring a new install. We are likely going to be using Fedora next time around as well.

#44 Updated by bigfoot65 about 5 years ago

  • Status changed from Feedback to Closed

Submitter indicated resolved in forum post.

Also available in: Atom