Project

General

Profile

Feature #1424

Audio playback stops when screen goes in standby

Added by megabitdragon about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
06/10/2014
Due date:
% Done:

0%


Description

I understand it is by design right now (or maybe I am wrong) but I think we should really use a service at least for the audio streaming. I want to listen to my music without the screen on or while browsing other apps and I think other user would like that as well.

History

#1 Updated by ming about 8 years ago

And next you wish to have controls at the notification center ;-) Not sure if iOS does it. Personally I don’t think Amahi is an audio player, Google Music does great job, but I’ll keep it in mind.

#2 Updated by megabitdragon about 8 years ago

First, I can take sarcasm, but I think it was not necessary in this case. I didn't use iOS in ages and I have no clue how it's done nor how the Amahi iOS app does it.

Having that out of the way, I just reported this from a user perspective. I started a song from my HDA and as soon as my screen went of the song stopped. Is this good user experience in your opinion? I am sure I am not the only person that will like to listen to music from their HDA and not stare at their screen while they do that. What if at some point in the future we would like to have controls in the notification center? It's that such a bad thing for the user experience? I agree google does a great job with their music app but does it mean people should stop making music player apps for that reason?

I apologize for venting on the bug tracker. Let's "keep calm and carry on".

#3 Updated by cpg about 8 years ago

we added this in ios at some point because a few people were requesting it. we have a feature to send feedback from the app directly to us.

even though we do not have multiple track play (another feature people want), people wanted it in particular for large duration things, like audiobooks, where they want to be able to listen to a whole book or whatnot in the background, while playing games, checking email, or whatever.

in the end we implemented this as well for video, so one can be watching a tv program or something, switch to email quickly and then be back, all the while without having to touch the movie/tv program playing. e.g. while a commercial is playing.

doing so, automatically made it available in the equivalent of the control center (the notification area and the lock screen) without having to code anything.

#4 Updated by ming about 8 years ago

Sorry If I made you angry, irony was for myself. The development drags me into areas I never was before, notifications is one of them.

About controls. Showing them at the lock screen is kind of nice supported, controls at the sticky notifications is completely custom.

#5 Updated by megabitdragon about 8 years ago

  • Priority changed from Normal to High

#6 Updated by megabitdragon about 8 years ago

  • Status changed from New to Closed

Nice. Closing this and I'll open other ones if I find new bugs. You can merge this branch.

#7 Updated by ming about 8 years ago

  • Status changed from Closed to Feedback
  • Assignee changed from ming to megabitdragon

Sorry, but it wasn’t actually done. That’s why I didn’t post any message or asked for feedback. Can you check it now, please? It should be much better, with pausing on headphones extraction, proper use of system audio focus so you can hear system notifications while listening, showing a notification and lock screen controls.

#8 Updated by cpg about 8 years ago

  • Status changed from Feedback to Closed

I tested it and all aspects of audio play in the background listed and they work.

I will merge it into master and release for testers.

[in the process i came across an exception while playing an mp3 that seems repeatable and filed it as bug #1455]

Also available in: Atom