Project

General

Profile

Bug #1442

crash when retrieving shares

Added by cpg about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
06/15/2014
Due date:
% Done:

0%


Description

on first launch, after logging in, i got a crash.

the return from the shares call was 200 OK, however, this crash still ocurred. i tried to reproduce, but i could not:

06-15 13:29:25.078  13493-13493/org.amahi.anywhere W/dalvikvm? threadid=1: thread exiting with uncaught exception (group=0x4157e7c0)
06-15 13:29:25.088  13493-13493/org.amahi.anywhere E/AndroidRuntime? FATAL EXCEPTION: main
    java.lang.RuntimeException: Could not dispatch event: class org.amahi.anywhere.bus.ServerSharesLoadedEvent to handler [EventHandler public void org.amahi.anywhere.fragment.NavigationFragment.onSharesLoaded(org.amahi.anywhere.bus.ServerSharesLoadedEvent)]: null
            at com.squareup.otto.Bus.throwRuntimeException(Bus.java:456)
            at com.squareup.otto.Bus.dispatch(Bus.java:386)
            at com.squareup.otto.Bus.dispatchQueuedEvents(Bus.java:367)
            at com.squareup.otto.Bus.post(Bus.java:336)
            at org.amahi.anywhere.server.response.ServerSharesResponse.success(ServerSharesResponse.java:37)
            at org.amahi.anywhere.server.response.ServerSharesResponse.success(ServerSharesResponse.java:33)
            at retrofit.CallbackRunnable$1.run(CallbackRunnable.java:45)
            at android.os.Handler.handleCallback(Handler.java:730)
            at android.os.Handler.dispatchMessage(Handler.java:92)
            at android.os.Looper.loop(Looper.java:137)
            at android.app.ActivityThread.main(ActivityThread.java:5323)
            at java.lang.reflect.Method.invokeNative(Native Method)
            at java.lang.reflect.Method.invoke(Method.java:525)
            at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:743)
            at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:559)
            at dalvik.system.NativeStart.main(Native Method)
     Caused by: java.lang.NullPointerException
            at org.amahi.anywhere.fragment.NavigationFragment.setUpSharesContent(NavigationFragment.java:287)
            at org.amahi.anywhere.fragment.NavigationFragment.onSharesLoaded(NavigationFragment.java:281)
            at java.lang.reflect.Method.invokeNative(Native Method)
            at java.lang.reflect.Method.invoke(Method.java:525)
            at com.squareup.otto.EventHandler.handleEvent(EventHandler.java:89)
            at com.squareup.otto.Bus.dispatch(Bus.java:384)
            at com.squareup.otto.Bus.dispatchQueuedEvents(Bus.java:367)
            at com.squareup.otto.Bus.post(Bus.java:336)
            at org.amahi.anywhere.server.response.ServerSharesResponse.success(ServerSharesResponse.java:37)
            at org.amahi.anywhere.server.response.ServerSharesResponse.success(ServerSharesResponse.java:33)
            at retrofit.CallbackRunnable$1.run(CallbackRunnable.java:45)
            at android.os.Handler.handleCallback(Handler.java:730)
            at android.os.Handler.dispatchMessage(Handler.java:92)
            at android.os.Looper.loop(Looper.java:137)
            at android.app.ActivityThread.main(ActivityThread.java:5323)
            at java.lang.reflect.Method.invokeNative(Native Method)
            at java.lang.reflect.Method.invoke(Method.java:525)
            at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:743)
            at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:559)
            at dalvik.system.NativeStart.main(Native Method)

History

#1 Updated by cpg about 8 years ago

  • Status changed from New to Closed

cannot reproduce

Also available in: Atom