Project

General

Profile

Bug #1492

things to do remaining in the webview

Added by cpg about 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
07/26/2014
Due date:
% Done:

0%


Description

now that we have a basic webview running (mostly1) correctly on multiple apps, here are the things we could do to make it minimally usable:

  • web history navigation: back button
  • web history navigation: forward button
  • typically, the two "buttons" above would be on the top action bar
  • the Android back button should exit directly to the apps list

about cookies and their management.

ideal situation: each app has an associated "amahi browser object", which contains a unique webview object, it's cookies and whatever else it needs to run (e.g. a JS thread).

it seems that we appear to not be able to virtualize the cookies (and we seem to have one webview object?), we may not be able to do the ideal situation.

the implication is that if the user logs in to an app (or the app keeps settings in cookies), as soon as the user exits to the app list, the user is automatically logged out, or loses all his settings.

here is an idea to make things a slightly better: lazy cookie elimination (LCE)

with LCE, the idea is for the app to ONLY delete cookies when the user is GOING into a NEW webapp. if the user goes back into the same app as before, the cookies are not deleted (hence preserved).

this entails keeping a variable with the state of the last app visited. only when a an app is tapped and this app is different than the last app visited the cookies will be deleted.

with this, at least login lasts as long as the user does not change apps.

we could do more to make this usable, however, that is probably all for the next milestone regarding functionality.

1 when using the dashboard, or any other app that requires cookies to login the user, i seem to be required to login TWICE. somehow the cookies are not set initially, but i do not why this is. i only notice it happens.

History

#1 Updated by cpg about 7 years ago

  • Description updated (diff)

#2 Updated by ming about 7 years ago

  • Status changed from New to Feedback
  • Assignee set to cpg

Can we eliminate the forward button and put back functionality to the back button? This is how it’s done for Chrome for example. I suspect that forward is rarely used.

About cookies—probably we can, it will give less pain for users. Have you got a chance to search for some kind of server-side HTTP possibilities for Vary-like behaviour? Something like “hey, we are giving you this response but cookies are dependent on the UA, not on the Host”.

#3 Updated by cpg about 7 years ago

  • Description updated (diff)

fine on forward button. i did not research server based vary-based cookies.

#4 Updated by ming about 7 years ago

Pushed.

#5 Updated by bigfoot65 about 7 years ago

Logged in to the dashboard, then went back to main screen with shares and apps menus. Was still in the apps section, but did not select anything other than Dashboard. I was prompted for user name and password again.

#6 Updated by cpg almost 7 years ago

  • Status changed from Feedback to Closed

verified that LCE works as intended. great job!

Also available in: Atom