Project

General

Profile

Bug #1507

Greyhole Plugin issues

Added by agmps17 over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
07/29/2014
Due date:
% Done:

0%

History

#1 Updated by agmps17 over 6 years ago

1)Strings are not properly localized.
2)Table being partially rounded.
3)Tables are quite large.

#2 Updated by bigfoot65 over 6 years ago

I have tested the plugin as follows:

a. added drives to the pool, selected some shares and added a few files.

b. I also did the fsck option.

c. On an existing greyhole install, it does not pick up the current settings. Those have to be done over for the drive selection. It will see the shares and number of copies initially, but loses them partially when the greyhole.conf file is rewritten by the plugin. Might be best if we recommend uninstall of amahi-greyhole before installing the plugin.

d. Also when uninstalling the plugin, it also uninstalls amahi-greyhole completely to include the database and greyhole.conf file.

The main thing I noticed is the greyhole.conf file is missing some options...plus there are some options that appear different that what the default .conf file reflects.

a. The attic setting has changed in greyhole to trash...the "delete_moves_to_attic = true" is now "delete_moves_to_trash = yes"

b. There are lines that are enabled in the default greyhole.conf but missing from the plugin:
- check_for_open_files = yes
- modified_moves_to_trash = yes
- ignored_files = \..*\.[0-9a-zA-Z]{6}
- ignored_files = [0-9A-F]{8}\.tmp
- ignored_files = \.cprestoretmp.*
- ignored_folders = .*/_UNPACK_.*

c. There are several other options that are not enabled, but potentially needed by users that are missing. Is it possible make the plugin greyhole.conf file look more like the default one?

d. As a nit picky comment, the copies and max font is too large. It should be closer to the size of the share names in my opinion.

e. I was also confused by the log entry of "storage pool? no" for each share that was Greyhole enabled. Also there was a message " Share? Docs" for each share enabled. I understand this identifies the share being updated by greyhole, but can we make is something more like "Processing share: Docs"?

I believe it has the same behavior as Amahi 6 from what I can remember. I was thinking maybe we can beef this one up over time. Add a few more sub tabs to cover some of the common things users might change or maybe a extra options box like the shares. That would allow uses to add the things that are missing from the plugin that might be needed.

#3 Updated by bigfoot65 over 6 years ago

Could these additional options be added to /var/hda/platform/html/config/greyhole.yml? If so, I could add it to the wiki and/or we could make the update down the road.

#4 Updated by cpg over 6 years ago

i added all the ignore options in one line, space separated. not sure if that works, but i did it ayway.

yes, the options in the yml file will take precedence and the user can modify anything in that file. it's meant for that.

either of these (lighter first, heavier later) will be needed to get the yaml file in effect

  • touch /var/hda/platform/html/tmp/restart.txt
  • systemctl httpd restart
  • reboot

#5 Updated by bigfoot65 over 6 years ago

Not sure I understand what these commands will do for Greyhole. I did them, but was not sure what to look for.

#6 Updated by cpg over 6 years ago

the yaml file is a configuration file. it takes precedence over the defaults.

nothing takes effect unless the rails server running the platform is restarted and at least one change to the UI is done.

the the three options i provided are ways to restart the rails server.

#7 Updated by bigfoot65 over 6 years ago

Got it. I will add something to the wiki to help explain use of the yml file.

#8 Updated by cpg over 6 years ago

  • Status changed from New to Feedback
  • Assignee set to bigfoot65

we changed defaults, so proper defaults matching the settings of the more modern GH are issued to the conf file.
examples: ignore_files, ignore_folders, drive_selection_algorithm, etc.

we also fixed a bug where max was not being shown properly in the UI.

still at version 1.1 for the plugin. please verify and close.

#9 Updated by bigfoot65 over 6 years ago

The settings are not sticking for partitions selected in the pool. I select two drives and then go to the Shares tab. It reflects no shares.

I check /etc/greyhole.conf and only see 1 drive was added. I then check the partitions tab and both drives are now unselected.

I have rebooted and cleared the browser cache.

#10 Updated by bigfoot65 over 6 years ago

Installed on my production HDA and worked perfectly. Recommend closing this bug.

#11 Updated by bigfoot65 over 6 years ago

  • Assignee changed from bigfoot65 to cpg

Just unintstalled and then installed the app due to the update. The dashboard GUI would not work :( Very similar behavior as I had indicated during testing.

I uninstalled and put back to the manual version due to necessity. I can't have my production machine not working properly with Greyhole.

I know we need to capture what is going on, so best to do that on the VM vs my production machine.

I should be able to recreate the problem quite easily.

#12 Updated by cpg over 6 years ago

We are aware of issues with Firefox (at least on mac), version at least 30 and 31. These browsers do not appear to show checkboxes and the selectors properly after refreshing the page.

Please be specific with details to reproduce one issue and we will try to reproduce. or please provide a vm for me to try it on.

#13 Updated by bigfoot65 over 6 years ago

That's exactly my issue. Using FF 31. Odd thing is I could not reproduce on the VM this time.

The issue is I would check the storage pool drives, but only 1 was added to the greyhole.conf file. When I went back to look at the UI, they were unchecked.

Next I went to shares page and nothing was reflected to choose from. When I looked at the greyhole.conf file, the shares were listed there.

Tried IE 10 and had the same behavior. I will keep trying to reproduce on the VM. Worse case, I can install the app on my production HDA and we can diagnose it. I already have the SSH set up for it too.

#14 Updated by bigfoot65 over 6 years ago

My issues are now resolved. Should we close this bug?

#15 Updated by cpg over 6 years ago

  • Subject changed from Greyhole Plugin to Greyhole Plugin issues
  • Status changed from Feedback to Closed

#16 Updated by bigfoot65 over 6 years ago

  • Status changed from Closed to Assigned

The issue that I had with the partitions is now present in the Shares section. When I select Max for copies, navigate away to another tab, then when I come back it's set to '-'.

I have checked the greyhole.conf file and it reflects num_copies = 1 for the share. This behavior was reported last night by lassenloop as well.

I did not see a problem earlier when we were testing, but I may have overlooked it as I have lots of shares.

#17 Updated by bigfoot65 over 6 years ago

  • Status changed from Assigned to Closed

This issue has been resolved by the latest update. Closing.

Also available in: Atom