Project

General

Profile

Bug #1531

OpenVPN ALS (Adito) Stops

Added by rdagijones about 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
08/16/2014
Due date:
% Done:

0%


Description

OpenVPN ALS stops working. When one goes to Settings > Servers on the Amahi Dashboard, OpenVPN ALS is stopped and will not restart. In terminal, executing "Service Adito Status" indicates that Adito has stopped. If one starts Adito from terminal it indicates that it is starting but does not actually start. Status is still stopped. I have seen OpenVPN ALS work for a few days or even weeks and then suddenly stop. I have witnessed this issue on at least 4 different Amahi 7 servers.

Starting Apache Ant by using terminal and changing directories to /var/hda/web-apps/adito/server and executing "start ant" apparently rebuilds Apache Ant. Then OpenVPN ALS will run. My guess is that an Apache Ant file is getting corrupted or something.

System stats:
Fedora 19
Amahi 7

History

#1 Updated by bigfoot65 about 7 years ago

  • Status changed from New to Feedback
  • Assignee set to rdagijones

I have been looking at this app and cannot honestly duplicate the issue. I don't see anything wrong out of the ordinary.

Will take a more in depth look when time permits.

#2 Updated by rdagijones about 7 years ago

What makes this such a difficult bug is that it seem to lack a pattern. A theory I have is that a Fedora update is causing a conflict or corrupted file with Apache Ant. Rebuilding it ("start ant" from /var/hda/web-apps/adito/server) solves the problem, though I cannot say definitively whether this fix is permanent. When I reboot the server Ant and OpenVPN ALS start as they should. I am waiting to see on those Amahi servers on which I have rebuilt Ant.

I have set up and currently service Amahi servers for several non-profit organizations. I have two servers that need to be upgraded. I will use them to try and reproduce the problem and gather data. Can anyone think of any log files or reports that would be useful for diagnoses? http://ant.apache.org/problems.html suggests "ant -verbose" to determine Apache Ant problems. How do I run OpenVPN ALS in debug mode? /var/hda/web-apps/Adito/error_log is blank even when I have this problem.

#3 Updated by bigfoot65 about 7 years ago

Honestly I am surprised it's lasted this long. Since active development stopped quite a while back, it's only a matter of time before Java or ant updates kill it.

I think your issue may have something to do with the start up script the app uses. There is a way to make it start and on reboot without using a service. If that is an option, I can give you the code you would need. It basically sets up a cron job that on reboot, will start the Adito server. That's how we used to have it in Fedora 14, then moved to a service.

Might be worth searching the HDA for log files.
find /var/hda/web-apps/adito/server -name *.log

#4 Updated by rdagijones about 7 years ago

Just tried to install OpenVPN ALS app on my personal server. Installation completes but does not run. Checking /var/hda/web-apps/adito/server/logs/adito.log I get the following:

[Wrapper-Connection] ERROR Main - Failed to start the server. The host name or address on which this service is running could not be determined. Check you network configuration. One possible cause is a misconfigured 'hosts' file (e.g. on UNIX-like systems this would be /etc/hosts, on Windows XP it would be C:\Windows\System32\Drivers\Etc\Hosts).
java.lang.Exception: The host name or address on which this service is running could not be determined. Check you network configuration. One possible cause is a misconfigured 'hosts' file (e.g. on UNIX-like systems this would be /etc/hosts, on Windows XP it would be C:\Windows\System32\Drivers\Etc\Hosts).
at com.adito.server.Main.start(Main.java:350)
at org.tanukisoftware.wrapper.WrapperManager.startInner(WrapperManager.java:1785)
at org.tanukisoftware.wrapper.WrapperManager.handleSocket(WrapperManager.java:2384)
at org.tanukisoftware.wrapper.WrapperManager.run(WrapperManager.java:2696)
at java.lang.Thread.run(Thread.java:745)

Also, the /var/hda/web-apps/adito/server/logs/wrapper.log file is looping the same information every 15 seconds or so:

STATUS | wrapper | 2014/08/18 21:36:34 | --> Wrapper Started as Daemon
STATUS | wrapper | 2014/08/18 21:36:34 | Launching a JVM...
INFO | jvm 1 | 2014/08/18 21:36:35 | OpenJDK Client VM warning: You have loaded library /var/hda/web-apps/adito/server/install/platforms/linux/x86/libwrapper.so which might have disabled stack guard. The VM will try to fix the stack guard now.
INFO | jvm 1 | 2014/08/18 21:36:35 | It's highly recommended that you fix the library with 'execstack c <libfile>', or link it with '-z noexecstack'.
INFO | jvm 1 | 2014/08/18 21:36:35 | Wrapper (Version 3.1.2) http://wrapper.tanukisoftware.org
INFO | jvm 1 | 2014/08/18 21:36:35 |
STATUS | wrapper | 2014/08/18 21:36:37 | <-
Wrapper Stopped

#5 Updated by rdagijones about 7 years ago

At least I solved the above problem. I uninstalled the app again,did a major update throught Software Update in Fedora and then reinstalled the app. Now it is working, though I am unsure this solves the original bug. We shall see. As for the update, I checked /var/log/yum.log to see if any updates were for Java and/or Ant but did not see anything of significance. I could list the updates here if you think it is worth persuing.

#6 Updated by bigfoot65 about 7 years ago

Please let us know how it goes. I have been unable to reproduce your issue.

#7 Updated by bigfoot65 almost 7 years ago

  • Status changed from Feedback to Closed

No reply indicated.

#8 Updated by rdagijones almost 7 years ago

This issue is back. I cannot produce the problem consistently. If I "start ant" from /var/hda/web-apps/adito/server, everything works again. I believe something is causing problems with Apache Ant.

Also available in: Atom