Project

General

Profile

Bug #1546

Plex and Amahi DNS issue

Added by nagybal almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Apps
Target version:
Start date:
09/13/2014
Due date:
% Done:

0%


Description

Were there any updates on the HDA in the couple of days?
The Plex app stopped to work and I can't recall changing anything. I can't manager my libraries, because the web-interface does not see the server.

http://plexms.vbu.hu/index.html#

I became I have found a workaround using this link.

http://hda:32400/web/index.html#

I started to look for a workaround because all the Plex Clients were able to see/play all the content just fine. The only thing new was: the server is called "localhostdomain" instead the "hda.vbu.hu" which is the address of my hda.

Any ideas? Its a really strange issue.

broken.png View (305 KB) nagybal, 09/13/2014 11:55 AM

workaround.png View (644 KB) nagybal, 09/13/2014 11:55 AM

History

#1 Updated by bigfoot65 almost 7 years ago

  • Status changed from New to Feedback
  • Assignee changed from bigfoot65 to nagybal

This sounds like a proxy issue. Have you cleared your browser cache? You can also change the URL to access the app as follows:
http://pwm.3e.sl.pt

We have not found what the cause of the proxy issues has been in the past. I would love to figure it out, but not sure where to start. Maybe check /var/hda/web-apps/plexms/logs directory for errors.

#2 Updated by nagybal almost 7 years ago

Two things:

1. The proxy works as the page "http://plexms.vbu.hu/index.html" loads... its just causing some kind of DNS miss match. The Plex web interface is unable to see its own database.

2. The page "http://hda:32400/web/index.html" works just fine. Libraries, all the content is there.

Please take a look at my config file. You might find something strange. For example the wiki page you have linked above mentions, the proxy pass suppose to be "http://hda:32400/manage/"

/etc/httpd/conf.d/1001-plexms.conf

<VirtualHost *:80>

        ServerName plexms
        ServerAlias plexms.vbu.hu

        ProxyPass / http://localhost:32400/web/
ProxyPassReverse / http://localhost:32400/web/

        DocumentRoot /var/hda/web-apps/plexms/html

        <Directory "/var/hda/web-apps/plexms/html">
                Options Indexes FollowSymLinks MultiViews
                AllowOverride AuthConfig
                Require all granted

        </Directory>

        ErrorLog  /var/hda/web-apps/plexms/logs/error_log
        CustomLog /var/hda/web-apps/plexms/logs/access_log combined env=!dontlog

</VirtualHost>

If I set the ProxyPass to "http://hda:32400/web/"

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /.

Reason: DNS lookup failure for: hda

PS: "http://hda/" works.

#3 Updated by bigfoot65 almost 7 years ago

  • Category changed from DNS to Apps

This may be related to the web UI access being driven by a port other than 80. I would think 32400 would need added to the ServerAlias line.

I may be wrong, but seems logical.

#4 Updated by nagybal almost 7 years ago

Like this?

ServerAlias plexms.vbu.hu:32400

Does not work. Could You be please more specific?

#5 Updated by cpg almost 7 years ago

  • Description updated (diff)

Let's stop speculating and trying things please.

I see that the broken.png image is not broken at all. the address is proper and it's displaying things.

So, this is not a DNS or serveralias issue.

Let's identify what is "this server" in "we can't reach this server". This is a Plex issue and the plex logs should show details.

Since you already starting to do things in the virtualhost/apache settings, it may be broken and could take much much longer to diagnose. We can't help with this, sorry.

#6 Updated by cpg almost 7 years ago

to be clear, let me put an analogy, this is the equivalent of realizing that your car radio is not working well and going into the engine and start changing wires, replacing some parts via speculation that it may be something or other without any facts. it could well be that there is a reception problem with the radio.

#7 Updated by nagybal almost 7 years ago

cpg: I have posted it on the plex forum. I hope it explains how plex works a little bit better:
https://forums.plex.tv/index.php/topic/121267-invisible-libraries-amahi-home-server/

#8 Updated by cpg almost 7 years ago

  • Status changed from Feedback to Closed

Also available in: Atom