Project

General

Profile

Bug #156

deleting root account

Added by Kaiser over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
04/28/2009
Due date:
% Done:

100%


Description

if you create a root account through the users tab in setup,
after you delete it, the root entry in /etc/passwd gets removed also.
thus disabling the use of the real root account on the system.

i have experienced this two times in a row after adding a user named root to the system using the "users" tab on the hda homepage.

History

#1 Updated by cpg over 11 years ago

how did you create a "root" user??

we put some controls in place to not allow for users that already exist from being created:

http://dl.getdropbox.com/u/364883/Amahi/cannot-create-root.png

#2 Updated by cpg over 11 years ago

  • Status changed from New to Feedback
  • Assignee set to cpg

hi,

here is a patch that fixes the issue on the server side.

rpm -Uvh http://alpha.amahi.org/noarch/hda-platform-3.1-3.noarch.rpm

however, i cannot reproduce it, even without this patch,
but somehow you managed to create it. if you could specify
how (browser, settings like javascript, etc.), it would be great.

#3 Updated by Anonymous over 11 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Applied in changeset commit:"f2a3dc47a823a170abea01a43927491e88e89e6a".

Also available in: Atom