Project

General

Profile

Bug #1586

webapps and dns aliases get stuck after a bad app install

Added by cpg almost 6 years ago. Updated over 3 years ago.

Status:
New
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
12/10/2014
Due date:
% Done:

0%


Description

something is not idempotent here.

sometimes upon a bad app install, webapps entries as well as dns_aliases entries fail to get cleaned up. this is a long-standing problem that needs to be addressed, even if we should also chase the issue of why an app failed to install (which is a grave issue to begin with).

http://dl.dropbox.com/u/364883/Screenshots/he6s.png

History

#1 Updated by cpg almost 6 years ago

also, it appears that after an app is reinstalled and these associations get pending, that the install of the app is systematically reported as an error with the usual ":(" message http://dl.dropbox.com/u/364883/Screenshots/gm0c.png

#2 Updated by bigfoot65 almost 6 years ago

  • Category set to App Install
  • Assignee set to cpg
  • Priority changed from Medium to High
  • Target version set to amahi-8-0

#3 Updated by bigfoot65 over 5 years ago

  • Project changed from platform to amahi 8 platform
  • Category deleted (App Install)
  • Target version deleted (amahi-8-0)

#4 Updated by bigfoot65 about 5 years ago

  • Project changed from amahi 8 platform to Amahi 9
  • Priority changed from High to Normal

#5 Updated by bigfoot65 over 3 years ago

  • Project changed from Amahi 9 to platform
  • Priority changed from Normal to High

Also available in: Atom