Project

General

Profile

Bug #1588

usermin issues with install script and https

Added by cpg almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Apps
Target version:
-
Start date:
12/12/2014
Due date:
% Done:

0%


Description

i tried to install usermin and i see the url is http://usermin.amahi.net .. but it appears to redirect automatically to https://usermin.amahi.net:20000

i really think we have to forbid this type of thing in apps. not only goes for https, also some high port that we can't do much about.

can you investigate why this happens?

History

#1 Updated by cpg almost 6 years ago

  • Description updated (diff)

#2 Updated by bigfoot65 almost 6 years ago

I have tried to prevent this in the past, but have not been able to with Amahi 7. When installing Usermin or Webmin, it see's OpenSSL is installed and tries to do a redirect.

To prevent it from being so ugly, I made the redirect permanent to the address. I will do more experimenting with a test app to see if I can make it work http using ProxyPass without the auto redirect to https.

#3 Updated by bigfoot65 almost 6 years ago

Made a few changes to the app and attempted to install. Received this error:
/var/hda/platform/html/vendor/bundle/ruby/gems/activeresource-4.0.0/lib/active_resource/connection.rb:144:in `handle_response': Failed. Response code = 404. Response message = Not Found. (ActiveResource::ResourceNotFound)
from /var/hda/platform/html/vendor/bundle/ruby/gems/activeresource-4.0.0/lib/active_resource/connection.rb:123:in `request'
from /var/hda/platform/html/vendor/bundle/ruby/gems/activeresource-4.0.0/lib/active_resource/connection.rb:82:in `block in get'
from /var/hda/platform/html/vendor/bundle/ruby/gems/activeresource-4.0.0/lib/active_resource/connection.rb:216:in `with_auth'
from /var/hda/platform/html/vendor/bundle/ruby/gems/activeresource-4.0.0/lib/active_resource/connection.rb:82:in `get'
from /var/hda/platform/html/vendor/bundle/ruby/gems/activeresource-4.0.0/lib/active_resource/base.rb:990:in `find_single'
from /var/hda/platform/html/vendor/bundle/ruby/gems/activeresource-4.0.0/lib/active_resource/base.rb:877:in `find'
from /var/hda/platform/html/app/models/app.rb:57:in `initialize'
from /var/hda/platform/html/vendor/bundle/ruby/gems/activerecord-4.1.4/lib/active_record/inheritance.rb:30:in `new'
from /var/hda/platform/html/vendor/bundle/ruby/gems/activerecord-4.1.4/lib/active_record/inheritance.rb:30:in `new'
from /var/hda/platform/html/script/install-app:105:in `main'
from /var/hda/platform/html/script/install-app:119:in `<main>'

Now the app does not appear in the available or installed apps area. It seems to have vanished.

#4 Updated by bigfoot65 almost 6 years ago

  • Category set to Apps
  • Status changed from Assigned to Feedback
  • Assignee changed from bigfoot65 to cpg

I finally found the magic formula to make this work with ProxyPass and no SSL. It will now install and can be accessed via usermin.domain.com

Please try and let me know the results. If it works for you, I will update Webmin to follow the same path. We should then be able to put Usermin back as LIVE.

#5 Updated by cpg almost 6 years ago

  • Status changed from Feedback to Closed

great work. works well!

Also available in: Atom