Project

General

Profile

Bug #1590

Sabnzbd+ .20 release will not install

Added by gpfleging over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Apps
Target version:
-
Start date:
12/13/2014
Due date:
% Done:

0%


Description

I attempted to upgrade the working copy I had (I think it was the .16 version). I did the uninstall from the App Page.
That looks like it completed as expected. as the directories were erased and the file in the conf.d is gone too.

I have attempted to uninstall and re-install multiple times and I keep looking for logs to see what is going on . From what I can tell it doesn't look like the service ever gets re-installed.
systemctl status sabnzbd.service
sabnzbd.service
Loaded: error (Reason: No such file or directory)
Active: inactive (dead)

Mar 22 15:57:28 h104.gwp.com systemd1: Starting SABnzbd Plus server...
Mar 22 15:57:47 h104.gwp.com systemd1: PID file /var/run/sabnzbd/sabnzbd-25915.pid not readable (yet?) after start.
Mar 22 15:57:49 h104.gwp.com systemd1: Started SABnzbd Plus server.
Mar 22 16:28:52 h104.gwp.com systemd1: Starting SABnzbd Plus server...
Mar 22 16:29:09 h104.gwp.com systemd1: PID file /var/run/sabnzbd/sabnzbd-25915.pid not readable (yet?) after start.
Mar 22 16:29:10 h104.gwp.com systemd1: Started SABnzbd Plus server.
Mar 25 12:30:06 h104.gwp.com systemd1: Starting SABnzbd Plus server...
Oct 13 15:25:26 h104.gwp.com systemd1: Starting SABnzbd Plus server...
Oct 22 16:05:27 h104.gwp.com systemd1: Stopped SABnzbd Plus server.
Oct 22 16:08:29 h104.gwp.com systemd1: Starting SABnzbd Plus server...
Oct 22 16:08:55 h104.gwp.com systemd1: PID file /var/run/sabnzbd/sabnzbd-25915.pid not readable (yet?) after start.
Oct 22 16:35:48 localhost systemd1: Starting SABnzbd Plus server...
Dec 13 10:42:00 localhost systemd1: Stopping SABnzbd Plus server...
Dec 13 10:42:00 localhost systemd1: Stopped SABnzbd Plus server.

The apache server seems to be ok:
systemctl status httpd.service
httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
Active: active (running) since Sat 2014-12-13 13:49:35 CST; 7s ago
Process: 21479 ExecStop=/usr/sbin/httpd $OPTIONS -k graceful-stop (code=exited, status=0/SUCCESS)
Process: 20697 ExecReload=/usr/sbin/httpd $OPTIONS -k graceful (code=exited, status=0/SUCCESS)
Main PID: 21491 (httpd)
Status: "Processing requests..."
CGroup: name=systemd:/system/httpd.service
??21491 /usr/sbin/httpd -DFOREGROUND
??21495 PassengerHelperAgent
??21497 Passenger spawn server
??21509 PassengerWatchdog
??21510 PassengerWatchdog
??21513 PassengerHelperAgent
??21515 Passenger spawn server
??21519 PassengerLoggingAgent
??21526 /usr/sbin/httpd -DFOREGROUND
??21527 /usr/sbin/httpd -DFOREGROUND
??21528 /usr/sbin/httpd -DFOREGROUND
??21529 /usr/sbin/httpd -DFOREGROUND
??21530 /usr/sbin/httpd -DFOREGROUND

Here is what I see in the amahi-app-installer log (just posting the initial parts I have been trying different things for hours with no luck I will just post the initial data) ======= app uninstall begin @ 2014-12-13 10:41:58 -0600 ==========
Uninstalling app id l87u14kg9n under /var/hda/platform/html/script/.. ENV=production
/tmp/run_script20141213-24179-1t7jd5d: line 1: $'\r': command not found
/tmp/run_script20141213-24179-1t7jd5d: line 2: $'\r': command not found
/tmp/run_script20141213-24179-1t7jd5d: line 22: $'\r': command not found
Stopping sabnzbd.service
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 1: $'\r': command not found
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 2: $'\r': command not found
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 3: $'\r': command not found
Backing up SABnzbd Plus settings to share
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 4: $'\r': command not found
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 5: $'\r': command not found
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 6: $'\r': command not found
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 7: $'\r': command not found
Disabling sabnzbd.service
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 8: $'\r': command not found
rm '/etc/systemd/system/multi-user.target.wants/sabnzbd.service'
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 9: $'\r': command not found
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 10: $'\r': command not found
Removing sabnzbd.service
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 11: $'\r': command not found
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 12: $'\r': command not found
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 13: $'\r': command not found
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 14: $'\r': command not found
Reloading systemctl daemon
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 15: $'\r': command not found
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 16: $'\r': command not found
Done!
/var/hda/web-apps/sabnzbdplus/elevated/stop.sh: line 17: $'\r': command not found
/tmp/run_script20141213-24179-1t7jd5d: line 23: $'\r': command not found
/tmp/run_script20141213-24179-1t7jd5d: line 24: $'\r': command not found
/tmp/run_script20141213-24179-1t7jd5d: line 25: $'\r': command not found
Your HDA services have been restarted.
App: SABnzbd Plus uninstalled ======= app uninstall end @ 2014-12-13 10:42:13 -0600 ==========

======= app install begin @ 2014-12-13 10:42:32 0600 ==========
Installing app id l87u14kg9n under /var/hda/platform/html/script/.. ENV=production
NOTICE: redirected 'http://downloads.sourceforge.net/project/sabnzbdplus/sabnzbdplus/0.7.20/SABnzbd-0.7.20-src.tar.gz' -
> 'http://tcpdiag.dl.sourceforge.net/project/sabnzbdplus/sabnzbdplus/0.7.20/SABnzbd-0.7.20-src.tar.gz' ...
file /var/hda/tmp/amahi-download-cache/6cd46350b435a19de8d53eda35a75e8230f2260e written in cache
Your HDA services have been restarted.
Your HDA services have been restarted.
/tmp/run_script20141213-24552-1g16fc9: line 1: $'\r': command not found
/tmp/run_script20141213-24552-1g16fc9: line 2: $'\r': command not found
Configuring Amahi settings
/tmp/run_script20141213-24552-1g16fc9: line 3: $'\r': command not found
/tmp/run_script20141213-24552-1g16fc9: line 147: $'\r': command not found
/tmp/run_script20141213-24552-1g16fc9: line 199: syntax error: unexpected end of file
App: SABnzbd Plus installed ======= app install end @ 2014-12-13 10:42:45 -0600 ==========

I also tried to get the install working on my 2nd server and it also fails on that server. I checked the cache directory and the cached file looks to be the same as one I download using wget.

Is it possible to get some instructions on how to go back to one of the other releases listed on source forge? Maybe I could verify that the newest release is the one that is having an issue and not something with my systems.

I have DNS turned on and pointed to my router. I am not having issues getting other apps installed or working right now. I reinstalled OPENVPN and switched over to the Greyhole UI while trying to troubleshoot this issue.

Hope this info helps...

Gerry

History

#1 Updated by bigfoot65 over 6 years ago

  • Category set to Apps
  • Status changed from New to Assigned
  • Assignee set to bigfoot65

App has been moved to BETA until we can determine the issue and correct it. The service is not being created nor are the subdirectories in the newsgroup share.

#2 Updated by gpfleging over 6 years ago

Is it possible instead of having this in beta that the older release that was working is put back?

#3 Updated by bigfoot65 over 6 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from bigfoot65 to gpfleging

The app has been fixed. Please test and report back if successful or not.

#4 Updated by gpfleging over 6 years ago

Updated version installed and it looks to be fixed.

Thanks for the quick repair

#5 Updated by bigfoot65 over 6 years ago

  • Status changed from Feedback to Closed

No further action required.

Also available in: Atom