Project

General

Profile

Bug #1662

Amahi 7 to Amahi 8 update issues

Added by cpg almost 5 years ago. Updated almost 5 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/13/2015
Due date:
% Done:

0%


Description

This is a bug to separate things from #1661, which ought to be just for Amahi 8/F21 issues.

Please post all details on upgrading from Amahi 7 to Amahi 8 here.

History

#1 Updated by bigfoot65 almost 5 years ago

Tested upgrade from pristine Amahi 7 Express DVD install with no apps to Fedora 21. During final step of upgrade, the following error was encountered:

WARNING: problems were encountered during transaction test:
  broken dependencies
    perl-PlRPC-0.2020-13.fc19.noarch requires perl-4:5.16.3-266.fc19.x86_64
    ruby-mysql-2.8.2-9.fc19.x86_64 requires ruby-libs-2.0.0.353-16.fc19.x86_64
Continue with the upgrade at your own risk.


The upgrade process was halted and no guidance provided on how to continue.

#2 Updated by bigfoot65 almost 5 years ago

Testing it again. The wiki guidance states to do:

yum update

then reboot and do it again before attempting the Fedora 21 upgrade. I followed it exactly so the broken dependencies should not exist.

No luck on the upgrade. It needs more research to see if we can get past the dependency error.

#3 Updated by megabitdragon almost 5 years ago

  • Assignee set to cpg

Here is my experience:
1. Install amahi 7.1 using express cd in a vbox using bridged network
2. disable dhcp server
3. sudo yum -y install fedup - OK
4. sudo fedup --network 21 --product=server

could not verify GPG signature: No public key

5. sudo fedup --network 21 --product=server --verbose --nogpgcheck
    WARNING: problems were encountered during transaction test:
      broken dependencies
        perl-PlRPC-0.2020-13.fc19.noarch requires perl-4:5.16.3-266.fc19.x86_64
        ruby-mysql-2.8.2-9.fc19.x86_64 requires ruby-libs-2.0.0.353-16.fc19.x86_64
    Continue with the upgrade at your own risk.

6. Reboot

fedup is doing its thing

After all this here is my system info

System    3.19.7-200.fc21.x86_64 ,x86_64
Platform    7.5.2-1
Core    5.5.1-1
Uptime    21:04:10 up 6 min, 1 user, load average: 0.03, 0.12, 0.07


7.yum check
perl-PlRPC-0.2020-13.fc19.noarch has missing requires of perl(:MODULE_COMPAT_5.16.2)
ruby-mysql-2.8.2-9.fc19.x86_64 has missing requires of libruby.so.2.0()(64bit)
Error: check all


8. sudo yum remove perl-PlRPC-0.2020-13.fc19.noarch
9. sudo yum remove ruby-mysql.x86_64
10. reboot
11. yum check
check all

Everything seems to be working

I thought it is suppose to be version 8. Why am I seeing platform 7.5?

#4 Updated by bigfoot65 almost 5 years ago

I followed the same process. The upgrade appears to be working correctly.
Updated the wiki with the additional guidance.
https://wiki.amahi.org/index.php/Amahi_8#Actual_upgrade

#5 Updated by bigfoot65 almost 5 years ago

BTW, the following packages may need to be updated for Fedora 21:

amahi-anywhere-1.40-1.x86_64
amahi-greyhole-0.9.60-3.x86_64
amahi-sync-0.20-11.x86_64

Also available in: Atom