Project

General

Profile

Bug #176

when a script contains #! in the beginning of a line, the installer still thinks it's a shebang script

Added by cpg over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Medium
Assignee:
-
Category:
-
Target version:
-
Start date:
05/10/2009
Due date:
% Done:

100%


Description

see subsonic app installer.

mv unpack program;
mkdir files;

cat > program/amahi-subsonic.sh <<'EOF'
#!/bin/sh

SUBSONIC_HOME="../files";
...

this still trips the installer thinking this script is a self-enclosed shebang script.

the problem is this:

[10:47:35](1)hda:~$ irb
irb(main):001:0> script = "sfsdf this \n#! this is a test" 
=> "sfsdf this \n#! this is a test" 
irb(main):002:0> script =~ /^#!/
=> 12
irb(main):003:0>

it should really only match at the very beginning of the script, not somewhere else in the beginning line of the script!

History

#1 Updated by Anonymous over 11 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset commit:"337dccdfd5fdd42eaf4739f171a52309bc9f2056".

Also available in: Atom