Project

General

Profile

Bug #1769

Cannot create shares in Amahi dashboard with special characters

Added by antiterror about 6 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
-
Start date:
08/06/2015
Due date:
% Done:

0%


Description

System 3.14.27-100.fc19.x86_64 ,x86_64
Platform 7.4.1-1
Core 5.4.2-1

I used to have shares containing special characters as : "08 år"
The issue is that i am not allowed to create a share with this name.
I have tried to manually edit greyhole.conf and smb.conf to include these shares, but smb.conf keeps deleting the entries (probably based on the shares created in the dashboard) This in turn keeps greyhole crashing/not initializing as there is a reference to a share not named in smb.conf

The issue is a problem as i now try to reconnect old greyhole drives containing files in those shares - my workaround will be renaming shares, mount shares locally and mount drives in a usb bay to transfer manually into the new shares.

If there is any additional information needed feel free to ask.

Br
Anders

History

#1 Updated by bigfoot65 about 6 years ago

  • Priority changed from Normal to High
  • Target version set to amahi-8-0

#2 Updated by bigfoot65 about 6 years ago

  • Project changed from platform to amahi 8 platform
  • Category deleted (Dashboard UI)
  • Assignee set to cpg
  • Target version deleted (amahi-8-0)

#3 Updated by cpg about 6 years ago

the problem is in this line in the code which validates the names of shares to make some sense. Unfortunately, it's too restrictive.

Samba does take share names like 08 år (as well it should), however, detecting that the name is valid (does not have non-printable chars, etc.) is harder to do with a regular expression for the :format validation.

one possibility is to simply remove this validation and allow anything and hope that the UI is controlling this, without much other checking in the model.

#4 Updated by cpg about 6 years ago

  • Status changed from New to Feedback

tried to fix it in this commit #7816f9f

we will need to test this.

#5 Updated by cpg almost 5 years ago

  • Status changed from Feedback to Closed

This has been verified to work on the latest code base already released on f24.

Also available in: Atom