Project

General

Profile

Bug #1779

some users reporting they cannot login

Added by cpg over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
08/19/2015
Due date:
% Done:

0%


Description

Even though we see lots of logins in the logs, some users are reporting that they are not able to login.

At this point there is enough noise to suspect an issue, possibly in the Android versions used.

However, there are a few versions being used, so it's not just the latest or very old versions of Android.

We're trying to get a user to debug this.

History

#1 Updated by ghs over 5 years ago

Android app worked initially with Amahi 7 Express CD install, then I upgraded to the latest by installing Fedora 21 from the Server Netinstall,and followed the Amahi install instructions and the install went fine. The problem started when I logged off the Amahi app to test another user account that I created on the HDA; I was not able to log into the app with the newly created account nor was I able to log back in with my HDA account; instead I received an error "The username or password are not correct. Please try again".

Steps Taken to Resolve:
1. Cleared cache; then cleared data, and Force Stop of the Amahi App, and tried again with the same results.
2: Uninstalled then reinstalled the App. Same results.
3: Reset Android Device to Factory Settings; then reinstalled App and tried again and it still failed.
4: Reinstalled HDA using the Fedora 19 install procedures; then command line for the HDA, and I received the same message "The username or password are not correct. Please try again" when I tried to logon with the app.
5: Reset password from the link provided in the app (username and pw screen) and the password was changed but it only affected the logon to the Control Panel and not the HDA, so I tried both pw's with the same result.

Suspicions:
I suspect that a uname pw cache is being maintained on a server somewhere between the Android authenticating process and the HDA, that's preventing the process from completing.

#2 Updated by cpg over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to cpg
  • Priority changed from Medium to High

can reproduce with the ios app. working on it.

#3 Updated by cpg over 5 years ago

  • Status changed from Assigned to Feedback

i think the upgrades we did broke the authentication flow (in a safe way, as it should be -- no access for anyone).

please try to login and note if it works for you.

#4 Updated by ghs over 5 years ago

I'm now able to login,however the username and shares shows up,but the Apps don't (well;momentary then it disappears). I was able to select Apps in the brief moment that it appeared and it returned "Connection Error Check your settings and try again".

Should other users that were created on the HDA be able to login as well?
If they should; none of the users that I created can (I created three other users and assigned the same pw as mine to one of the other users and I can login but the other user cannot using the same pw).
Great job fixing this isuue!

#5 Updated by cpg over 5 years ago

  • Status changed from Feedback to Closed

This was purely an authentication issue for new logins. People logged in already had an oauth token that was valid and they could continue to login.

To answer your questions: no, other users cannot login with the app. this is a long-standing feature request we have.

About the apps, I am not sure why it does not work (or better, why does it show and then it disappears!).

#6 Updated by megabitdragon over 5 years ago

The only reason I can think of for the apps appearing and disappearing shortly after is if you are connected through the proxy. The apps are only available when you are on the local network. The fact that they appear on remote connection is a bug that we should fix. If your usage scenario is different you can open a new bug.

#7 Updated by ghs over 5 years ago

Apps and Shares are working fine now. Thanks for the hard work!

#8 Updated by darkesp over 5 years ago

Can confirm that app login is working as intended on both iOS and Android. Fixed the bug before I even had a chance to poke around! Thanks for all of your efforts.

Also available in: Atom