Project

General

Profile

Bug #1857

Ez Server Manager

Added by rbmattis over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
10/26/2015
Due date:
% Done:

0%


Description

Server Error 500
"The website encountered an error while retrieving

http://esm.<localdomain>.net/

It may be down for maintenance or configured incorrectly."

error_log says:
[Tue Oct 27 01:42:02.083267 2015] [:error] [pid 16747] [client 192.168.1.134:65282] PHP Fatal error: Call to undefined function utf8_encode() in /var/hda/web-apps/esm/html/libs/Utils/Config.php on line 23

History

#1 Updated by cpg over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to rbmattis

php related rpms installed:

php-cli-5.6.14-1.fc21.x86_64
php-pecl-jsonc-1.3.9-1.fc21.x86_64
php-pdo-5.6.14-1.fc21.x86_64
php-5.6.14-1.fc21.x86_64
php-common-5.6.14-1.fc21.x86_64
php-mysqlnd-5.6.14-1.fc21.x86_64

can you indicate how you installed this Amahi 8 system?

#2 Updated by rbmattis over 5 years ago

i installed f21 using a live DVD, then installed amahi 8 on top

#3 Updated by cpg over 5 years ago

I am not sure how much we test the live dvd install, but that could explain the reason this fails.

try exactly this (and no more please):

yum -y install php-mbstring

then update the bug indicating if it works on not.

#4 Updated by rbmattis over 5 years ago

okay i did that

#5 Updated by rbmattis over 5 years ago

still same error (500)

#6 Updated by cpg over 5 years ago

no try this as root (or with sudo) and report:

systemctl restart httpd

then see if the app works.

#7 Updated by rbmattis over 5 years ago

nope, no luck

#8 Updated by cpg over 5 years ago

  • Description updated (diff)

ok, thanks, then try this:

yum -y install php-intl
systemctl restart httpd

and report if it works well.

#9 Updated by rbmattis over 5 years ago

Tested. Still error 500.

#10 Updated by rbmattis over 5 years ago

[Tue Oct 27 21:12:33.304335 2015] [:error] [pid 19710] [client 192.168.1.2:56437] PHP Fatal error: Call to undefined function utf8_encode() in /var/hda/web-apps/esm/html/libs/Utils/Config.php on line 23

#11 Updated by cpg over 5 years ago

ok, thanks, then try this:

yum -y install php-xml

and report if it works well. further research indicates it ought to work.

if it does not, please then try this

systemctl restart httpd

and report how it does.

#12 Updated by rbmattis over 5 years ago

amazing, that fixed it.

#13 Updated by bigfoot65 over 5 years ago

  • Status changed from Assigned to Closed

Also available in: Atom