Project

General

Profile

Bug #1863

Disk Wizard using mount points more than once

Added by jkbuckethead almost 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
11/01/2015
Due date:
% Done:

0%


Description

I recently upgraded from Amahi 7 with a new fresh install of Amahi 8. The initial install was completed with just the OS drive connected. I then installed 4 additional drives, three for storage and the fourth was to be a dedicated landing zone drive. All four were added using the new Disk Wizard. The first three used default setting, and were mounted as sdb1, sdc1, and sdd1. The fourth was mounted as disklz because I entered this in the disk wizard. At this point, I had no problems with the wizard.

Yesterday, I added two additional drives to increase storage capacity. I plugged in the drives, turned on the HDA, and used the disk wizard to add them. After this was complete I had two sdb1 and sdc1 drives because the wizard had mounted the new drives to the same mount point as the existing. The original drives already installed are 5TB, but now they showed as 4TB with 100% free to match the new drives when they should be half full. The text below is my /etc/fstab/ file which shows clearly the duplicates.

# /etc/fstab
# Created by anaconda on Sat Oct 17 22:14:23 2015
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=0d0e9507-ceba-45f0-82d7-fa69cb1fbef6 / ext4 defaults 1 1
UUID=42e055e9-dda5-48cd-b6d7-123bf67c6552 /boot ext4 defaults 1 2
UUID=55c11082-8b70-472d-b4f4-3fbaeccbc2e3 swap swap defaults 0 0
UUID=d0e757b5-8971-4d1c-9e03-d380301f008c /var/hda/files/drives/disklz auto auto,rw,exec 0 0
UUID=6d1a051d-5b38-43af-8ec4-145314df2deb /var/hda/files/drives/sdb1 auto auto,rw,exec 0 0
UUID=df8dcaf6-16cf-4ad8-9fd3-b322d4174836 /var/hda/files/drives/sdc1 auto auto,rw,exec 0 0
UUID=bef849d5-7d7f-4e46-a159-d54b0f17fc9f /var/hda/files/drives/sdd1 auto auto,rw,exec 0 0
UUID=de0c31de-88c2-4ae1-a19b-cbb9603c397b /var/hda/files/drives/sdb1 auto auto,rw,exec 0 0
UUID=334650e5-9a0b-4d9e-9f98-bb4508eed006 /var/hda/files/drives/sdc1 auto auto,rw,exec 0 0

I have also attached a screenshot that shows the presence of multiple drives with the same location.

Fortunately, I am familiar with the manual method of adding drives from amahi 7 so I was able to solve the problem by editing the /etc/fstab/ file. I changed the mount points on the new drives to sde1 & sdf1, respectively. After I rebooted, the results inside amahi looked as they should.

It is fixable, but it seems this shouldn't have happened in the first place.

It seems this was caused, at least in part, by the order that the hardware sees the drives. As you can see by the after screenshot, the new drives at the top are tagged as partition sdb1 and sdc1. This may be why the disk wizard mounted these as sdb1 and sdc1 even though these mount points were already in use.

Amahi Home Server.png View - before - 4 drives on 2 mount points (132 KB) jkbuckethead, 11/01/2015 10:55 AM

Amahi Home Server - Disks.png View - after - new drive mount points changed in /etc/fstab/ (129 KB) jkbuckethead, 11/01/2015 10:56 AM

History

#1 Updated by bigfoot65 almost 5 years ago

  • Status changed from New to Assigned
  • Assignee set to cpg

#2 Updated by cpg almost 5 years ago

  • Project changed from apps to disk wizard plugin
  • Description updated (diff)
  • Category deleted (Apps)

hmm. i thought the disk wizard mounted to ...../drive1 then drive2, etc.
we will investigate.

#3 Updated by bigfoot65 over 3 years ago

  • Status changed from Assigned to Closed

Closing due as unable to reproduce.

Also available in: Atom