Project

General

Profile

Bug #1870

Issue with AmahiSync

Added by jaylanzy about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Apps
Target version:
Start date:
11/08/2015
Due date:
% Done:

100%


Description

I am having issues with AmahiSync. I cannot get files to the cloud. Here is the error report. On the AmahiSync control panel, there is no Public File extension attached after my HDA name. Bigfoot recommended i file a bug report for further investigation. Let me know if you need any more information.

[root@localhost jay]# systemctl restart amahi-sync
[root@localhost jay]# tail -f /var/log/amahi-sync.log
Starting Amahi Sync v0.20
150912-075808-344233: sync ended with exit status: 12
150912-075810-686371: sync errors found - sleeping to check later
Exiting Amahi Sync v0.20 normally with code(15)
Exiting Amahi Sync v0.20 with error code(0)
rsync: connection unexpectedly closed (0 bytes received so far) [sender]

Thanks!

bird
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.1]

History

#1 Updated by jaylanzy about 5 years ago

FYI I truncated the error report with my final salutation. oops!

#2 Updated by cpg about 5 years ago

  • Status changed from New to Feedback
  • Assignee set to jaylanzy

Hi, we have launched a rebuild of your cloud drive. We suspect it may have fallen out of sync if you rebuilt your HDA?

it will eventually finish and sync up.

it may sync up sooner if you restart the amahi-sync process:

sudo systemct restart amahi-sync

Apologies for the hiccup.

#3 Updated by dano5 almost 5 years ago

having same issue, been having it since before my last reinstall, does not resync after a while or with a service restart.

http://paste.fedoraproject.org/304213/50857233

there's also still the bug where on a fresh install the public folder i lower case P instead of upper case P - the latter being what the sync app wants.

#4 Updated by cpg almost 5 years ago

  • Assignee changed from jaylanzy to cpg

Yes, same issue. We sometimes get Amahi Sync off the rails in reinstalls.

Please verify and close @dano5.

#5 Updated by dano5 almost 5 years ago

  • Assignee changed from cpg to jaylanzy
  • % Done changed from 0 to 100

I can confirm that a uninstall and install fixed it.

#6 Updated by dano5 almost 5 years ago

  • Status changed from Feedback to Closed

#7 Updated by TheParkerFamily almost 5 years ago

I am having same issue - I did rebuild several times in past few months.

Tail results:
[root@hda ~]# tail /var/log/amahi-sync.log
Starting Amahi Sync v0.20
160108-175621-860409: sync ended with exit status: 12
160108-175623-863628: sync errors found - sleeping to check later
Exiting Amahi Sync v0.20 normally with code(15)
Exiting Amahi Sync v0.20 with error code(0)
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.1]
Starting Amahi Sync v0.20
160108-175659-747964: sync ended with exit status: 12
160108-175701-750498: sync errors found - sleeping to check later
[root@hda ~]#

#8 Updated by bigfoot65 almost 5 years ago

  • Status changed from Closed to Assigned
  • Assignee changed from jaylanzy to cpg

#9 Updated by cpg almost 5 years ago

@TheParkerFamily, it should be fixed at this time. It make take a few minutes to re-sync.

If not, please let us know.
(I'd be curious to know if this was reinstalled or the profile re-created)

#10 Updated by TheParkerFamily almost 5 years ago

I recreated the profile last time I installed as I was having a weird situation where it wasn't using correct IP address.

The Public folder is now syncing - how do you choose what folders or content to sync? I'm not seeing any options in the HDA web interface, but not 100% sure what I should be looking for...

#11 Updated by cpg almost 5 years ago

  • Status changed from Assigned to Closed

In Amahi 9 we will be adding options to sync more than one folder (and hopefully control sharing as well).
Thanks for the feedback.

Also available in: Atom