Project

General

Profile

Bug #1876

Multicraft-server stoppes and is not starting again

Added by messing over 5 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
11/14/2015
Due date:
% Done:

0%


Description

Multicraft-server stopped and is not starting again. Even rebooting does not start it.

[root@localhost ~]# systemctl status multicraft
? multicraft.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)
[root@localhost ~]#

Any idea?

History

#1 Updated by messing over 5 years ago

Found this in /var/hda/web-apps/multicraft/app/multicraft.log

2015-11-14 20:05:46,469 INFO Multicraft 1.8.2 starting
2015-11-14 20:05:46,500 INFO No license file found at /var/hda/web-apps/multicraft/app/multicraft.key
2015-11-14 20:05:46,500 INFO Running in Free License mode
2015-11-14 20:05:46,502 ERROR Failed to create pid file: [Errno 13] Permission denied: u'/var/hda/web-apps/multicraft/app/amahi-multicraft.pid'
2015-11-14 20:05:46,503 ERROR Failed to delete the pid file: [Errno 2] No such file or directory: '/var/hda/web-apps/multicraft/app/amahi-multicraft.pid'

After creating a emty file named "amahi-multicraft.pid" and rebooting the hda multicraft-server is working.

#2 Updated by cpg over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to cpg

Interesting. That log error was helpful to get to the bottom of the issue.

It's interesting that nothing changed with this from Amahi version to Amahi version, so I don't know why would this happen by default.
Maybe the permissions for that folder were such that apache was not able to write the PID file. This ought to not happen without user intervention, tho.

#3 Updated by bigfoot65 about 4 years ago

  • Status changed from Assigned to Closed

Closed due to no activity from requester.

Also available in: Atom