Project

General

Profile

Bug #1877

Crashplan stopped working

Added by ceayuso almost 4 years ago. Updated over 3 years ago.

Status:
Feedback
Priority:
Normal
Assignee:
Category:
Apps
Target version:
-
Start date:
11/21/2015
Due date:
% Done:

0%


Description

Crashplan stopped working and filled up the hard drive on Amahi 7 because it needed Java 1.7 (see attachment). I upgraded to Amahi 8 and installed Crashplan but I'm unable to start the Crashplan Desktop to configure the backup service (installer log is attached).

Crashplan Support.txt View - Response from Code42 about Crashplan disk space issue (721 Bytes) ceayuso, 11/21/2015 12:56 PM

amahi-app-installer.log View (922 Bytes) ceayuso, 11/21/2015 12:58 PM

crashplan.log View (1.52 KB) ceayuso, 12/08/2015 05:33 PM

amahi-app-installer.log View (2.28 KB) ceayuso, 12/09/2015 05:35 PM

History

#1 Updated by bigfoot65 over 3 years ago

  • Project changed from amahi 8 platform to apps
  • Category set to Apps

#2 Updated by bigfoot65 over 3 years ago

  • Status changed from New to Feedback
  • Assignee set to ceayuso

Have been looking at the Amahi 8 CrashPlan application and it appears to work. However, as mentioned only with Java 1.7.

In order to get it working again, you will need to remove any Java 1.8 packages installed. You can do the following as root user:

yum list "java-1.8*" 

Then anything installed that is 1.8, remove it via:
yum erase "java-1.8*" 

Once done, you will need to uninstall CrashPlan and then reinstall. Check /var/log/amahi-app-installer.log for errors.

If you did a new Amahi 8 install, this should work. If you did an upgrade from Amahi 7 to 8, there may be other issues.

Please report back your experience.

#3 Updated by ceayuso over 3 years ago

That worked, thanks!

#4 Updated by ceayuso over 3 years ago

I did the update from 7 to 8. No errors in the log. The only possible issue is that Crashplan tried and failed to upgrade to a newer version when I started the desktop. It is set to try again in 1 hour. This is what filled up the hard drive when I was on Amahi 7 because Crashplan kept writing upgrade files to the hard drive until it was full. I'll keep an eye on it.

#5 Updated by ceayuso over 3 years ago

[UPDATE] The automatic upgrade is not working and Crashplan is repeatedly writing upgrade files to the hard drive. What's interesting is that the Amahi Apps pages says version 4.4.1 was installed but Crashplan Desktop says it is version 3.2.1.

#6 Updated by bigfoot65 over 3 years ago

Did you install the application in Amahi 8 or was it left from the Amahi 7 to 8 upgrade?

Have you tried uninstalling the app, then reinstalling?

This is a very finicky application in Linux and hard to get working correctly. The version you see on the Amahi app is what it's supposed to upgrade to automatically.

Odd that it's not doing so.

#7 Updated by ceayuso over 3 years ago

It was left from the upgrade. Attached is the crashplan installer log from when it last tried to update.

#8 Updated by bigfoot65 over 3 years ago

Ok hold off doing any uninstall or reinstall. I am trying to upgrade the app to the latest version which is 4.5.0.

I will let you know when it's ready.

#9 Updated by bigfoot65 over 3 years ago

Upgraded to the new version. My preliminary tests indicate it's working.

There are two errors regarding some directories that do no exist. It may be a problem with the software.

Please uninstall and reinstall. Hoping I got it right on the first shot :)

#10 Updated by bigfoot65 over 3 years ago

Errors have been corrected, so all should go well.

#11 Updated by ceayuso over 3 years ago

Sorry to be a pain. The install seemed to go fine, no errors in the log but the Crashplan Desktop isn't starting again.

#12 Updated by bigfoot65 over 3 years ago

No worries.

What do you mean? The service appears to be running. What is the output of:

systemctl status crashplan

If it shows running, then the server is working as designed.

There are manual steps you will need to complete to setup the clients as noted in the wiki guidance: https://wiki.amahi.org/index.php/Crashplan#Amahi_8_.28Fedora_21.29

The guidance is somewhat different that it was for Amahi 7. I presume it's due to the newer version.

#13 Updated by ceayuso over 3 years ago

I use Crashplan Desktop to link to my account and configure the backups. It looks like the service is running.

$ systemctl status -l crashplan
  • crashplan.service - LSB: CrashPlan Engine
    Loaded: loaded (/etc/rc.d/init.d/crashplan)
    Active: active (exited) since Wed 2015-12-09 20:55:47 EST; 22h ago
    Docs: man:systemd-sysv-generator(8)
    Process: 24130 ExecStart=/etc/rc.d/init.d/crashplan start (code=exited, status=0/SUCCESS)

Dec 09 20:55:47 localhost.localdomain crashplan [24130]: CrashPlan is already running with pid 23931

I'll try the steps on the wiki to see if I can get the desktop running again. Thanks!

#14 Updated by ceayuso over 3 years ago

It looks like nothing was written to /var/lib/crashplan/.ui_info during install. I copied the data from a Windows computer and the CrashPlanDesktop tries to start but is unable to connect to the backup engine. I'll keep poking at it...

#15 Updated by ceayuso over 3 years ago

Stopped and re-started the service and all is running again, thanks!

#16 Updated by bigfoot65 over 3 years ago

Great to hear it's working.

Can you update the wiki with the basic steps you followed for the client? I am sure what is on that link is more than what's needed.

Also please describe what you did to get the /var/lib/crashplan/.ui_info created. Was it just a stop and start?

#17 Updated by ceayuso over 3 years ago

Will do. I think the file was there but was empty. I copied the info from the same file on one of my Windows computers and pasted it into the file on the hda using nano. Then a service restart had everything running again.

#18 Updated by bigfoot65 over 3 years ago

Great. I really appreciate your assistance with testing this app. It's one of the more difficult ones to update and get working.

My test VM install showed that file with data, so maybe yours was not quite right due to the previous install.

#19 Updated by ceayuso over 3 years ago

That's probably correct but all's working well again. Thanks for your excellent effort!

#20 Updated by bigfoot65 over 3 years ago

No problem. Happy to assist. Appreciate your help as well. Without your efforts, we would not have the user testing it needed.

Once you have the wiki guidance updated, we will try to release this LIVE for Amahi 8.

Please let me know so I can test your steps and hopefully achieve the same result.

#21 Updated by ceayuso over 3 years ago

Having a new problem. The root drive filled up. I traced the problem to /var/hda/files/crashplan:

du -ch -d 1 | sort -hr
36G total
36G .
33G ./719682739095919459
3.7G ./454851773982048358

Although I told CrashPlan to use another drive for inbound backups, it seems to be trying to mirror the backups on the root drive. Here's the the location I specified for the inbound backups:

du -ch -d 1 | sort -hr
120G total
120G .
116G ./719682739095919459
3.7G ./454851773982048358

Is this something I need to ask Code42 about? I don't see anything in their UI that says to use /var/hda/files/crashplan for the backups.

#22 Updated by bigfoot65 over 3 years ago

Check the /usr/local/crashplan/conf/my.service.xml file and see if it's there.

You can also remove the /var/hda/files/crashplan directory and create a symbolic link from it to the desired location. That will ensure all the files go to that location.

#23 Updated by ceayuso over 3 years ago

Didn't see it in my.service.xml. I'm hoping that it was set as the default location until I was able to log into the UI. I'll keep an eye on it to see if it keeps using it as a backup location. Thanks!

#24 Updated by bigfoot65 over 3 years ago

/var/hda/files/crashplan is the default path for backup set on install. The app install script sets it as such.

Hopefully changing it on the client side will correct it. That is a good item to note in the wiki when you add the steps for post-install configuration.

Also available in: Atom