Project

General

Profile

Bug #1907

Cannot import iTunes play lists or channel into Amahi Plex Server

Added by dagunnyeyes almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Apps
Target version:
Start date:
01/17/2016
Due date:
% Done:

0%


Description

I cannot import iTunes playlists.
I changed the xml file to reflect /var/hda/files/music/files.mp3 vice c:\users\user\music\
I also added link "/var/hda/files/music/iTunes Music Library.xml" under server settings
When trying to import I get a 500 error.
The music imports OK, just not the playlists.
It took a day to setup the Plex server with Carlos's help.
I have a Windows Plex server working fine with Plex and iTunes playlists so there is something to compare against.
fpaste link http://ur1.ca/of9vp -> http://paste.fedoraproject.org/311767/14530562
Thanks for any help.

History

#1 Updated by bigfoot65 almost 5 years ago

We have updated Plex Media Server to the latest version. Please see if this corrects your problem.

Recommend you see Bug #1648

#2 Updated by bigfoot65 almost 5 years ago

  • Category set to Apps
  • Status changed from New to Feedback
  • Assignee set to dagunnyeyes
  • Target version set to amahi-8

#3 Updated by dagunnyeyes almost 5 years ago

Negative - updated latest alpha version as per link under 1648. Restarted a few times - no change - still nasty red bubble - problem importing.
Any other suggestions appreciated. Thx!

#4 Updated by dagunnyeyes almost 5 years ago

OK - I think I found part of the problem. I renamed "itunes music library.xml" to itunes.xml.
I also put it in a path with no names (/var/hda/itunes).
I restarted amahi-plex and ran an import - green light - it finally took the file.
However, it only imported two playlists - recently added and one other.
The xml file has %20's embedded for spaces and other special charcters ("_").
I've edited the xml file ad naseum trying to put quotes around the various file names, paths, et al.
Is there a way to modify the code of the program that reads the .xml to substitute something for the spaces?
I have 50k plus mp3's and about 100 playlists.
I'm playing with Eric Daugherty's iTunesexport, which changes any %20 back to spaces but it still has embedded spaces in the path/file names.
Thx!

#5 Updated by dagunnyeyes almost 5 years ago

Alternatively - is there any way I can grab a file from my Windows Plex server and add that to the Fedora Plex server and have all the playlists magically appear?

#6 Updated by cpg almost 5 years ago

I don't know that much detail about the PMS. I am not sure if anyone has experience with what you mention, however, that strikes me a little open ended and it might be a better fit for the Amahi Forums.

OTOH, we just released the latest that we proposed here for testing about 12 hours ago, which means your Amahi HDA will automatically pick it up soon, if it hasn't already. Not sure if that will help (certainly not, if you already installed it before for your testing).

#7 Updated by dagunnyeyes almost 5 years ago

Finally got it to work!
Ran a manual update of Amahi Plex Server.
rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.9.14-1.x86_64.rpm
I went back to the iTunes host, updated to the latest iTunes.
In iTunes - edit, preserences, advanced, share xml with other apps.
In iTunes - File, library, export library, filename linuxitunes.xml

I used Ultraedit to replace file://localhost/c:/Users/yourusername/Music/ with file://localhost/var/hda/files/music/
Also file://localhost/c:/Documents%20and%20Settings/yourusername/My%20Documents/My%20Music/ with file://localhost/var/hda/files/music/
I also replaced any occurence of %20 with a space (" ").
I replaced any occurence of %2F with a "/"
I put linuxitunes into /var/hda/files/music
I ran an update on the amahi-plex server. ( I have been doing this every couple of hours the last two days just as a precaution as I know Amahi has been updating it).
Ran a systemctl restart amahi-plex
Went back to Plex, Settings, server, channels, set path to /var/hda/files/music/linuxitunes.xml (no quotes around them) and enabled the iTunes channel.
Went back to Plex Home, playlists, and imported iTunes playlist - took about an hour.
The playlists and album art popped up and worked!
I tested from a Samsung TV and all works well, except, clicking iTunes channels and playlists show empty. They do display under music playlists though.
It's a temporary work-around until the space and special character parsing is resolved.
Next, I'll try and get the channels working - if they can. I'm new to Plex and don't know the intricacies.
Semper Fi

#8 Updated by bigfoot65 almost 5 years ago

So do we consider this resolved?

If so please close the bug.

#9 Updated by dagunnyeyes almost 5 years ago

I don't know. I just replaced the hard drive and am reinstalling from scratch to document the results. If it works I'll update. Nice to have toys to play on. Appreciate the assist!

#10 Updated by dagunnyeyes almost 5 years ago

  • Status changed from Feedback to Closed

That did the trick - at least now it's documented if others have the same problem migrating iTunes. Thanks for the help.

Also available in: Atom