Project

General

Profile

Bug #1942

Plex Update Version required

Added by austwhite over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
02/12/2016
Due date:
% Done:

0%


Description

Sorry if this is posted elsewhere.
Current Version of Amahi-Plex is Version 0.9.14.6
Publicly available version is Version 0.9.15.2.1663
It is not causing me any major issues yet, other than getting the nag stating an update is available.

Would it be possible to check this and update?

History

#1 Updated by bigfoot65 over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to cpg
  • Target version set to amahi-8

#2 Updated by cpg over 4 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from cpg to austwhite

here is a new test release. can you try and install this and report how it goes?

without uninstalling the one-click app, can you try this:

rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.9-1.x86_64.rpm

then provide feedback and set it to assigned back to me.

#3 Updated by austwhite over 4 years ago

  • Assignee changed from austwhite to cpg

When I ran

rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.9-1.x86_64.rpm
as root I got this:

Retrieving http://alpha.amahi.org/tmp/amahi-plex-0.9-1.x86_64.rpm
Preparing...                          ################################# [100%]
        package amahi-plex-0.9.14-1.x86_64 (which is newer than amahi-plex-0.9-1.x86_64) is already installed.

Restarted Plex Server - still reports Version 0.9.14.6 ? An update is available. Please install manually.

Fully restarted HDA- Still reports Version 0.9.14.6 ? An update is available. Please install manually.

Thanks

#4 Updated by austwhite over 4 years ago

Sorry, for some reason it didn't save the change of status :/

#5 Updated by cpg over 4 years ago

sorry, my bad. this is the rpm to install:

rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.9-15.x86_64.rpm

#6 Updated by austwhite over 4 years ago

  • Status changed from Feedback to Assigned

Installing package.
Using command: sudo rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.9-15.x86_64.rpm
Still getting
Retrieving http://alpha.amahi.org/tmp/amahi-plex-0.9-15.x86_64.rpm
Preparing... ################################# [100%]
package amahi-plex-0.9.14-1.x86_64 (which is newer than amahi-plex-0.9-15.x86_64) is already installed

Thanks.

#7 Updated by austwhite over 4 years ago

Hi cpg/amahi team,

Any update on what the issue is with the rpm preventing it from installing?

#8 Updated by cpg over 4 years ago

o.m.g. .. this is too embarrassing. this is the version that should install well.

rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.9.15-1.x86_64.rpm

#9 Updated by austwhite over 4 years ago

Third times a charm as they say.
You must have been working too hard CPG.
Prior to Install I make sure everything is updated:
sudo yum update

Ok, Installing this update.
Command : sudo rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.9.15-1.x86_64.rpm
Retrieving http://alpha.amahi.org/tmp/amahi-plex-0.9.15-1.x86_64.rpm
Preparing... ################################# [100%]
Updating / installing...
1:amahi-plex-0.9.15-1 ################################# [ 50%]

Got stuck here for 10 minutes then received the following message:

warning: %post(amahi-plex-0.9.15-1.x86_64) scriptlet failed, signal 2

Repeated command: sudo rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.9.15-1.x86_64.rpm

Retrieving http://alpha.amahi.org/tmp/amahi-plex-0.9.15-1.x86_64.rpm
Preparing... ################################# [100%]
package amahi-plex-0.9.15-1.x86_64 is already installed
Checked Plex
Version 0.9.14.6 ? An update is available. Please install manually

Reboot HDA
Plex version has updated, but looks like there is another public update available (it is never ending)
Version 0.9.15.2 ? An update is available. Please install manually

Checked Plex.tv and public version is now Version 0.9.15.3.1674-

Looks like your update worked, but they released another update in the mean time

#10 Updated by anovak765 over 4 years ago

Just update to Plex Media Server version 0.9.15.2 from the link that cpg provided. Downloaded, installed, and updated without a problem. Seems to work on web browser, will try playback on various other media devices. Plex also came out with a new upgrade, newest is 0.9.15.5 (for plex pass users), 0.9.15.3 (for non plex pass users).

#11 Updated by austwhite over 4 years ago

Everything is running smoothly. Not sure what the initial install glitch was.
Pretty sure this should be safe to move to a release.

Thanks cpg

#12 Updated by cpg over 4 years ago

would you like to test the latest?

if interested, please do this without reinstalling the amahi app:

rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.9.15.6-1.x86_64.rpm

please report how it goes if you test it out.

#13 Updated by austwhite over 4 years ago

Just as an update. I have been away but tried this via a remote ssh session.
Unfortunately it is just getting stuck for me and not passing the retrieving stage. It sits there retrieving the file for 30 minutes or more before i manually cancel it.
When I am back home I will reboot the hda fully and try again.

#14 Updated by austwhite over 4 years ago

Ok I got the chance to test this again.

It took approx. 15 mins to retrieve the file, but then installation was successful.

sudo rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex.9.15.6-1.x86_64.rpm
[sudo] password for xxxxxxx:
Retrieving http://alpha.amahi.org/tmp/amahi-plex-0.9.15.6-1.x86_64.rpm
Preparing... ( 3################################# [100%]
Updating / installing...
1:amahi-plex-0.9.15.6-1 ( ################################# [ 33%]
Cleaning up / removing...
2:amahi-plex-0.9.15-1 ( ################################# [ 67%]
3:amahi-plex-0.9.14-1 ( ################################# [100%]

Plex Server reports: Version 0.9.15.6  Check for Updates  Up to date.

LG Media link and android plex clients all work perfectly. I haven't had a chance to test a Windows client yet. All looks positive though.

#15 Updated by austwhite over 4 years ago

I noticed this is still open so I thought I might add Plex has done yet another update.
Version 0.9.16.2.1827 is now public.

#16 Updated by cpg over 4 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from cpg to austwhite

0.9.16.4.1911-ee6e505 released, please try, same as usual: do not reinstall the app, just do the rpm command

rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.9-16.x86_64.rpm

then double check that is the version reported, then report back how well (or not) it works.

#17 Updated by TheParkerFamily over 4 years ago

cpg wrote:

0.9.16.4.1911-ee6e505 released, please try, same as usual: do not reinstall the app, just do the rpm command

[...]

then double check that is the version reported, then report back how well (or not) it works.

Was having same issue - it seems to be installed now with no errors, however when you try to go to the Plexms.hda.local URL is brings up a white screen with no info.

#18 Updated by bigfoot65 over 4 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from austwhite to cpg
  • Target version changed from amahi-8 to amahi-9

Tested install and have same behavior as others.

Accessing the web UI ends up as a blank white screen.

BTW this is being tested on Amahi 9.

#19 Updated by bigfoot65 over 4 years ago

One user reported being to access the web UI at this URL:

 http://hda:32400/web/index.html#!/setup/library

#20 Updated by austwhite over 4 years ago

Has the install been rolled back to a previous version?
I was going to test it (sorry for the delay) but receive this when trying to install.

$ sudo rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-0.9-16.x86_64.rpm

Retrieving http://alpha.amahi.org/tmp/amahi-plex-0.9-16.x86_64.rpm
Preparing... ################################# [100%]
package amahi-plex-0.9.15.6-1.x86_64 (which is newer than amahi-plex-0.9-16.x86_64) is already installed

#21 Updated by cpg over 4 years ago

  • Subject changed from Plex Update Version required - Publicly available version is now Version 0.9.15.2.1663 to Plex Update Version required

New test version (the previous 0.9.16.4 has been released for amahi 9):

http://alpha.amahi.org/tmp/amahi-plex-0.9.16.6-1.x86_64.rpm

#22 Updated by bigfoot65 over 4 years ago

Just tested new version and works with the exception of dashboard access.

Appears to be problem with proxypass as accessing the URL http://plexms.amahi.net/index.html from the dashboard yields a blank screen.

When manually changing the URL to http://plexms.amahi.net:32400/web, the web UI is presented correctly.

#23 Updated by austwhite about 4 years ago

This bug still exists, but also Plex is reporting another update.
Current version Version 0.9.16.4
Update available to 1.0.0.2261-a17e99e is available.

Is it worth investigating this given Plex seems to now hit the 1.x milestone?

#24 Updated by cpg about 4 years ago

thanks for the update. here is a test release. anyone up for testing it and reporting?

use rpm -Uvh and do not uninstall/reinstall the app.

rpm -Uvh http://alpha.amahi.org/tmp/amahi-plex-1.0.0.2261-1.x86_64.rpm

#25 Updated by austwhite about 4 years ago

Installation was successful and considerably faster than previous releases. Running tests and will report back soon.

#26 Updated by austwhite about 4 years ago

All went well except we still have the issue of the web interface needing the /web bit so from the dashboard link it only shows a blank page.
The server itself works well on Windows and Android clients both remote and local. Transcoding is smooth. LG MediaLink app works smoothly too.
All in all, with the exception of the dashboard link, completely smooth and troublefree upgrade.
If you navigate to http://hda:32400/web the web interface displays normally.

#27 Updated by Osyrus about 4 years ago

I have used this same link to update my Server running Amahi 8 and all went well. Will monitor to see how it goes, but it is currently working on the new web portal (plex.tv/web/app) and on the Android app.

#28 Updated by austwhite about 4 years ago

confirm the new webapp is working well as do MAC based Plex clients.

I reckon if you can fix the dashboard interface this would be ready for a Live release based on my testing.

#29 Updated by cpg about 4 years ago

amahi-plex-1.0.0.2261-1 has been released live to our repos now.

The web interface issue is a bug in the app, not in Amahi. So this workaround of using http://hda:32400/web will have to continue until the app fixes this broken behavior.

#30 Updated by cpg about 4 years ago

  • Project changed from apps to plex
  • Category deleted (Apps)
  • Status changed from Assigned to Closed
  • Target version deleted (amahi-9)

we have created a new section on the bug tracker specifically for the Plex Media Server app for Amahi. Please file any issues under that section in the future.

closing.

Also available in: Atom