Project

General

Profile

Bug #1945

No Apps listed due to "lack of network connectivity".

Added by hemington1 almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
02/17/2016
Due date:
% Done:

0%


Description

No Apps listed on App page due to lack of network connectivity. Accessing the internet thru HDA DNS is very slow.

Screen Shot 2016-02-17 at 7.58.26 PM.png View (119 KB) hemington1, 02/17/2016 04:04 AM

Screenshot from 2016-02-18 22-05-05.png View (199 KB) hemington1, 02/18/2016 06:05 AM

A9-ifcfg1.jpg View (54.9 KB) hemington1, 02/23/2016 05:37 PM

A9-install2.jpg View (92.9 KB) hemington1, 02/23/2016 05:37 PM

A9-install1.jpg View (118 KB) hemington1, 02/23/2016 05:37 PM

A9-ipadd.jpg View (72.1 KB) hemington1, 02/23/2016 05:37 PM

History

#1 Updated by bigfoot65 almost 5 years ago

  • Assignee set to hemington1

Please provide some context to this problem.

What type of install did you do?

Provide the URL for the following:

fpaste --sysinfo

Were there any errors on install?

#2 Updated by cpg almost 5 years ago

  • Status changed from New to Feedback

The local HDA server is just a cached relay for DNS. Try changing the DNS servers used by the local DNS server in Setup > Network > Settings
or http://hda/tab/network/settings

(advanced settings may need to be enabled)

if it works, please close this bug. Else explain and set to assigned and me as the assignee.

#3 Updated by cpg almost 5 years ago

  • Project changed from Amahi 9 to amahi 8 platform

#4 Updated by hemington1 almost 5 years ago

fpaste --sysinfo failed to upload.
"server not found" error during network trouble shooting wiki guide.
A fresh install of F23 and Amahi 9.
No errors during installation. I followed wiki Amahi 9 fresh install to the letter.
I will try cpg suggestions this evening and report back.

#5 Updated by cpg almost 5 years ago

oh, i'm sorry, i thought this was amahi 9 by mistake.

we typically do not release apps live until the platform has been released, however, you should at least see apps that you have bought.

if the fpaste does not work, that is a strong sign that the networking is not right.

one possibility is to see via

ip addr

if the interface you expect to be configured, has the IP address you configured in amahi.org.

#6 Updated by hemington1 almost 5 years ago

192.168.1.10
Network settings show gateway 192.168.1.1
my router is also showing this address as a wired device (allowed).
The HDA is not reaching the outside world.

#7 Updated by hemington1 almost 5 years ago

I re-installed a fresh Amahi 9, with same results after triple checking network settings during config of Amahi 9.
I then did a fresh install of Amahi 8, checked I had network connection via dashboard, then did the wiki upgrade to F23 & Amahi 9.
Network connection is present and apps (purchased) are showing.
Do you want me to re-install a fresh version of Amahi 9 to trouble shoot this bug?

#8 Updated by cpg almost 5 years ago

i would certainly be useful to know what's up with that failed installation.

since there is no network, screenshots would be best. you may have to do the screenshots with an actual camera, unless you are running on a VM or something like that.

we're interested in the network configuration.

ip add

as well as the contents of /etc/sysconfig/network-scripts/ifcgf*

actually, before you destroy the working amahi 9 system, it would be good to record that information from it.

also, thanks for trying the upgrade. a positive report on that is very useful!

#9 Updated by hemington1 almost 5 years ago

Working Amahi 8 fresh install (9 upgrade & 9 fresh install coming):

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default                                              
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00                                                                      
    inet XXX.0.0.1/8 scope host lo                                                                                             
       valid_lft forever preferred_lft forever                                                                                 
    inet6 ::1/128 scope host                                                                                                   
       valid_lft forever preferred_lft forever                                                                                 
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000                       
    link/ether 00:27:0e:26:52:34 brd ff:ff:ff:ff:ff:ff                                                                         
    inet 192.168.1.10/24 brd 192.168.1.255 scope global enp0s25                                                                
       valid_lft forever preferred_lft forever                                                                                 
    inet6 fe80::227:eff:fe26:5234/64 scope link                                                                                
       valid_lft forever preferred_lft forever                                                                                 
3: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100              
    link/none                                                                                                                  
    inet 10.8.0.1 peer 10.8.0.2/32 scope global tun0                                                                           
       valid_lft forever preferred_ft forever

Amahi 9 upgrade:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default                                              
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00                                                                      
    net XXX.0.0.1/8 scope host lo                                                                                             
       valid_lft forever preferred_lft forever                                                                                 
    inet6 ::1/128 scope host                                                                                                   
       valid_lft forever preferred_lft forever                                                                                 
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000                         
    link/ether 00:27:0e:26:52:34 brd ff:ff:ff:ff:ff:ff                                                                         
    inet 192.168.1.10/24 brd 192.168.1.255 scope global enp0s25                                                                
       valid_lft forever preferred_lft forever                                                                                 
    inet6 fe80::227:eff:fe26:5234/64 scope link                                                                                
       valid_lft forever preferred_lft forever                                                                                 
3: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 100                 
    link/none                                                                                                                  
    inet 10.8.0.1 peer 10.8.0.2/32 scope global tun0                                                                           
       valid_lft forever preferred_ft forever

ifcfg output:

TYPE="Ethernet"                                                                                                                
BOOTPROTO=none                                                                                                                 
DEFROUTE="yes"                                                                                                                 
IPV4_FAILURE_FATAL="no"                                                                                                        
IPV6INIT="yes"                                                                                                                 
IPV6_AUTOCONF="yes"                                                                                                            
IPV6_DEFROUTE="yes"                                                                                                            
IPV6_FAILURE_FATAL="no"                                                                                                        
NAME="enp0s25"                                                                                                                 
UUID="815d0a6f-1cc8-4ee3-a0f5-dbed4a132c54"                                                                                    
ONBOOT="yes"                                                                                                                   
DNS1=208.67.222.222                                                                                                            
DNS2=208.67.220.220                                                                                                            
IPADDR=192.168.1.10                                                                                                            
PREFIX=24                                                                                                                      
GATEWAY=192.168.1.1                                                                                                            
IPV6_PEERDNS=yes                                                                                                               
IPV6_PEERROUTES=yes

Amahi 9 fresh install - broken. I can reproduce bug for each re-install.
Refer attached screen shots for info.

#10 Updated by cpg almost 5 years ago

ok so we know the upgrade looks good. output looks good (i added pre blocks to make it readable, don't forget next time).

ifcfg looks good. i assume it's from the amahi 9 upgraded system, not the fresh install.

looking at what theses look like in the fresh install would be good.

#11 Updated by hemington1 almost 5 years ago

Amahi 9 fresh install pics.

#12 Updated by bigfoot65 almost 5 years ago

Could this be an IPV6 issue? I have no problems with installs and upgrades. My network does not use IPV6.

Does your Hemington1?

#13 Updated by hemington1 almost 5 years ago

Big, my router is IPV6 capable, but no my network is not set to IPV6.

#14 Updated by bigfoot65 over 4 years ago

Really odd behavior. Wonder if anyone else has issues.

#15 Updated by hemington1 over 4 years ago

Well, if there is nothing more you need from me, I will do a fresh install of Amahi 8 and reload and setup all my apps. I took this opportunity to test Amahi 9 due to my hard drive failure. I had just purchased a new boot drive and thought a good opportunity to do some testing prior to setting up my HDA again.
Or if you want, I can setup my apps on Amahi 8 and upgrade to Amahi 9 and test the apps?

#16 Updated by cpg over 4 years ago

wait. the amahi 9 fresh install does not work?

#17 Updated by hemington1 over 4 years ago

cpg, correct fresh install of Amahi 9 does not connect to the internet (for me).

#18 Updated by cpg over 4 years ago

for some reason i did not noticed your pictures yesterday. sorry.

could you run the network troubleshooter on it?

the settings look ok for the device!

maybe DNS is not working properly (that would be a good bug to catch!!)?

if you can debug in real time, come to the IRC and ping cpg and see if we nail this one down.

#19 Updated by hemington1 over 4 years ago

cpg, see my post #4.
The network wiki trouble shooting failed at last step, with server not found.
I'll try again and also catch you on the IRC. What time zone are you in?
I notice the bug heading is Amahi 8 platform????????

#20 Updated by cpg over 4 years ago

  • Project changed from amahi 8 platform to Amahi 9

i'm in pacific time, usually afternoons and evenings (late afternoons I go to exercise)

yeah, i would like to know wha is up with that, not just that it does not work.

something like -- cat /etc/resolv.conf
and pinging the ip of your router, etc.

maybe it's DNS. basic connectivity seems set up ok.

#21 Updated by hemington1 over 4 years ago

I booted my HDA this morning to start some investigative work, and it is inexplicably working.......full access to the internet.........odd. However a ping to my router gets 63% packet loss. Is this normal behaviour?

#22 Updated by cpg over 4 years ago

definitely not normal.

[fwiw ,i'm in irc at the moment]

#23 Updated by hemington1 over 4 years ago

Apps seems to hang during installation. Accessing the app page in dashboard is not always successful. I get "invalid argument" (NSPOSIX error domain 22) when slow access to apps page using Safari on a client machine.

#24 Updated by cpg over 4 years ago

We saw ssl timeouts in the logs. not sure why.

can you share the following 2 fpaste urls:

sudo tail -200 /var/log/amahi-app-installer.log | fpaste
sudo dnf check-update | fpaste

#26 Updated by cpg over 4 years ago

These are three different reasons for failures. Very unusual.

The high error rate could be a good clue of the problem that may be going on here.

Looking at the output of tail -400 /var/log/messages may help, potentially.

tail -400 /var/log/messages | fpaste

#27 Updated by hemington1 over 4 years ago

sorry cpg, no such file or directory........

#28 Updated by hemington1 over 4 years ago

Any further info needing to be checked?

#29 Updated by cpg over 4 years ago

  • Status changed from Feedback to Closed

Probably best if we close this one. Reopen it if it necessary.

I think the high packet loss is an indication of some kind of hardware trouble -- maybe a loose or wonky cable or something?

#30 Updated by hemington1 over 4 years ago

Thanks cpg.......no wonky connections on my setup.......!!!! ;-)
I'm not sure if it is hardware, as a fresh install of 8 and 9 upgrade just works, over and over.
Anyway 8 install this weekend and back to what a HDA should be doing.......

#31 Updated by cpg over 4 years ago

FYI, amahi 9 has (unofficially) been released

#32 Updated by hemington1 over 4 years ago

Excellent, I'll go down the upgrade path this weekend.

#33 Updated by hemington1 over 4 years ago

cpg, I found the packet loss issue. My router needed a firmware update and a reboot. No packet losses now.

Also available in: Atom