Project

General

Profile

Bug #1957

pydio showing issues, also, v6.2.2 is out

Added by cpg over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Apps
Target version:
Start date:
02/22/2016
Due date:
% Done:

0%


Description

pydio has been showing signs of issues. their website was down recently for a little while.

also, i notice 6.2.2 is out.

https://sourceforge.net/projects/ajaxplorer/files/pydio/stable-channel/6.2.2/

may want to get to the latest and mirror the download file ourselves, to be sure there are less instabilities.

History

#1 Updated by bigfoot65 over 4 years ago

I've had the update on my list for a while. It came out when all the mirror and dl.amahi.org went offline.

I waited, but guess it's time to update the app. I will try to get it done in the next few days.

#2 Updated by bigfoot65 over 4 years ago

  • Category set to Apps
  • Assignee changed from bigfoot65 to cpg
  • Priority changed from Low to Normal
  • Target version set to amahi-8

Application has been updated.

Mirrored download source to dl.amahi.org vs using sourceforge.net.

Getting SHA1SUM error for some reason, but it's correct and app is working:

WARNING: primary downloaded file /var/hda/tmp/amahi-download-cache/ca4e26f9db227f44fa60c708cf09935bb9898ba1 did not pass signature check - got 963029501706ff69b4cb78daf24789f7f6bd6ea1, expected ca4e26f9db227f44fa60c708cf09935bb9898ba1
new file /var/hda/tmp/amahi-download-cache/ca4e26f9db227f44fa60c708cf09935bb9898ba1 from Amahi's mirror written in the cache

#3 Updated by cpg over 4 years ago

  • Assignee changed from cpg to bigfoot65

the patch file seems to be what's having trouble with, not the main download.

the patch file is at http://bigfoot65.amahi.me/Public/mirror/pydio-6.2.0-patch.tar.gz

can you repeat the install after this:

rm /var/hda/tmp/amahi-download-cache/*

#4 Updated by bigfoot65 over 4 years ago

  • Assignee changed from bigfoot65 to cpg

Cleared download cache and installed. Received same error.

#5 Updated by cpg over 4 years ago

just to be clear, there is no issue with the download cache. i just wanted to make sure that the platform downloaded the app completely from scratch.

i received this file and not only it matches the signature, it has the proper content (of course -- it matches the signature!).

now -- it looks like the file was picked up from the mirror, which is a good thing, and that is the resulting file i got to see and check.

problem is the first download of the file, which fails, and it should not because the original file looks fine, with all it's bits lined up well.

i will try and see if i can replicate locally for more debuggability

#6 Updated by cpg over 4 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from cpg to bigfoot65

it's a DUH! no bug.

this fails

amahi-download pydio-6.2.0-patch.tar.gz ca4e26f9db227f44fa60c708cf09935bb9898ba1;

because pydio-6.2.0-patch.tar.gz is NOT published. it's in your sync drive but not in dl.
(i.e. the FIXME in the install script still applies)

i looked in the miror manager log and the dl-master sync log i recently added and it was nowhere to be found.

i think you must have thought about publishing but did not.

because it was mirrored, the fallback system picked it up and it worked.

#7 Updated by bigfoot65 over 4 years ago

  • Assignee changed from bigfoot65 to cpg

Ah must have been missed when rebuilding dl.amahi.org as this file used to be there.

The patch file is several months old, so I did not just create it.

I should have checked to make sure it was there. Sorry about all the work.

#8 Updated by bigfoot65 over 4 years ago

  • Status changed from Feedback to Closed

Tested and the issue is resolved.

Lesson learned, double check that patch file is hosted on amahi.org.

Also available in: Atom