Project

General

Profile

Bug #2043

Issue when trying to open Transmission webui

Added by therealistninja over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Apps
Target version:
Start date:
05/06/2016
Due date:
% Done:

0%


Description

sysinfo: http://paste.fedoraproject.org/363584/46260022

Getting this error with transmission:

Starting amahi-transmission (via systemctl): Job for amahi-transmission.service failed because the control process exited with error code. See "systemctl status amahi-transmission.service" and "journalctl -xe" for details.
[FAILED]
localalhost ~]# systemctl status amahi-transmission.service
● amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
Active: failed (Result: exit-code) since Fri 2016-05-06 10:07:46 EDT; 34s ago
Docs: man:systemd-sysv-generator(8)
Process: 22738 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=1/FAILURE)

May 06 10:07:39 localhost.localdomain systemd[1]: Starting SYSV: This is a daemon which runs on the server to download torrents...
May 06 10:07:39 localhost.localdomain amahi-transmission[22738]: /etc/rc.d/init.d/amahi-transmission: line 34: [: =: unary operator expected
May 06 10:07:46 localhost.localdomain amahi-transmission[22738]: chown: cannot access ‘blocklist.bin’: No such file or directory
May 06 10:07:46 localhost.localdomain runuser[22760]: pam_unix(runuser:session): session opened for user transmission by (uid=0)
May 06 10:07:46 localhost.localdomain runuser[22760]: pam_unix(runuser:session): session closed for user transmission
May 06 10:07:46 localhost.localdomain amahi-transmission[22738]: [49B blob data]
May 06 10:07:46 localhost.localdomain systemd[1]: amahi-transmission.service: Control process exited, code=exited status=1
May 06 10:07:46 localhost.localdomain systemd[1]: Failed to start SYSV: This is a daemon which runs on the server to download torrents.
May 06 10:07:46 localhost.localdomain systemd[1]: amahi-transmission.service: Unit entered failed state.
May 06 10:07:46 localhost.localdomain systemd[1]: amahi-transmission.service: Failed with result 'exit-code'.

History

#1 Updated by cpg over 2 years ago

  • Description updated (diff)

#2 Updated by bigfoot65 over 2 years ago

It appears you are running a Desktop UI. Is that correct?

That may be part of the issue. The packages installed for the GUI often conflicts/causes issues with some apps.

I did a test on a headless server and cannot replicate your problem.

We will need to dig further into the details you provided to see what might be the root cause.

Is there any other info you can provide?

#3 Updated by bigfoot65 over 2 years ago

  • Category set to Apps
  • Status changed from New to Assigned
  • Assignee set to therealistninja
  • Target version set to amahi-9

#4 Updated by therealistninja over 2 years ago

I am trying to login to the web UI, i used the one click installation from amahi. I ended up wiping, configuring a new hda, and reinstalling with the new install code and have the same result. I was able to use transmission for about a day and now receiving the same error.

#5 Updated by bigfoot65 over 2 years ago

Please provide the URL for:

apaste --sysinfo

Also the full output of the following command:
systemctl status amahi-transmission

#6 Updated by therealistninja over 2 years ago

http://paste.fedoraproject.org/371164/75942146/ -> http://paste.fedoraproject.org/371164/75942146

[root@localhost ~]# systemctl status amahi-transmission
● amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
   Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
   Active: failed (Result: exit-code) since Thu 2016-05-26 12:15:04 EDT; 16s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 31333 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=1/FAILURE)

May 26 12:15:03 localhost.localdomain systemd[1]: Starting SYSV: This is a daemon which runs on the server to download torrents...
May 26 12:15:03 localhost.localdomain amahi-transmission[31333]: /etc/rc.d/init.d/amahi-transmission: line 34: [: =: unary operator expected
May 26 12:15:04 localhost.localdomain amahi-transmission[31333]: chown: cannot access ‘blocklist.bin’: No such file or directory
May 26 12:15:04 localhost.localdomain runuser[31350]: pam_unix(runuser:session): session opened for user transmission by (uid=0)
May 26 12:15:04 localhost.localdomain runuser[31350]: pam_unix(runuser:session): session closed for user transmission
May 26 12:15:04 localhost.localdomain amahi-transmission[31333]: [49B blob data]
May 26 12:15:04 localhost.localdomain systemd[1]: amahi-transmission.service: Control process exited, code=exited status=1
May 26 12:15:04 localhost.localdomain systemd[1]: Failed to start SYSV: This is a daemon which runs on the server to download torrents.
May 26 12:15:04 localhost.localdomain systemd[1]: amahi-transmission.service: Unit entered failed state.
May 26 12:15:04 localhost.localdomain systemd[1]: amahi-transmission.service: Failed with result 'exit-code'.

#7 Updated by bigfoot65 over 2 years ago

Made a minor change that hopefully will fix the issue.

Uninstall the app, reboot, then reinstall and see if it works.

#8 Updated by genweas over 2 years ago

Hi folks,

I'm very new to Amahi, Fedora, and Linux in general. I set up Fedora/Amahi yesterday and everything seems fine. My server is controlling DHCP perfectly and all the devices in my house are working at low latency/high speed. The only issue is that Transmission will not start. I've looked at the servers in setup and tried to stop/restart with no luck. I've uninstalled and reinstalled multiple times with multiple reboots to my server. I've tried disabling firewalls and placing the server in a DMZ through the router, which is no longer controlling DHCP so I don't even know if that matters. When I try to open Transmission from the dashboard I get a "503 Service Unavailable" message and the text "The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later." I've used transmission with Lubuntu and loved it. Any help would be greatly appreciated. Plex runs fine as well. I apologize in advance for how green I am to all this.

#9 Updated by bigfoot65 over 2 years ago

Please provide the following:

  1. URL for:
    apaste --sysinfo
    
  2. Relevant log file info for app in /var/log/amahi-app-installer.log

#10 Updated by genweas over 2 years ago

I'm not sure how to check the installer log file but here is the link I received from typing apaste --sysinfo http://paste.fedoraproject.org/373083/14647253/ I'll browse around and try to figure out the how to view the log.

Edit Here is the relevant log info:
Installing amahi-transmission service
Enabling amahi-transmission service
Starting amahi-transmission (via systemctl): Job for amahi-transmission.service failed because the control process exited with error code. See "systemctl status amahi-transmission.service" and "journalctl -xe" for details.
[FAILED]
chmod: cannot access ‘/usr/share/transmission/torrentwatch.sh’: Not a directory
App: Transmission installed ======= app install end @ 2016-05-31 16:26:47 -0400 ==========

#11 Updated by bigfoot65 over 2 years ago

Please provide the output of the following:

systemctl status amahi-transmission

Also is this a CD or DVD install? Did you do yum update to install OS updates?

#12 Updated by genweas over 2 years ago

Hi Bigfoot,

I was not updated but I am now.

When I installed, I did the prescribed netinstall of Fedora 23 from a CD I created using the .iso linked in the installation instructions.

Here is the result of "systemctl status amahi-transmission" copied from Shell in a Box:

● amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
Active: failed (Result: exit-code) since Wed 2016-06-01 19:55:23 EDT; 36s ago
Docs: man:systemd-sysv-generator(8)
Process: 2592 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=1/FAILURE)

Jun 01 19:55:20 localhost.localdomain systemd1: Starting SYSV: This is a daemon which runs on the server to download torrents...
Jun 01 19:55:23 localhost.localdomain amahi-transmission2592: chown: cannot access ‘blocklist.bin’: No such file or directory
Jun 01 19:55:23 localhost.localdomain runuser2614: pam_unix(runuser:session): session opened for user transmission by (uid=0)
Jun 01 19:55:23 localhost.localdomain amahi-transmission2592: Starting Transmission daemon... /usr/bin/transmission-daemon: error while loading shared libraries: /lib64/libnatpmp.so.1: file too short
Jun 01 19:55:23 localhost.localdomain amahi-transmission2592: [17B blob data]
Jun 01 19:55:23 localhost.localdomain systemd1: amahi-transmission.service: Control process exited, code=exited status=1
Jun 01 19:55:23 localhost.localdomain systemd1: Failed to start SYSV: This is a daemon which runs on the server to download torrents.
Jun 01 19:55:23 localhost.localdomain systemd1: amahi-transmission.service: Unit entered failed state.
Jun 01 19:55:23 localhost.localdomain systemd1: amahi-transmission.service: Failed with result 'exit-code'.

Thanks for taking the time to help a newbie.

-Genweas

#13 Updated by genweas over 2 years ago

I forgot to mention: After I updated, I also restarted the server and uninstalled/reinstalled Transmission before copy/pasting the above info from Shell in a Box.

#14 Updated by bigfoot65 over 2 years ago

Thanks for the info.

Try doing the following:

systemctl restart amahi-transmission

If it fails, check with the status command.

#15 Updated by genweas over 2 years ago

Hi Bigfoot,

I tried the restart command like you asked and then the status command. Here are the results:

[root@hda ~]# systemctl restart amahi-transmission
Job for amahi-transmission.service failed because the control process exited with error code. See "systemctl status amahi-transmission.service" and "journalctl -xe" for details.
[root@hda ~]# systemctl status amahi-transmission.service
● amahi-transmission.service - SYSV: This is a daemon which runs on the server to download torrents
Loaded: loaded (/etc/rc.d/init.d/amahi-transmission)
Active: failed (Result: exit-code) since Thu 2016-06-02 20:44:59 EDT; 8s ago
Docs: man:systemd-sysv-generator(8)
Process: 25932 ExecStart=/etc/rc.d/init.d/amahi-transmission start (code=exited, status=1/FAILURE)

Jun 02 20:44:57 hda.amahi.net systemd1: Starting SYSV: This is a daemon which runs on the server to download torrents...
Jun 02 20:44:59 hda.amahi.net amahi-transmission25932: chown: cannot access ‘blocklist.bin’: No such file or directory
Jun 02 20:44:59 hda.amahi.net runuser25961: pam_unix(runuser:session): session opened for user transmission by (uid=0)
Jun 02 20:44:59 hda.amahi.net amahi-transmission25932: Starting Transmission daemon... /usr/bin/transmission-daemon: error while loading shared libraries: /lib64/libnatpmp.so.1: file too short
Jun 02 20:44:59 hda.amahi.net runuser25961: pam_unix(runuser:session): session closed for user transmission
Jun 02 20:44:59 hda.amahi.net amahi-transmission25932: [17B blob data]
Jun 02 20:44:59 hda.amahi.net systemd1: amahi-transmission.service: Control process exited, code=exited status=1
Jun 02 20:44:59 hda.amahi.net systemd1: Failed to start SYSV: This is a daemon which runs on the server to download torrents.
Jun 02 20:44:59 hda.amahi.net systemd1: amahi-transmission.service: Unit entered failed state.
Jun 02 20:44:59 hda.amahi.net systemd1: amahi-transmission.service: Failed with result 'exit-code'.
[root@hda ~]#

#16 Updated by bigfoot65 over 2 years ago

Have you done OS updates? If not, that might fix the issue with the error.

#17 Updated by genweas over 2 years ago

Hi Bigfoot,

Yes, I updated per your instructions 7 days ago. The update appeared to go well. Has there been an update since then? I'll try it again and report back.

#18 Updated by bigfoot65 over 2 years ago

Has there been an update since then?

Nothing has been changed with the app as I cannot replicate your issue.

Everything works fine on my end.

#19 Updated by genweas over 2 years ago

I updated again using "yum update" with no luck. I uninstalled and reinstalled transmission after. It still won't start.

#20 Updated by bigfoot65 over 2 years ago

When you uninstall Transmission, also do the following:

yum erase transmission-daemon

Then reinstall. Once installed, give is a minute or so before you try to access.

If you still cannot access, check the status of amahi-transmission as before and post results. If it's the same error, then we will have to look more into the details as to what is causing it.

#21 Updated by bigfoot65 almost 2 years ago

  • Status changed from Assigned to Closed

Closed due to no activity from requester.

Also available in: Atom