Project

General

Profile

Bug #2257

Install of Amahi on Fedora 26

Added by bigfoot65 over 2 years ago. Updated about 2 years ago.

Status:
Assigned
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
06/16/2017
Due date:
% Done:

0%


Description

Executing dnf -y install hda-ctl results in the following error:

Error:
 Problem: conflicting requests
  - package hda-ctl-10.0.0-1.x86_64 requires hda-platform >= 10.0.0, but none of the providers can be installed
  - package hda-ctl-5.5.0-1.armv7hl does not have a compatible architecture
  - package hda-ctl-5.5.1-1.armv7hl does not have a compatible architecture
  - nothing provides libruby.so.2.3()(64bit) needed by hda-platform-10.0.0-1.x86_64

History

#1 Updated by cpg over 2 years ago

You have to install hda-ctl and hda-platform at the same time

#2 Updated by bigfoot65 over 2 years ago

Did that too, but there is an issue with the ruby-libs.

#3 Updated by cpg over 2 years ago

  • Subject changed from Install of Amahi on Fedora 26 Beta to Install of Amahi on Fedora 26

This has been resolved and we have done a couple of installs of amahi 11 alpha on fedora 26.

minor update to the wiki instructions for upgrade: https://wiki.amahi.org/index.php/Amahi_11#Upgrade_from_Fedora_25

These are the known issues at the moment (did not do a thorough checklist testing):

  • cannot login to samba (ugh!), even after changing password to be 8+ chars long
  • UI is all new code and it's not refined, lots of artifacts

#4 Updated by bigfoot65 over 2 years ago

Did a test of the upgrade from Amahi 10 to Amahi 11. Went without issue and all appears to be working as expected.

As mentioned, there are some things that need cleaned up with the UI.

Next will try a new install.

#5 Updated by bigfoot65 over 2 years ago

Did a test install of Amahi 11 from scratch. All went as expected and so far all things appear to be working as designed.

I did notice that the enable/disable DNS option in network settings is back. We removed that in Amahi 10. Was it intended to be brought back?

Also I was able to access the Samba shares no problem with the initial user.

Did a app install of Adminer and all installed and worked as expected. The UI cleanup is present as it was with the upgrade test I did earlier.

Otherwise, things are looking pretty good from my point of view.

#6 Updated by bigfoot65 over 2 years ago

Tested DVD install with no issues. Amahi 11 install went fine, but the following message was noted during install:

/usr/share/gems/gems/ruby-dbus-0.11.0/lib/dbus/marshall.rb:301: warning: constant ::Fixnum is deprecated
/usr/share/gems/gems/ruby-dbus-0.11.0/lib/dbus/message.rb:129: warning: constant ::Fixnum is deprecated

Also the install script makes reference to http://setup which does not exist. Need to change it to http://hda/tab/users/ or remove it entirely. Also the storage pooling line still exists:
***************        TBD: Initialize storage pooling ... *******************

#7 Updated by cpg about 2 years ago

  • Status changed from New to Assigned
  • Assignee set to cpg

I did not realize at the time, but I had a test HDA running in a VM and my attempts to login to my shares were, unbeknownst to me, being rejected by that other VM HDA, not my hardware HDA.

Thanks for the reports. The UI is going to be a bit of a bear.

Also available in: Atom