Project

General

Profile

Bug #2259

MariaDB error during Amahi 10 Install

Added by bigfoot65 almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
06/17/2017
Due date:
% Done:

0%


Description

Two users (forum post https://forums.amahi.org/viewtopic.php?f=9&t=6878)recently identified an issue when installing Amahi 10 with Fedora 25 Netinstall CD:

ERROR 1045 (28000): Access denied for user 'amahihda'@'localhost' (using password: YES)

I have tested and was able to reproduce the issue. I noticed today there was a MariaDB package update, which may be the cause.

Will test with the Fedora 25 DVD to see if the same issue exists.

History

#1 Updated by bigfoot65 almost 3 years ago

This appears to affect both install media, Netinstall CD and Server DVD.

#2 Updated by cpg almost 3 years ago

same as #2258. a work-around is:

dnf --allowerasing downgrade mariadb mariadb-common

prior to hda-install or after the failed hda-install.

#3 Updated by cpg almost 3 years ago

  • Assignee changed from cpg to bigfoot65

could you or someone else try this quick patch for hda-install in a fresh install?

http://alpha.amahi.org/tmp/hda-ctl-10.1.0-1.x86_64.rpm

#4 Updated by cpg almost 3 years ago

not working. trying to fix it.

#5 Updated by bigfoot65 almost 3 years ago

Got a new install ready to go.

Let me know when you're ready.

#6 Updated by cpg almost 3 years ago

ok, try again please, same url.

#7 Updated by bigfoot65 almost 3 years ago

  • Assignee changed from bigfoot65 to cpg

Looks like it worked. No error.

Updating apps affected by new password.

Recommend release to repo and close bug.

#8 Updated by cpg almost 3 years ago

  • Status changed from New to Closed

verified here as well. hda-ctl-10.1.0-1 was released to the repo.

#9 Updated by cpg almost 3 years ago

  • Status changed from Closed to Feedback
  • Assignee changed from cpg to bigfoot65

After some deliberation, we released hda-ctl-10.2.0-1 which goes back to using "hda" as the default root password in new installs.

We may have to consider a couple of things:

  • add provisions in the next hda-ctl to
    1) update the root RB for users to the "hda" default it that was not it
    2) periodically (every few hours?) check the cracklib plugin file in MariaDB in case it gets reinstalled (possibly updated too?), which will break all of Amahi
  • maybe find out who installed over the weekend and consider reaching out

Updated the wiki for root password. Please update the rest and sorry.

#10 Updated by bigfoot65 almost 3 years ago

Should I update the apps or leave the link to the wiki page?

I blanked out the root password for the 3 or 4 apps that had it.

#11 Updated by bigfoot65 almost 3 years ago

BTW it did not auto install. Had to do:

sudo dnf clean all
sudo dnf update

Then it installed along with updated Amahi Anywhere.

#12 Updated by cpg almost 3 years ago

what do you mean by "blanked out"?

leaving a link in special instructions to the wiki page is great, but if the 'hda' password was changed before in the apps, it has to be reverted.

#13 Updated by bigfoot65 almost 3 years ago

I left the initial password field blank. That way they'd have to go to the wiki page.

#14 Updated by cpg almost 3 years ago

  • Status changed from Feedback to Closed

perfect! great job

Also available in: Atom