Project

General

Profile

Bug #2315

Cannot login to http://hda for the first time. (Wooopsie)

Added by mohito6 about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
07/17/2018
Due date:
% Done:

0%


Description

"The Dashboard has encountered an exception!
Woopsie. Sorry about that!
It could be due to a bug, or very low memory, or very low disk in the root (/) partition.
If your disk or memory are not critical, it's likely a bug.
If this persists, please file a bug report with as much detail as you can.
You will be redirected to a debug page with more information shortly." 

This is the message I get when I try to log in to http://hda for the first time. I've tried a lot of things and followed some past bug reports related to this bug but the problem still remains. I'm on Amahi 10 and Fedora25. Thanks in advance.

History

#1 Updated by mohito6 about 2 years ago

  • Assignee changed from mohito6 to cpg

#2 Updated by cpg about 2 years ago

  • Project changed from hdaconnect to platform
  • Category deleted (hda-install)
  • Status changed from New to Feedback
  • Assignee changed from cpg to mohito6
  • Priority changed from High to Normal

The details of the error should be at the end of this file in the server: /var/hda/platform/html/log/production.log

or if not, in /var/log/httpd/error_log

If you can provide more details on those perhaps we can help you.

#3 Updated by mohito6 about 2 years ago

Here's the production.log

Processing by UserSessionsController#start as HTML                              
  Rendering user_sessions/start.html.slim within layouts/login                  
  Rendered user_sessions/start.html.slim within layouts/login (2.8ms)           
Completed 200 OK in 30ms (Views: 7.9ms | ActiveRecord: 2.8ms)                   
Started GET "/assets/body_bg.jpg" for 192.168.1.143 at 2018-07-17 13:32:04 +0300
Started GET "/assets/amahi-logo.png" for 192.168.1.143 at 2018-07-17 13:32:04 +0300                                                                             
Started POST "/user_sessions/initialize_system" for 192.168.1.143 at 2018-07-17 13:50:10 +0300                                                                  
Processing by UserSessionsController#initialize_system as HTML                  
  Parameters: {"utf8"=>"✓", "authenticity_token"=>
"bRXAAZkptMvkTKLinDohT8KKbfadhR3uFLoa+swNQtQ50x7xMrZSXyJb7by0zTglW+VjNmbYPTnfbB96XNs54w==", 
"username"=>"mohito6", "password"=>"[FILTERED]","password_confirmation"=>"[FILTERED]", "commit"=>"Δημιουργία"}                                                                   
Completed 500 Internal Server Error in 123ms (ActiveRecord: 73.6ms)             

ActiveRecord::StatementInvalid (Mysql2::Error: Incorrect string value: '\xCE\x95\xCE\xBE\xCF\x85...' for column 'comment' at row 1: 
INSERT INTO `servers` (`name`, `comment`, `pidfile`, `created_at`, `updated_at`) VALUES 
('smb', 'Εξυπηρετητή Αρχείων (Samba)', 'smbd.pid', '2018-07-17 10:50:11', '2018-07-17 10:50:11')):                                                                                
app/models/server.rb:37:in `create_default_servers'                             
app/controllers/user_sessions_controller.rb:119:in `initialize_default_settings'
app/controllers/user_sessions_controller.rb:103:in `initialize_system'

And the error_log

er core shutdown finished                                                       
[ 2018-07-17 13:24:15.1498 1098/7f8fa47154c0 age/Wat/WatchdogMain.cpp:1291 ]: Starting Passenger watchdog...                                                    
[ 2018-07-17 13:24:15.1711 1101/7fa260cbf4c0 age/Cor/CoreMain.cpp:982 ]: Starting Passenger core...                                                             
[ 2018-07-17 13:24:15.1713 1101/7fa260cbf4c0 age/Cor/CoreMain.cpp:235 ]: Passenger core running in multi-application mode.                                      
[ 2018-07-17 13:24:15.1736 1101/7fa260cbf4c0 age/Cor/CoreMain.cpp:732 ]: Passenger core online, PID 1101                                                        
[ 2018-07-17 13:24:15.1947 1112/7fba60fe04c0 age/Ust/UstRouterMain.cpp:529 ]: Starting Passenger UstRouter...                                                   
[ 2018-07-17 13:24:15.1959 1112/7fba60fe04c0 age/Ust/UstRouterMain.cpp:342 ]: Passenger UstRouter online, PID 1112                                              
[Tue Jul 17 13:24:15.219100 2018] [mpm_prefork:notice] [pid 952] AH00163: Apache/2.4.27 (Fedora) PHP/7.0.25 Phusion_Passenger/5.0.30 configured -- resuming normal operations                                                                   
[Tue Jul 17 13:24:15.219350 2018] [core:notice] [pid 952] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'                                                
App 1254 stdout:                                                                
App 1282 stdout:                                                                
App 1289 stdout:                                                                
[ 2018-07-17 13:36:51.2412 1101/7fa260c59700 age/Cor/CoreMain.cpp:819 ]: Checking whether to disconnect long-running connections for process 1289, application /var/hda/platform/html

#4 Updated by cpg about 2 years ago

Change to English or other Latin language to start the session. I think we have fixed this issue with Cyrillic and other locales in the next release. I think you can switch back to Greek after the initial user has been created and the dashboard is initialized

#5 Updated by mohito6 about 2 years ago

Can you give me some help on how to do that? I remember choosing English as the default language during the installation (I only selected Greek for keyboards, local time etc.)

UPDATE: I found out that the language selection is based on the broswer language. Problem solved, thanks a lot cpg!

#6 Updated by cpg about 2 years ago

  • Status changed from Feedback to Closed

Also available in: Atom