Project

General

Profile

Bug #2332

Unable to access HDA front-end - phusion passenger issue

Added by modem7 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
07/30/2018
Due date:
% Done:

100%


Description

Heya,

For some reason, I can't seem to access the hda frontend.

I get the attached message.

When I click on the link, it takes me to https://www.phusionpassenger.com

Passenger status shows:
[]$ passenger status
Phusion Passenger Standalone is not running, according to PID file /home/alex/passenger.3000.pid

Tried to run passenger status and get:
The Phusion Passenger agent is already installed.

--> Installing Nginx 1.10.1 engine
Phusion Passenger was not installed from an official release package, so you cannot download our precompiled Nginx engine.

No precompiled Nginx engine could be downloaded. Compiling it from source instead.
--> Installing Phusion Passenger Nginx module sources
Running: sudo yum install passenger-devel-5.0.30
Redirecting to '/usr/bin/dnf install passenger-devel-5.0.30' (see 'man yum2dnf')
Last metadata expiration check: 1:37:23 ago on Sun Jul 29 21:29:03 2018.
No package passenger-devel-5.0.30 available.
Error: Unable to find a match.
  • Command failed: sudo yum install passenger-devel-5.0.30

Unsure how to proceed

Capture.JPG View (61.2 KB) modem7, 07/30/2018 03:30 AM

History

#1 Updated by bigfoot65 5 months ago

  • Priority changed from Medium to Normal

Please provide what OS / Amahi version you are using.

Also if possible, the URL for:

apaste --sysinfo

#2 Updated by modem7 5 months ago

bigfoot65 wrote:

Please provide what OS / Amahi version you are using.

Also if possible, the URL for:
[...]

https://paste.fedoraproject.org/paste/AxLiSf3eIvgChf5Qt8hQoQ/

Linux localhost.localdomain 4.13.16-100.fc25.x86_64 #1 SMP Mon Nov 27 19:52:46 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Amahi 10

#3 Updated by modem7 4 months ago

  • Subject changed from Unable to access HDA front-end to Unable to access HDA front-end - phusion passenger issue

#4 Updated by modem7 4 months ago

Is there a log location which I can see what could be causing this? Unsure if it's a permissions issue or if the passenger agent just isn't loading this particular webapp.

I can see a passenger.3000.pid.lock file, but I'm unsure how best to proceed without breaking things further.

#5 Updated by cpg 4 months ago

  • Status changed from New to Feedback
  • Assignee set to modem7

yeah, touching anything related to passenger may very well break things somewhat irreversibly.

the file that would have errors is

/var/hda/platform/html/logs/production.log

and if not

/var/log/httpd/error_log

#6 Updated by modem7 4 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

cpg wrote:

yeah, touching anything related to passenger may very well break things somewhat irreversibly.

the file that would have errors is

/var/hda/platform/html/logs/production.log

and if not

/var/log/httpd/error_log

Perfect! Seeing the error log allowed me to see the issue and resolve.

Issue was with share.rb and the modifications I had made within. Hadn't realised that messing with my samba config would have had an impact upon the dashboard.

Many thanks!

Marking as resolved.

Also available in: Atom